"Set as Wallpaper" doesn't work

Bug #1314829 reported by ToZ on 2014-04-30
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ristretto
Fix Released
Medium
ristretto (Ubuntu)
Undecided
Unassigned

Bug Description

Running Xubuntu 14.04 with xfdesktop4 (4.11.6-1ubuntu1)

What happened: From within Ristretto (desktop set as Xfce in ristretto properties), I select View >> Set as Wallpaper, the desktop wallpaper doesn't change.

Expected: Desktop wallpaper will change.

Further Info: Running "xfconf-query -c xfce4-desktop -m" returns the following:

- when trying from within ristretto (doesn't work):
set: /backdrop/screen0/monitor0/image-style
set: /backdrop/screen0/monitor0/color1
set: /backdrop/screen0/monitor0/color2

- when trying from thunar (works):
set: /backdrop/screen0/monitor0/image-path
set: /backdrop/screen0/monitor0/image-style
set: /backdrop/screen0/monitorLVDS-0/workspace0/last-image

Interestingly, on my laptop, in xfconf, I have screen0 defined and 4 monitors underneath this screen:
- monitor0
- monitor1
- monitorLVDS0
- monitorLVDS1
...though I've never attached an external monitor. Laptop has an nvidia card using the proprietary nvidia driver.

Looks like the proper xfconf settings aren't being hit in this case.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ristretto 0.6.3-2ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
CurrentDesktop: XFCE
Date: Wed Apr 30 17:47:37 2014
InstallationDate: Installed on 2014-04-09 (20 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta i386 (20140325.1)
SourcePackage: ristretto
UpgradeStatus: No upgrade log present (probably fresh install)

ToZ (toz) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ristretto (Ubuntu):
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/Xfce. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

In , ToZ (toz) wrote :

In situations where there are more than one /backdrop/screen0/monitor entries, and the first entry is _not_ the valid entry, Ristretto does not change the wallpaper for that monitor property. It only affects the first entry. The end result is that the desktop wallpaper is not changed.

I have seen this in two separate scenarios:

1. Xubuntu 14.04 as a Virtualbox guest. On install, the /backdrop/screen0/monitor0 property is created. When the virtualbox additions are installed, a second property, /backdrop/screen0/monitorVBOX0 is created. The second monitor property is the active one, but Ristretto only affects the first monitor property.

2. Arch Linux install with nvidia driver. On install, the /backdrop/screen0/monitor0 property is created. When the properietary driver is installed, a second property, /backdrop/screen0/monitorLVDS0 is created. he second monitor property is the active one, but Ristretto only affects the first monitor property.

Changing the wallpaper from within xfdesktop-settings works, so that module must know which is the active monitor. That same code should probably be used here.

ToZ (toz) wrote :
Changed in ristretto:
importance: Unknown → Medium
status: Unknown → Confirmed

Created attachment 5695
Support xfdesktop >= 4.11

Currently I use this patch, in order to define new wallpaper.

Note: color1 and color2 properties are not supported.

In , ToZ (toz) wrote :

I can confirm that this patch works. Thanks.

Created attachment 5698
Update xfconf settings

Enhance previous patch:

- Use same value (stretched) for /backdrop/.../image-style
- Don't force to create /backdrop/single-workspace-mode property

Awesome, thanks! Pushed to master in:

commit eb1732c7fe84a77c5d0da935e888028fa3477c8e
Author: Olivier Duchateau <email address hidden>
Date: Tue Oct 21 19:20:45 2014 +0000

    Update xfconf settings for Xfdesktop >= 4.11
http://git.xfce.org/apps/ristretto/commit/?id=eb1732c7fe84a77c5d0da935e888028fa3477c8e

Changed in ristretto:
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1314829

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ristretto - 0.8.0-0ubuntu1

---------------
ristretto (0.8.0-0ubuntu1) vivid; urgency=medium

  * New upstream release. LP: #1424887
    - Set wallpapers in xfdesktop >= 4.11. LP: #1314829
  * Track all releases in debian/watch
  * Drop git patch, fixed upstream
 -- Jackson Doak <email address hidden> Sun, 01 Mar 2015 07:32:29 +1100

Changed in ristretto (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.