Ubuntu

No Settings are available in "Preferred format", only preset defaults are used

Reported by Doug McMahon on 2012-03-04
248
This bug affects 52 people
Affects Status Importance Assigned to Milestone
GStreamer
Incomplete
Wishlist
rhythmbox (Ubuntu)
High
Unassigned
Precise
High
Iain Lane
transmageddon (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

= Transmageddon =

[ Description ]

Transmageddon ships gstreamer preset files in a shared directory, /usr/share/gstreamer-0.10/presets. As these presets have fixed names, this is unhelpful. An upstream commit included in 0.21 moves these to a private location.

[ Development fix ]

Fixed in Quantal in an identical way.

[ Regression potential ]

If the fix doesn't work then it's possible that transmageddon won't be able to find its presets and will not be able to encode anything.

[ Testing ]

There should be no functional difference. Test with both the old and new transmageddon that you can still transcode some videos using a variety of settings, and that the settings you choose are the ones which are pplied.

= Rhythmbox =

[ Description ]

No encoding preset is shipped with Rhythmbox, meaning that subpar defaults for encoding are selected.

[ Development Fix ]

Quantal's Rhythmbox has support for custom encoding settings. There, we've shipped the same set of "ubuntu-default" presets, but have set the default (in rhythmbox.gep) to use the user's selected custom settings.

[ SRU fix notes ]

We Break and Replace old transmageddons, which have a file conflict with this version.

** Thus, the Rhythmbox SRU MUST NOT be accepted, both into -proposed and -updates, without the transmageddon one. Otherwise we will introduce upgrade failures. **

[ Regression potential ]

Perhaps the new settings will fail to apply and Rhythmbox will pick up a worse set than it had before.

[ Testing ]

Rip a CD with the new Rhythmbox with the default settings and determine that the quality and other encoder parameters are what they should be.

[ Original Description ]

This has been going on since 11.10 dev, maybe should be addressed

In Edit > Preferences, on the Music tab the Settings button for Preferred Format is greyed out & unavailable. So there is no user available means to adjust encoding for vorbis, mp3, mp4, ect.
Even using something like sound-juicer to change the very same 'Preferred.. ' is of no use, Rhythmbox doesn't use.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: rhythmbox 2.95-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Sat Mar 3 19:25:18 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120302)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Ewano (i-launchpad-ewano-net) wrote :

Testing 12.04 beta I tried to rip a CD (Helb Alpert - he's the king right?) and found that it seems to only be encoding at 32kb/s by default.

test@precisepangolin:~/Music/Herb Alpert/Definitive Hits$ mpg321 -t 01\ -\ The\ Lonely\ Bull.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.2.13-4 (2011/09/29). Written and copyrights by Joe Drew,
now maintained by Nanakos Chrysostomos and others.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!
Title : The Lonely Bull Artist : Herb Alpert
Album : Definitive Hits Year : 2001
Comment : Genre : Unknown

Playing MPEG stream from 01 - The Lonely Bull.mp3 ...
MPEG 1.0 layer III, 32 kbit/s, 44100 Hz joint-stereo

[2:17] Decoding of 01 - The Lonely Bull.mp3 finished.

I played the file using VLC and found the codec info agrees with this stating 32kb/s - however when looking at the statistics the bitrate seems to be fluctuating which makes me think that the default settings are for very low quality VBR.

Anyone know where Rhythmbox stores it's settings for calling the encoder (gstreamer?) these days? I've been playing about with rhythmbox.gep, but it's not particularly well documented..

Conor Curran (cjcurran) on 2012-04-17
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Conor Curran (cjcurran) on 2012-04-17
Changed in rhythmbox (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → High
Conor Curran (cjcurran) wrote :

I talked with Jonathan today about this.
Currently the only way to get rhythmbox to use a new lame preset, is to first create the preset.
In python this looks like something like:

import gst;

l = gst.element_factory_make("lamemp3enc");
l.props.quality = 2.0;
l.save_preset("precise-defaults")

This will create the preset in ~/.gstreamer-1.0/presets/GstLameMP3Enc.prs

We will need to ship the preset so it ends up /usr/share/gstreamer-0.10/presets/ and reference it's name in the rhythmbox.gep.

Attached you will find the preset and the updated rhythmbox.gep which references this preset.

Changed in rhythmbox (Ubuntu):
status: Triaged → In Progress
Conor Curran (cjcurran) wrote :

And the gep file to be shipped so as the default player uses our new Lame preset.

Doug McMahon (mc3man) wrote :

So just for info, if or when you have a moment I'm sure it will become apparent when it ships -
The user will have a choice of some presets, somewhat similar to how soundconverter works , (descriptive presets, I believe 6
And - there are still some apps (third party), that use the gst profiles pipelines in gconf, are those profiles due to be removed?

Conor Curran (cjcurran) wrote :

The encoder name is the preset is incorrect. Please use this one.

Conor Curran (cjcurran) wrote :

I still though have 'Additional software needed...' when i select the mp3 preset ?

On 04/20/2012 02:03 PM, Conor Curran wrote:
> I still though have 'Additional software needed...' when i select the
> mp3 preset ?
>
See the same thing

Doug McMahon (mc3man) wrote :

Got this to work but have to go out so the location of the preset I'll check later
In comment 4 you said "~/.gstreamer-1.0/presets/" which doesn't exist, created but then decided to delete & to put in ~/.gstreamer-0.10/presets/ & also left loose in ~/.gstreamer-0.10.
I think the preset folder is where to go

As far as the .gep & the preset name - got rid of "12:04-default" & just went with a plain word, doesn't really matter what , used
high (no quotes)
Also adjust the name in the .psr
That stopped RB from complaining about missing decoder -

Ran some test encodes of same track altering the quality= in the .psr, (used 2,0 & 6) & results where as expected, could be a little adjustment could be done to the preset as it currently is, for the most part good (been a while since I've used mp3

Conor Curran (cjcurran) wrote :

It was the quotes in the gep, please use this gep instead. Silly me.

Conor Curran (cjcurran) wrote :

Doug,
You beat me to it :)
So what would you recommend for a vbr setting ? Right now it's on 2. Which I would hope averages out at around 190 +.

Doug McMahon (mc3man) wrote :

I think the quality=2 is just fine, should avg. around 192
Plus users can adjust if inclined to explore a bit

Possibly someone who uses/knows mp3 well could better advise but I'd be inclined to set the bitrate= line to either 96 or even 64
IIRC in VBR it just sets the absolute lower limit, so leaving down a bit gives VBR some room to do it's thing

Doug McMahon (mc3man) wrote :

Just to add- don't know what the final on this is but a little fooling shows that adding a Profile is pretty straight up - so if there are complaints about no choice I'll just advise users as either editing the .psr as needed or even adding an additional profile or 2

screen is a "low" profile quality@ 6, br@ 32

Doug McMahon (mc3man) wrote :

just to mention -
gnome has set the default quality of ogg vorbis to 0.3 (avg. 112) from the previous of 0.5 (avg 160

So it would be nice if that could get a preset also
Have tried - cannot see how, all attempts lead to the 'Additional software needed...'
Using the info from gst-inspect vorbisenc but no go?

Doug McMahon (mc3man) wrote :

vorbis is working fine here now from a preset - stupid mistake, was naming the file with a .psr instead of .prs
(GstVorbisEnc.prs

Conor Curran (cjcurran) wrote :

Thanks Doug,
Seb can we package this vorbis preset also as part of that SRU ?

Doug McMahon (mc3man) wrote :

Just to note - sound-juicer is also using the same deal, it actually has a rhythmbox.gep in /usr/share/sound-juicer/
So it can use the very same .prs's as RB, it just needs the preset=line(s) in it's included rhythmbox.geb
(should this be a new bug or can S-J be marked as affected or too late??

Conor Curran (cjcurran) wrote :

Doug can you attach the vorbis preset ?

Doug McMahon (mc3man) wrote :

Sure - everything but the quality= represents defaults as seen in gst-inspect. Have q @ 6 which represents about a 192 avg.
The previous default was 5, current is 3
Seems to give consistent times checking with various players (vlc, audacious, totem, RB

As far as the mp3 preset I get better time results acroos all players with perfect-timestamp=true

And again, if possible. it seems soundconverter just copies & includes the current rhythmbox.geb which obviously is lacking the preset= line for mp3, vorbis, ect.

Conor Curran (cjcurran) wrote :

Thanks Doug.

Here is the bug upstream.

https://bugzilla.gnome.org/show_bug.cgi?id=675477

affects: rhythmbox → gstreamer
Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → New
Changed in gstreamer:
status: New → Incomplete
Jesse Avilés (notbitmonk) wrote :

I tried to follow your solution and was not able to reproduce it. I have a FLAC file that I transcode to ogg using Rhythmbox. I did not change the rhythmbox.gep. In ~/.gstreamer-0.10 I dropped the GstVorbisEnc.prs Doug McMahon. I also created a "presets" folder and placed a copy GstVorbisEnc.prs. I tried it three times. The first two times, only one copy of the GstVorbisEnc.prs existed at one of the previous location. The third time I placed a copy at both locations. I opened up Rhythmbox, transcoded the file and looked at its metadata. The bit rate was always 112. In previous versions (10.04), whatever setting I had in the ogg preset was used to transcode to ogg.
I then compared the Rhythmbox.gep file in here and the default one. There were no changes to the ogg vorbis section. This is a workaround that I want to function. Still, the bug is not resolved as the settings button is grayed out and no changes to encoding quality can be made through the GUI.

Doug McMahon (mc3man) wrote :

@Jesse Avilés -
You must edit the rhythmbox.gep file & add a preset= line in oggvorbis section - not really the place here to provide support
see here for how to, any questions ask in that thread
http://ubuntuforums.org/showpost.php?p=11874076&postcount=7

Doug McMahon (mc3man) wrote :

Note - this was fixed in rhythmbox ( 2.97-0ubuntu1) in 12.10, consideration to adding to 12.04 should be given
 2.97-0ubuntu1 source should be a fairly easy build in 12.04

terakin (terakinizers) wrote :

I confirmed this phenomena on 12.04 amd64. The preference button at Sound Juicer does not appear. I tried some workaround introduced on the Net (such as https://bugzilla.redhat.com/show_bug.cgi?id=713721 ) but the thing did not go better. Very curiously, another software, goobox (I had to install this because of profile selection) seems working, appearing profile selection button and selection itself.

Doug McMahon (mc3man) wrote :

Everything is in place in RB 2.97 for the use of 'custom settings' in RB except there is no
preset=rhythmbox-custom-settings
in /usr/share/rhythmbox/rhythmbox.gep

Seriously don't get it - like pulling a tigers tooth to get something simple done.

Doug McMahon (mc3man) on 2012-06-21
tags: added: quantal
ed10vi (ed10vi86) wrote :

How could I use xingmux with the described method for rhythmbox 2.96?

Bryce Harrington (bryce) on 2012-07-23
description: updated
Jean-Rene Bastien (jrbastien) wrote :

The question from ed10vi86 is important. Without xingmux, all variable rate mp3 created without xingmux will report an incorrect lenght. We used to be able to specify the xingmux option in the pipeline string in the previous version.

Éric Piel (pieleric) wrote :

I confirm that the mp3 encoded have the wrong length computed. Xingmux is missing. This used to be the working pipeline:
audio/x-raw-int,rate=44100,channels=2 ! lamemp3enc name=enc target=0 quality=6 ! xingmux ! id3v2mux

If someone could put it again, that'd be great.

Changed in rhythmbox (Ubuntu):
assignee: Conor Curran (cjcurran) → Iain Lane (laney)
Changed in rhythmbox (Ubuntu Precise):
assignee: nobody → Iain Lane (laney)
importance: Undecided → High
status: New → Confirmed
Iain Lane (laney) wrote :

So I'm looking at patching this for Q and P now. I have some questions/confusion that hopefully you can help me out with

Precise doesn't have the custom settings code at all, right? So what I'll do here is to add the new LAME and vorbis profiles and modify the .gep to use those. So there the defaults will be better, but still won't be customisable.

For Quantal I'll upload a fix to use the rhythmbox-custom-settings preset.

Am I understanding this right?

Iain Lane (laney) wrote :

Bah, looks like transmageddon ships these files with different settings.

Iain Lane (laney) wrote :

But it has http://git.gnome.org/browse/transmageddon/commit/?id=5a25dfee615dbf5fa33d5b456ec54468a81bb362 which we can probably SRU to make the conflict go away.

Iain Lane (laney) on 2012-07-30
Changed in transmageddon (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmageddon - 0.20-1ubuntu2

---------------
transmageddon (0.20-1ubuntu2) quantal; urgency=low

  * Backport upstream commit 5a25dfee to use a transmageddon specific
    directory for the presets. (LP: #945987)
  * Revert changes from previous upload which aren't necessary now that there
    will be no file conflict.
 -- Iain Lane <email address hidden> Mon, 30 Jul 2012 17:15:29 +0100

Changed in transmageddon (Ubuntu):
status: New → Fix Released
Doug McMahon (mc3man) wrote :

Is there any way that users encoding to mp3 can get xingmux, it appears to me it's a different plugin/element than GstLameMP3Enc so don't see how it can be in the preset itself?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.97-1ubuntu3

---------------
rhythmbox (2.97-1ubuntu3) quantal; urgency=low

  [ Sebastien Bacher ]
  * debian/patches/09_keywords.patch:
    - backport upstream patch to set keywords in the desktop entry,
      it makes easier to find totem in the unity dash or gnome-shell
      (lp: #1029964)

  [ Iain Lane ]
  * debian/*.prs, debian/patches/10_encoding_use_ubuntu_profiles.patch: Add an
    OGG and MP3 preset with improved defaults to use when encoding. Patch
    rhythmbox.gep to work with user-supplied custom settings (LP: #945987)
  * debian/patches/dont_free_consumed_floating_gvariant.patch: Take patch from
    upstream bug#680842 (by Ryan Lortie) to not crash when opening preferences
    dialog by trying to free an already consumed value. (LP: #1030295)
  * Add Breaks and Replaces on versions of transmageddon which shipped the
    .prs files we are now shipping in -data.
 -- Iain Lane <email address hidden> Mon, 30 Jul 2012 17:46:42 +0100

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Released
Iain Lane (laney) wrote :

I'm not sure; I don't see how to do it myself. If someone wants to investigate how we go about doing that then I'm happy to include it in a separate upload, but for now let's take care of just this issue.

Iain Lane (laney) on 2012-07-30
description: updated
Doug McMahon (mc3man) wrote :

On 07/30/2012 02:06 PM, Iain Lane wrote:
> I'm not sure; I don't see how to do it myself. If someone wants to
> investigate how we go about doing that then I'm happy to include it in a
> separate upload, but for now let's take care of just this issue.
>
Sounds reasonable -
It may be that a bug should be filed with gstreamer, though what plugin
not sure, xingmux shows in both the good & bad.
Though considering the current lack of attention in Debian/Ubuntu to
the .10 branch of gstreamer plugins it won't be me filing a new one
upstream.

Iain Lane (laney) on 2012-07-30
description: updated
Changed in transmageddon (Ubuntu Precise):
status: In Progress → Triaged
Changed in rhythmbox (Ubuntu Precise):
status: Confirmed → In Progress
James M. Leddy (jm-leddy) wrote :

Hi Doug, or anyone else,

Would you please review the merge request here? I'd like to get this into precise because it is blocking another gstreamer bug causing cheese to hog cpu, especially on low power devices. The merge request is here:

https://code.launchpad.net/~jm-leddy/ubuntu/precise/transmageddon/movepresets/+merge/117478

Doug McMahon (mc3man) wrote :

As far as I can tell, (& I've never used transmageddon before), the new package in 12.10 is broken & will not transcode anything.

"$ transmageddon
Traceback (most recent call last):
  File "transmageddon.py", line 863, in on_transcodebutton_clicked
    self._start_transcoding()
  File "transmageddon.py", line 736, in _start_transcoding
    self.videopasstoggle, self.interlaced, self.inputvideocaps)
  File "/usr/share/transmageddon/transcoder_engine.py", line 60, in __init__
    Gst.preset_set_app_dir("/usr/share/transmageddon/presets/")
NameError: global name 'Gst' is not defined "

If I were to purge RB* & install the previous transmageddon then it appears to work fine in a limited test.
Does that need a new bug or is this break known & or expected?

Doug McMahon (mc3man) wrote :

Seems like it should be a new one
Bug 1031439

Hello Doug, or anyone else affected,

Accepted transmageddon into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/transmageddon/0.20-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in transmageddon (Ubuntu):
importance: Undecided → High
Changed in transmageddon (Ubuntu Precise):
importance: Undecided → High
status: Triaged → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

I'd call this a fail just like in 12.10 due to Bug 1031439
Atm transmageddon does work in 12.10 when adjusted per the above bug report & with a patched gst-python, at least with-in the limitations of current bad plugin

tags: added: verification-failed
removed: verification-needed
Doug McMahon (mc3man) wrote :

Just to fill out - in 12.04 adjusting transcoder_engine.py line 60 to
 gst.preset_set_app_dir("/usr/share/transmageddon/presets/")
& providing a patched gst0.10-python, (gst/gst.defs), allows transmageddon to again transcode most files, exceptions noted ad nauseum elsewhere...

Iain Lane (laney) wrote :

A new transmageddon is in the queue. It should go in no earlier than gst0.10-python (bug #1031439). Preferably at the same time; the versioned dep should keep everything in line.

Iain Lane (laney) on 2012-08-07
Changed in transmageddon (Ubuntu Precise):
status: Fix Committed → In Progress
Iain Lane (laney) on 2012-08-07
tags: removed: verification-failed
Bryce Harrington (bryce) wrote :

Not sure from comment #42 why this failed verification, but as there is at the moment nothing further to be sponsored, I'm unsubbing sponsors for now.

On 08/16/2012 03:43 PM, Bryce Harrington wrote:
> Not sure from comment #42 why this failed verification, but as there is
> at the moment nothing further to be sponsored, I'm unsubbing sponsors
> for now.
>
Verification was asked on transmageddon in proposed, (comment 41
. It was a fail because the proposed transmageddon package failed to
encode anything
https://bugs.launchpad.net/ubuntu/+source/transmageddon/+bug/1031439

James M. Leddy (jm-leddy) wrote :

The new gst0.10-python is in now, so we should be able to verify this time.

James M. Leddy (jm-leddy) wrote :

By "in", I mean in -proposed.

Doug McMahon (mc3man) wrote :

Not sure what needs verification here
To recap from here -
All is fine in 12.10 - python-gst0.10 (0.10.22-3ubuntu1, transmageddon (0.21-1), RB

As far as precise - with the new gst0.10-python (0.10.22-3ubuntu0.1, - what version of transmageddon??
The previous upload to proposed is gone & was no good anyway (used Gst

The only avail. transmageddon in precise now is 0.20-1 which works because it uses the gstreamer presets
As mentioned in comment 43, taking the previously proposed transmageddon 0.20-1ubuntu0.1 & editing Gst to gst then all is fine in 12.04 as far as transmageddon

Is there a redone transmageddon for precise?

Hello Doug, or anyone else affected,

Accepted rhythmbox into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/rhythmbox/2.96-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rhythmbox (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in transmageddon (Ubuntu Precise):
status: In Progress → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Doug, or anyone else affected,

Accepted transmageddon into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/transmageddon/0.20-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Doug McMahon (mc3man) wrote :

Well it's fixed in transmageddon
I'm not sure how this can be considered fixed in precise when there is no option in RB to alter the settings,
So a ~/gstreamer-0.10/presets is created but it's empty & there is no custion settings available in RB like in 12.10 (which has been screwed up again, next comment

Doug McMahon (mc3man) wrote :

Re-opening RB or should I file a new one ?

In 12.10 you all are now providing a rhythmbox.gep & 2 presets that are incompatible.
The effect of this is both mp3 & ogg encoding are unavailable & a "Install additional software required to use this format" box appears.
Clicking it will be to no avail., when a preset is wrong the box appears & will not go away until the preset or .gep is corrected.

The 2 .prs's supplied have this as the name - (in /usr/share/gstreamer-0.10/presets
[ubuntu-default]

The rhythmbox.gep has this -
preset = rhythmbox-custom-settings

So they need to be the same, pick one or the other

Changed in rhythmbox (Ubuntu):
status: Fix Released → New
status: New → Confirmed
Iain Lane (laney) wrote :

(precise-amd64)root@iota:/home/laney/temp# grep ubuntu-default /usr/share/gstreamer-0.10/presets/*
/usr/share/gstreamer-0.10/presets/GstLameMP3Enc.prs:[ubuntu-default]
/usr/share/gstreamer-0.10/presets/GstVorbisEnc.prs:[ubuntu-default]
(precise-amd64)root@iota:/home/laney/temp# grep ubuntu-default /usr/share/rhythmbox/rhythmbox.gep
preset = ubuntu-default
preset = ubuntu-default

I don't understand.

Since you seem to understand the issue which clearly nobody else does then I suggest you provide a patch, lest we "screw it up" again.

Doug McMahon (mc3man) wrote :

Will apologize for the comment - not really meant as written & will say the reason it doesn't work 'smoothly' OOTB in 12.10 is for a different reason than I thought.

When a user first opens RB > Edit > Prefs> Music, ~/.gstreamerr-0.10/presets is created without any .prs in it.
This causes the dialog about needing to install additional software which if clicked on for ogg will return a not found & the dialog will remain
For mp3 it will install, * again the dialog will still be there.

Only when a valid .psr is in ~/.gstreamerr-0.10/presets will the add. software dialog go away.
This will occur if the settings dropdown is expanded & Custom settings is chosen, it won't if Default or default is chosen

So maybe not a big issue because sooner or later the user will pick Custom settings from the dropdown & a .prs will be created in the plugins folder & the dialog will go away.

The 2 ways around if this was considered an issue would be to have ~/.gstreamerr-0.10/presets receive a .prswhen created or not have it be created until Custom settings is chosen.

James M. Leddy (jm-leddy) wrote :

Doug, this sounds like an entirely different issue. Would you explain what this has to do with transmageddon moving it's presets files? Especially when most default installations have rhythmbox installed but not transmageddon?

Hi James,

On Wed, Sep 05, 2012 at 03:34:50PM -0000, James M. Leddy wrote:
> Doug, this sounds like an entirely different issue. Would you explain
> what this has to do with transmageddon moving it's presets files?
> Especially when most default installations have rhythmbox installed but
> not transmageddon?

This bug is about rhythmbox mainly; it's just linked into the
transmageddon and other SRUs by shared files and other shuffling that's
required. I think a further /code/ patch to RB is needed to implement
the behaviour Doug described (very clearly, thank you) in #55. But I do
not think this necessarily needs to fail this SRU?

Happy for it to do so and for RB to fall out again if you think it's
critical for the issue to be properly fixed (and that the 12.04 released
version is better in this respect than the proposed one), but I don't
plan on working on such a patch myself.

I think the transmageddon and python-gst0.10 parts are fine and can go
in independently of the rhythmbox part.

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

James M. Leddy (jm-leddy) wrote :

Thanks for the explaination, I was getting confused there :)

I hate to say it but I think we may need to open anther bug to track the original RB issue. The problem is, this has now been looped in with the transmageddon fix, and this bug is now blocking a cheese bug 981803 that is only semi-related. I can make it easier by opening another rhythmbox bug. Does everyone agree that's the right thing to do?

Doug McMahon (mc3man) wrote :

I would think so except - for which RB? (& possibly what bug?

The bug is fixed in 12.10 with the small exception that until a user actually picks a Custom setting they will get confusing & possibly incorrect info.

As far as 12.04 it may be committed fixed to the extent that anyone intends to fix. A ubuntu-default preset is in place but because RB in 12.04 doesn't expose that Custom setting menu it's up to the user to create a .prs in ~/.gstreamerr-0.10/presets

Additionally there could be a 12.10 bug on whether it should of gotten the 12.04 fix, (ubuntu-default), along with the RB fix of Custom Settings. Atm it doesn't look like having both presets avail. & in ~/.gstreamerr-0.10/presets/ causes any problems, if so that'll be a new bug

In any event transmageddon is ok here now.

Iain Lane (laney) on 2012-09-17
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmageddon - 0.20-1ubuntu0.2

---------------
transmageddon (0.20-1ubuntu0.2) precise-proposed; urgency=low

  * Use correct variable name 'gst' instead of 'Gst', resolving failure to
    transcode.
  * Version python-gst0.10 dep to ensure we get the version which first
    exposed preset_set_app_dir which we require to change the preset path.

transmageddon (0.20-1ubuntu0.1) precise-proposed; urgency=low

  * Backport upstream commit 5a25dfee to use a transmageddon specific
    directory for the presets. (LP: #945987)
 -- Iain Lane <email address hidden> Sun, 05 Aug 2012 23:01:07 +0100

Changed in transmageddon (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.96-0ubuntu4.2

---------------
rhythmbox (2.96-0ubuntu4.2) precise-proposed; urgency=low

  * debian/*.prs, debian/patches/10_encoding_use_ubuntu_profiles.patch: Add an
    OGG and MP3 preset with improved defaults to use when encoding. Patch
    rhythmbox.gep to work with user-supplied custom settings (LP: #945987)
  * Add Breaks and Replaces on versions of transmageddon which shipped the
    .prs files we are now shipping in -data.

  [ Sebastien Bacher ]
  * debian/patches/09_keywords.patch:
    - backport upstream patch to set keywords in the desktop entry,
      it makes easier to find rhythmbox in the unity dash or gnome-shell
      (lp: #1029964)
 -- Iain Lane <email address hidden> Mon, 30 Jul 2012 18:03:50 +0100

Changed in rhythmbox (Ubuntu Precise):
status: Fix Committed → Fix Released
Simon Butcher (sbutcher) wrote :

I upgraded to 2.96-0ubuntu4.2 on precise but still suffer with the problem where i cannot modify (or even view) the mp3 settings.
I thought "patch rhythmbox.gep to work with user-supplied custom settings" would enable settings via the GUI when using mp3 format?

On 09/23/2012 01:16 PM, Simon Butcher wrote:
> I upgraded to 2.96-0ubuntu4.2 on precise but still suffer with the problem where i cannot modify (or even view) the mp3 settings.
> I thought "patch rhythmbox.gep to work with user-supplied custom settings" would enable settings via the GUI when using mp3 format?
>
Simon - generally LP isn't for support but seeing as how convoluted this
report became a short explain.
The fix in 12.04 with RB 2.96 is just to provide 2 new presets to
override the default gnome ones which produced low quality encodes for
.mp3 & .ogg

You can see them in /usr/share/gstreamer-0.10/presets & if desired can
adjust using available gstreamer options
Or you can re-create the above locally in your home folder
(~/.gstreamer-0.10/presets/GstLameMP3Enc.prs ,
~/.gstreamer-0.10/presets/GstVorbisEnc.prs & edit the .prs as desired
using available gstreamer options as seen in gst-inspect lamemp3enc ,
gst-inspect vorbisenc

The fix for 12.10, RB 2.97 _additionally_ added a gui 'Custom Settings'
that will create ~/.gstreamer-0.10/presets/* & adjust the quality option
as specified thru the gui

Changed in gstreamer:
importance: Medium → Wishlist
Ekimia (u-contact-ekimia-fr) wrote :

Sorry but When and how the fix for rhythmbox was released ?
Please clean up the description field

Vivien GUEANT (vivienfr) wrote :

The bug is present with Ubuntu 13.04 (Raring Ringtail) AMD 64 when using Sound Juicer : The preference button at Sound Juicer does not appear.

Pocio (marco-sting) wrote :

xingmux semmes to be stille needed, but I don't know how to add it.

Pocio (marco-sting) wrote :

xingmux seems to be still needed, but I don't know how to add it.

(sorry for the previous wrong message)

Iain Lane (laney) wrote :

Unassigning myself, anyone else feel free to work on any remaining issues for this bug.

Changed in rhythmbox (Ubuntu):
assignee: Iain Lane (laney) → nobody
amias (amias) wrote :

raring ringtail is still attempting to rip cd's at 11khz which might ok if you are listening to herb alpert (probably makes it more interesting) but if you are listening to anything made in the last 20 years (i.e electronic music with a huge dynamic range like say Reso , Noisia or Frederick Robinson) its annoying.

Can we not just have a dialog pop up when you first try ripping that asks you which settings you want to use ?

Cheers
Amias

Sebastien Bacher (seb128) wrote :

Sorry that got ignored for all that long, I've renamed the profiles as Doug suggested in comment #53, closing that bug since I used bug #1086806 in the changelog and they are duplicate. Now we just need to tweak the gsettings key to make the Ubuntu profiles default

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.