Can't remove Last.fm / Libre.fm radio

Bug #921688 reported by Pierre Rudloff on 2012-01-25
84
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Undecided
Unassigned

Bug Description

I can add Last.fm radios using the Last.fm plugin, but there is no way to remove them.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rhythmbox-plugins 2.90.1~20110908-0ubuntu1.2
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Jan 25 18:18:48 2012
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Pierre Rudloff (rudloff) wrote :
Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?
we use software center find it and remove it from there.
are you talking about to remove the plugin or remove the last fm?
This will help us to find and resolve the problem.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Pierre Rudloff (rudloff) wrote :

I am talking about the Last.fm playlists ("radios" that you can create by going into Library (left pane) > Last.fm, enter some artist name in the "Similar to Artist" field and then click on "Create Station".
Then it adds a playlist/radio under Last.fm in the library pane but :
- You can't right click on it.
- Edit > Remove is disabled
- Backspace does nothing

jerico (jerico-dev) wrote :

Changed to "Confirmed" - may be a feature request, though.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
jerico (jerico-dev) wrote :

Workaround: Editing /home/[your linux user]/.local/share/rhythmbox/audioscrobbler/stations/Last.fm/[your last.fm user] manually solves the problem for me.

Bence Lukács (lukacs-bence1) wrote :

This bug still exist in 12.04.
Rhythmbox version: 2.95-0ubuntu2

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New
Miguel Ramiro (mike.longbow) wrote :

Confirmed in Rhythmbox 2.96 on Ubuntu 12.04. There is no way to remove those entries aside from manually deleting them from the file jerico pointed at.

Also, thanks for the tip, jerico.

Confirmed in Rhythmbox 2.98 on Xubuntu 12.10.

JobIgen (jobigenvamdrup) wrote :

I think this should be filed as a feature request. I agree on the priority though.

summary: - Can't remove Last.fm radio
+ Can't remove Last.fm / Libre.fm radio

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox:
importance: Medium → Undecided
status: New → Invalid
Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
DistroRelease: Ubuntu 13.10
InstallationDate: Installed on 2013-10-02 (194 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
NonfreeKernelModules: nvidia
Package: rhythmbox 2.99.1-0ubuntu1 [origin: unknown]
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.8.0-31.46-generic 3.8.13.8
Tags: third-party-packages saucy
Uname: Linux 3.8.0-31-generic x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: Upgraded to saucy on 2014-04-12 (2 days ago)
UserGroups: adm lpadmin sambashare sudo vboxusers

tags: added: apport-collected saucy third-party-packages

apport information

apport information

apport information

apport information

apport information

Thanks el-gallo-azul for your info. It would be great if you could try to see if this can be reproduced with Ubuntu 14.04. It's being released this week, so as soon as you can verify if the problem is still present in 14.04, which brings Rhythmbox 3.0.2, we can update this report.

el_gallo_azul (el-gallo-azul) wrote :

I look forward to 14.04 coming out. I have found a number of things that stopped working a few days ago when I went from 13.04 to 13.10, and hopefully they will start working again with 14.04.

Dabian (dabian) wrote :

If this bug persist, I am pretty sure it is an upstream issue.

dino99 (9d9) wrote :

This version has expired

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
JobIgen (jobigenvamdrup) wrote :

I suspect it might be an upstream issue, however, it is still a bug, if it has not been fixed meanwhile. At least we have the workaround now.

Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.