3rd Party Plugins Ignored

Bug #878352 reported by Matthew Woerly on 2011-10-19
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

For some reason, after upgrading to Oneiric, Rhythmbox no longer shows any third party plugins. I have tried putting them in many locations. Both of these plugins are ignored. Remuco is even in the Ubuntu repos and does not work.
Rhythmweb/Rhythmote
Remuco

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rhythmbox 2.90.1~20110908-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 19 12:06:50 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to oneiric on 2011-09-28 (21 days ago)

Matthew Woerly (nattgew) wrote :
Pedro Villavicencio (pedro) wrote :

anything on the command line? could you paste the output you get there? thanks.

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Matthew Woerly (nattgew) wrote :

Nothing on normal command line.
Here's output with the debug flag. It seems to search and find the regular plugins fine, nothing about the 3rd party ones in there that I can find.

Tsjoecha (driesfeys) wrote :

I have the same issue on 2 different laptops.

I did an upgrade to ubuntu 11.10 on both of them, both have remuco installed as a package, but the package is not visible between my plugins in rhythmbox.

I found however the cause : where before the plugins had to be identified as a .rb-plugin file with a [RB PLUGIN], this now has to be a .plugin file with a [PLUGIN] section. I renamed the thing, and the plugin is recognised.

I don't know whether this is an unannounced change in the RB behaviour, rather than an errouneous feature-change.

Tsjoecha (driesfeys) wrote :

Unfortenately, I get a forbidden sign when trying to enable the plugin. I don't have time today to look further (logging level etc), but at least, there is a way...

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Could you please get a rhythmbox debug log? please run rhythmbox as : rhythmbox --debug &> rhythmbox-debug.txt ; reproduce the issue and attach that resulting log file to the report, Thanks ina dvance.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Si Dedman (si-dedman) wrote :

Have you tried only installing those for RB version 3? I find that they install and are present in the presets list, although not all of them work.

Tsjoecha (driesfeys) wrote :

Unfortenately I uninstalled RB, as I really needed remuco. I switched to Exaile. Sorry.

Matthew Woerly (nattgew) wrote :

I did a clean install and moved my config over, same thing happens.
Si Dedman, where could I find that version of RB?

Si Dedman (si-dedman) wrote :

It's deceptive. Unless i'm very much mistaken (open invitation to anyone wiser to step in here!), v 2.90.1 which comes bundled with ubuntu 11.10 IS v3. And the version before 2.90.1 aka 3 is v 0.##.##. This [bizarre situation] is how i understand things based on researching today.

So Matt, if you fire up RB, play a track, quit, reopen, hopefully the track's not playing. Assuming not, follow the steps to install the rhythmbox remember (name is wrong, but it's similar) plugin, from the v3 list, then repeat the steps after selecting the plugin from the menu. That *should* work. I can't vouch for the others.

BasileD (khivan-dufay) wrote :

I have the same issue as Tsjoecha (driesfeys) described.

It seems to be related to this bug report on remuco website:
http://code.google.com/p/remuco/issues/detail?id=177&can=1&q=11.10&colspec=ID%20Type%20Status%20Component%20Stars%20Summary
Even if its about the remuco totem plugin.

Relevant part of the "rhythmbox --debug" output is:
......
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/remuco/remythm.py", line 30, in <module>
    import rb, rhythmdb
ImportError: No module named rhythmdb

(rhythmbox:13876): libpeas-WARNING **: Error loading plugin 'remythm'
..........
Hope this will help.

Matthew Woerly (nattgew) wrote :

I looked in my log and could not find anything like the error described. I can look at a more recent log and check, but it doesn't look like the same thing...

dirk (dirk-janssen) wrote :

same problem here, remuco-rhythmbox worked fine on natty, now broken on oneiric. I renamed the file to .plugin as indicated above by driesfeys, also renamed the section. You can then see the plugin, but not enable it because checking its box will crash it. I get this on the stdout:

$ rhythmbox
[ stuff about my media keys which is not relevant]
[ upon clicking the checkbox, this appears: ]
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/remuco3/remythm.py", line 30, in <module>
    import rb, rhythmdb
ImportError: No module named rhythmdb

(rhythmbox:3541): libpeas-WARNING **: Error loading plugin 'remythm'

I provided a full debug log, but it basically contains the same info.

fossfreedom (fossfreedom) wrote :

To all,
  Rhythmbox 2.9x has moved to GTK3 and thus all the API's have also changed.

The plugins need to be recoded.

Many have - I would recommend the gnome-third party plugin website

 - https://live.gnome.org/RhythmboxPlugins/ThirdParty

Alternatively this Ask Ubuntu question.

 - http://askubuntu.com/questions/147942/how-do-i-install-third-party-rhythmbox-plugins

As such, I would recommend closure of this bug report due to the reasons above.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.