rhythmbox-client is missing

Bug #875064 reported by Jean-Philippe Guérard on 2011-10-15
This bug affects 12 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)

Bug Description

The rhythmbox-client has a man page, but is not in the rhythmbox package.

$ dpkg -L rhythmbox | grep rhythmbox-client

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rhythmbox 2.90.1~20110908-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Oct 15 16:37:24 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release i386 (20110426.1)
 PATH=(custom, user)
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (0 days ago)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that is fixed in upstream git:

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
obadz (obadz) wrote :

Not sure when we'll see the fixed package come out in oneiric but until then, one solution is to pin rhythmbox back to the natty version:

To do so, create the file /etc/apt/preferences.d/rhythmbox-pin containing:

Package: rhythmbox
Pin: release n=natty
Pin-Priority: 1001

Then copy /etc/apt/sources.list to /etc/apt/sources.list.d/sources-natty.list replacing all occurrences of 'oneiric' by 'natty'


sudo apt-get update # if there are errors, comment out the appropriate lines in sources-natty.list
sudo apt-get --purge remove rhythmbox
sudo apt-get --purge autoremove
sudo apt-get install rhythmbox


Tomasz Rzepecki (nub) wrote :

I did what obadz suggested, and it solved the problem, however, because of this I can't install rhythmbox-plugins -- the oneiric version doesn't agree with rhythmbox, while the natty version apparently conflicts with vlc.
On a sidenote, rhythmbox doesn't appear anywhere in notification area in lxde desktop (not even the natty rhythmbox), which it did in natty. Is that related to bug #724369 ?

Pedro Villavicencio (pedro) wrote :

Rhythmbox-Client was removed [1] during March and then re enabled and ported to DBus+Mpris [2], sadly that code is not on the Oneiric package and since it's almost a new feature (whole re write) i don't think we can SRU that, however the feature is going to be there on the new Package in Precise.

1- http://git.gnome.org/browse/rhythmbox/commit/?id=9d4e5bcf1e969caa2f9848340ec610792c6a29d1
2- http://git.gnome.org/browse/rhythmbox/commit/?id=5ec27a0dece6eb6d7e4d77da4f02f393bbe5c47f

obadz (obadz) wrote :

Thanks Pedro.

I've just tried the rhythmbox package that's currently in precise. It doesn't seem to have rhythmbox-client in it yet. Do you know when it will be there?

As of this comment, the version currently in precise is the same one in oneiric. You can keep checking here for updated versions: https://launchpad.net/ubuntu/+source/rhythmbox

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.90.1~20111126.89c872b0-0ubuntu1

rhythmbox (2.90.1~20111126.89c872b0-0ubuntu1) precise; urgency=low

  * Upload the new version to Ubuntu, should solve those issues:
    - the lack of rhythmbox-client command (lp: #875064)
    - the music sharing preferences dialog (lp: #894153)
    - several segfaults (lp: #859195, #814614)
  * debian/control.in:
    - let the rhythmbox gir depends on gir1.2-peas-1.0 (lp: #874973)

  [ Rico Tzschichholz ]
  * New upstream git snapshot
 -- Sebastien Bacher <email address hidden> Mon, 05 Dec 2011 19:31:23 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Rafael SDM Sierra (rafaeljsg14) wrote :

If you are here looking for some way to control Rhythmbox via console, you can create alias or run the following commands:

dbus-send --type=method_call --dest=org.mpris.MediaPlayer2.rhythmbox /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Next # Next track
dbus-send --type=method_call --dest=org.mpris.MediaPlayer2.rhythmbox /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Previous # Previous track
dbus-send --type=method_call --dest=org.mpris.MediaPlayer2.rhythmbox /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlayPause # Play/Pause
dbus-send --type=method_call --dest=org.mpris.MediaPlayer2.rhythmbox /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Stop # Stop

From here: http://en.gentoo-wiki.com/wiki/Multimedia_Keys#Rhythmbox

Tomasz Rzepecki (nub) wrote :

Thanks a lot Rafael, your suggestion solved my problem. :)
Specifically, I needed those to set up keyboard shortcuts in lubuntu. They work just fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers