rhythmbox-metadata crashed with SIGSEGV in _start()

Bug #815837 reported by trebor271074 on 2011-07-25
560
This bug affects 65 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

help?

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: rhythmbox 2.90.1~20110329-1ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Jul 25 14:27:24 2011
ExecutablePath: /usr/lib/rhythmbox/rhythmbox-metadata
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110724)
ProcCmdline: /usr/lib/rhythmbox/rhythmbox-metadata unix:tmpdir=/tmp
ProcEnviron:
 LANG=ro_RO.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x409725 <_start+1937>: cmp %rbp,0x8(%rbx)
 PC (0x00409725) ok
 source "%rbp" ok
 destination "0x8(%rbx)" (0x00000009) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: rhythmbox
Stacktrace:
 #0 0x0000000000409725 in _start ()
 No symbol table info available.
StacktraceTop: _start ()
Title: rhythmbox-metadata crashed with SIGSEGV in _start()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

trebor271074 (trebor271074) wrote :

StacktraceTop:
 connection_closed_cb (connection=0xa91040, svc=0x1) at rb-metadata-dbus-service.c:216
 ffi_call_unix64 () at ../src/x86/unix64.S:75
 ffi_call (cif=0x7fff77b6f320, fn=0x4096f0 <connection_closed_cb>, rvalue=<value optimized out>, avalue=<value optimized out>) at ../src/x86/ffi64.c:486
 g_cclosure_marshal_generic (closure=0x7fca68000db0, return_gvalue=0x0, n_param_values=3, param_values=<value optimized out>, invocation_hint=<value optimized out>, marshal_data=0x4096f0) at /build/buildd/glib2.0-2.29.14/./gobject/gclosure.c:1146
 g_closure_invoke (closure=0x7fca68000db0, return_value=0x0, n_param_values=3, param_values=0xb15d90, invocation_hint=<value optimized out>) at /build/buildd/glib2.0-2.29.14/./gobject/gclosure.c:773

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
tags: added: bugpattern-needed
Bilal Shahid (s9iper1) wrote :

the bug is also present in 12.04 i have also seen this but can not t notice the steps to reproduce it.so i am reopening this bug.and also marking it public.

Changed in rhythmbox (Ubuntu):
status: Expired → New
importance: Medium → High
visibility: private → public
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

any body please define the steps to reproduce it any specific steps to reproduce it ?

Sam_ (and-sam) on 2012-02-03
tags: added: precise
Sam_ (and-sam) wrote :

Not really specific steps on dupe bug 926342.
Initial launch works fine, second and third crash, fourth and fifth work fine.
Terminal output:
~$ rhythmbox
GLib-GIO-CRITICAL **: GApplication subclass 'RBShell' failed to chain up on ::startup (from start of override function)

tags: added: qa-manual-testing rls-mgr-p-tracking
Sam_ (and-sam) wrote :

Unable to reproduce a crash, started rhythmbox five times via indicator, dash, terminal. Terminal output same as #9.
rhythmbox:
  Installed: 2.95-0ubuntu2
  Candidate: 2.95-0ubuntu2
  Version table:
 *** 2.95-0ubuntu2 0

Rick McBride (rmcbride) wrote :

I was able to consistently reproduce this when bug 933026 was flagged by apport.

NULL VMA looks suspiciously like something particular to metadata on affected systems creating an OOB situation somewhere.

sayth (flebber-crue) wrote :

https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/944576

Distro 12.04

Error occured when attempting to play WavPack.

Sam_ (and-sam) wrote :

Just happened again with rhythmbox 2.95-0ubuntu3.
Run rhythmbox via indicator, edit some files, close the app results in crash.

bwat47 (bwat47) wrote :

I get this crash in precise beta 1 too. For me I was able to workaround it by setting the check for new podcasts option to "never"

tags: added: rls-p-tracking
icrauler (iofcrauler) wrote :

I get rhythmbox crash while opening .mp3 from a site with Firefox. This reproduces when there is no rhythmbox (and rhythmbox-metadata) process in memory and .mp3 is opening with Firefox "Open with..." dialog from internet (from /tmp).

Example: file:///tmp/diyalog2-1.mp3 (-r-------- 1 name name 1227546 mar 15 22:03 diyalog2-1.mp3) causes 1 sec play and then crash.

Vadim Rutkovsky (roignac) wrote :

Reproduced using steps from comment #15

This is fixed in rhythmbox 2.96

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Committed
Changed in rhythmbox:
importance: Unknown → Critical
status: Unknown → Fix Released
Michael Terry (mterry) wrote :

Marking fix released since 2.96 is in precise.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.