Ubuntu

Descender letters (g j p q y) get their tail cut off in current song

Reported by Chris on 2011-07-16
350
This bug affects 67 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Papercuts Ninjas
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

look at the current song in the screenshot

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rhythmbox 2.90.1~20110329-1ubuntu4 [modified: usr/share/doc/rhythmbox/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
Date: Sat Jul 16 12:19:58 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to oneiric on 2011-07-15 (0 days ago)

Related branches

Chris (ccouzens) wrote :
Pedro Villavicencio (pedro) wrote :

does that works correctly with other player, like totem?

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

No problem in Totem. I presume the problem is that the GUI is laid out
too closely, and GStreamer is not to blame.

On Fri, Jul 22, 2011 at 2:42 PM, Pedro Villavicencio <email address hidden> wrote:
> does that works correctly with other player, like totem?
>
> ** Changed in: rhythmbox (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: rhythmbox (Ubuntu)
>       Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/811475
>
> Title:
>  Descender letters (g j p q y) get their tail cut off in current song
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/811475/+subscriptions
>

Pedro Villavicencio (pedro) wrote :

at least would be nice to put a ... but a ~3 looks really bad.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Chris (ccouzens) wrote :

"at least would be nice to put a ... but a ~3 looks really bad."

That is actually a bug with the radio station. Other players (like iTunes) have the ~Number behaviour for the same feed.

Captain Chaos (launchpad-chaos) wrote :

Pedro, Chris, note that this bug is not about the ~3, it's about the fact that the descenders of the letters are cut off. I've attached another screenshot showing the problem.

UbuntuFlo (ubuntuflo) wrote :

I underlined the letters which cause problems in this screenshot: https://launchpadlibrarian.net/86025889/cut-letters-rhythmbox.png

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New

Further to my duplicate report, https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/920587

i propose that either the 'Now playing x' information, or the bar which moves as the song plays, should be moved to the empty space highlighted in orange on my last image, freeing up more room to show more contents of the library etc

It seems inefficient to have an large empty space sitting there, when we have this problem.

Changed in hundredpapercuts:
status: New → Confirmed
Changed in rhythmbox:
status: New → Confirmed
Chris Wilson (notgary) on 2012-02-28
Changed in hundredpapercuts:
milestone: none → precise-4-music-video
assignee: nobody → Papercuts Ninja (papercuts-ninja)
importance: Undecided → Low
status: Confirmed → Triaged
rnsmith2 (rnsmith2) wrote :

Also occuring with non-English writing systems, see attachment for the problem in Georgian.

rnsmith2 (rnsmith2) wrote :

And also for Russian. (highlighted song in library is how they are supposed to appear)

Platon Pukhlechev (ifalkorr) wrote :

same for me

Alan Bell (alanbell) wrote :

this is a bit of a gtk bug in the ellipsize method of the gtk_lable. It resizes vertically to the height of the default text, but doesn't consider the pango formatted <big> bit around the song title. Forcing the widget to request a height of 25 seems to fix it nicely.

Alan Bell (alanbell) wrote :

it needs

 gtk_widget_set_size_request (GTK_WIDGET (header->priv->song),-1,25);

added around line 254 of widgets/rb-header.c

Timothy Arceri (t-fridey) wrote :

If this is caused by a gtk bug a bug report should be filed upstream in the gnome bugzilla and it should be fixed there rather than hard coding values into rhythmbox to work around it.

Alan Bell (alanbell) wrote :

it has apparently been worked around in upstream rhythmbox now in https://bugzilla.gnome.org/show_bug.cgi?id=668262
I don't think that is a fix in the GTK ellipsize method, but it doesn't affect the new rhythmbox layout that we don't have yet. I guess we live with it until 12.10 or patch it now and it will look nice in 12.04.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in rhythmbox:
status: Confirmed → Fix Released

This bug was marked "Fix released" on 2012-03-29, but it's still affecting me today (2012-4-15). I'm attaching a screenshot.

The bug causes the title "Hjertebarn by Under Byen from Kyst" to show up as if it were "Hiertebarn bv Under Bven from Kvst".

Timothy Arceri (t-fridey) wrote :

fix released is for the upstream bug. The ubuntu package is still marked as fix committed which means it may not have been added to ubuntu yet

My bad. Sorry for the misinterpretation.

Alan Bell (alanbell) wrote :

it is fixed in some future version of rhythmbox with a different layout. It won't get fixed in 12.04 without the fix I suggested or some other fix. I am quite happy to make a patch that addresses the problem, or we can live with it for 5 years of LTS support.

For what it's worth, it's a small patch that fixes a cosmetic issue we've had for a while now - i'm all in favour of patching it in 12.04 and i think alan should go for it!

melrokz (melrockz) wrote :

I'm in favour of the patch too! For now, Will compiling rhythmbox from source fix the issue?

Alan Bell (alanbell) wrote :

this should do it

The attachment "08_fix_song_title_descenders.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Very pleased to see that the issue has been fixed!

Version 2.97 has been released which displays the now playing bar to the right and improves real estate on the screen a bit.
Don't know when it'll be ready for the precise etc repositories, but it's available on the webupd8 ppa by doing:

sudo add-apt-repository ppa:webupd8team/rhythmbox

and then sudo apt-get update && sudo apt-get dist-upgrade

Ton of other bug fixes done too it seems! :) Problem solved, guys!

Rodney Dawes (dobey) wrote :

Not sure why this was marked "Fix Committed" as it isn't. Also, the attached patch isn't really a fix, but rather a small workaround. The proper fix should be in GTK+.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Confirmed
Changed in hundredpapercuts:
status: Fix Committed → Confirmed

In the meantime -- I looked at a slightly different way of fixing this. Padding between widgets in the header looked a little unusual to me anyway; so I added 5 pixels on top and bottom; then pushed the result to my PPA. If someone wants to try it and review whether it makes things better or not:

https://launchpad.net/~mathieu-tl/+archive/ppa/+sourcepub/2495974/+listing-archive-extra

Just a workaround, but the change with 10px (although that's arguably a lot) seems to work properly at multiple font sizes.

Timothy Arceri (t-fridey) wrote :

This was marked as fix commuted because its fixed upstream

This is fixed released in quantal: the new layout is already available there. Setting to confirmed for the precise task.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Changed in rhythmbox (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Low
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Mathieu Cossette (mcossette) wrote :

Installing RhythmBox 2.97 from 12.10 distribution got it fixed for me ;)

Hello? Is Ubuntu really going to leave the default mediau player of a 2 year LTS with a glaring GUI bug for the entire time? This bug has been patched here and upstream but no fix has been issued to people not subscribing to PPAs or back porting. General users still stare this ugly bug in the face everyday. I have a hard time buying into Ubuntu beating anyone on quality when I can't even properly read song names in the default media player and this bug has been known and essentially ignored or unfixed for over half a year. Come on, telling people to upgrade to the still beta next release for a fix or a PPA is unacceptable. What is preventing this particular fix from being generally pushed. I get loads of other software updates everyday from Ubuntu for issues less glaring than this. This is a sad joke yes? I'm on this LTS at work for 2 years. This is the quality and polish I can continue to look forward to. Apps that appear not to have had a QA person even *use* them once? At all?

Just for reference, Rhythmbox reports I'm apparently listening to a song callled:
Solitarv (Sional Version) ....

Nekhelesh Ramananthan (nik90) wrote :

Can we please get this backported to Precise please?

Sorry if my tone sounded hostile, I'm just really frustrated by this bug and the lack of finish and shine it shows in Ubuntu's flagship current leading release. It's embarrassing to me as well as annoying and seems so needless :( Didn't mean to explode so much though.

LAZA (laza74) wrote :

+1 for backport into Precise.

And it is five(!) years for those who woul not change to the next LTS...

Timothy Arceri (t-fridey) wrote :

I'm not sure what the holdup here is the patch for version 2.96 (i.e Ubuntu 12.04) was posted in comment #23

Lisa Schmidt (boxnotify) wrote :

I also wonder why Canonical doesn't change their update policy and upstreams important 'user applications' as soon as there is an update package available. Stuff like Gimp, LibreOffice, etc. should get an updated PPA shortly after the update is available, not after months!

LAZA (laza74) wrote :

Wasn't this bug really NOT fixed in one of the updates?
Looks for me a bit better (but is another machine) - BUT still not correct:

Queen - A Nioht at the Opera

(the 'Q' looks fine, but half of the 'g' is still missing and the 'p' looks shortened...)

Eduard Grebe (eduardgrebe) wrote :

This bug is definitely not fixed for me on a bog standard 12.04.1 installation. I attach a screenshot that demonstrates the probelm still occurring.

Eduard Grebe (eduardgrebe) wrote :

I should clarify: the problem is most pronounced not in the song title, but in the artist and album names (in smaller text following the song title).

In an effort to quench similar comments coming in recently, here is the current state of things, including solutions:

A patch isn't really necessary because it's fixed upstream and it's known that the bug exists in versions of rhythmbox <2.97.

So..What needs to be done is a request for the version in quantal (2.97-1ubuntu5) to be backported to replace the version in precise (2.96-0ubuntu4.1) or precise-updates (2.96-0ubuntu4.2). (What is the correct procedure for this?)

OR you can install version 2.98 from the webupd8 ppa:

sudo add-apt-repository ppa:webupd8team/rhythmbox
sudo apt-get update && sudo apt-get dist-upgrade

To post a comment you must log in.