Window does not always close when running gnome-shell

Bug #780747 reported by Julien Olivier on 2011-05-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

See here: https://bugzilla.gnome.org/show_bug.cgi?id=648114

When running rhythmbox inside gnome-shell, you can close rhythmbox' main window once when music is playing. Then, if you open it again, then try to close it again (still with music playing), it does nothing... The window just stays there unless you close it after having stopped the music.

Related branches

Xavier Claessens (zdra) wrote :

Note taht when you can't close it, if you go to overview rb window is not shown.

Empathy had similar issue, the problem is the use of gtk_window_iconify() that should be replaced with gtk_widget_hide().

Xavier Claessens (zdra) wrote :

I rb_shell_set_visibility() is dead code in upstream. That function does lots of hacks to inconify the window, but a plain gtk_widget_hide() works much better.

Xavier Claessens (zdra) wrote :

oh, and also fixed a leak: g_object_get() returns a ref !

Rico Tzschichholz (ricotz) wrote :

Update to a new git snapshot which also includes the updated patch for this bug.

rhythmbox (2.90.1~20110727-0ubuntu1) oneiric; urgency=low

  * New upstream git snapshot.
  * debian/control.in:
    - rename gir-package to gir1.2-rb-3.0
    - add libdiscid0-dev, libpeas-dev (>= 0.7.3)
    - drop libgnome-media-profiles-dev
    - bump gstreamer dependencies (>= 0.10.32)
    - disable rhythmbox-plugin-coherence package
  * debian/*.install:
    - update for new source
  * debian/patches:
    - refreshed as needed
    - drop 00git-daap-password-handling.patch and 00git-dacp-enums.patch
    - fix 05_hide_on_quit.patch (LP: #780747)

 -- Rico Tzschichholz <email address hidden> Fri, 29 Jul 2011 16:41:38 +0200

Package files are locate here: http://people.ubuntu.com/~ricotz/rhythmbox/

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for the update Rico, that seems mostly good, small questions though:

- why do you comment the coherence binary? could you give the reason in the changelog? (i.e upstream needs to solve ...)
- why is the patch from this bug commented in the serie? that doesn't match the changelog which says it's updated to fix the issue
- there has been some translation updates and bug fix since your tarball, bonus point if you update to current trunk and list the launchpad bugs to close in the changelog ;-)

the update is ok otherwise but is blocking on the commented patch issue to be sorted

Rico Tzschichholz (ricotz) wrote :

rhythmbox (2.90.1~20110802-0ubuntu1) oneiric; urgency=low

  * New upstream git snapshot up to commit
    5371a53f180007f7998720acf8d7d3376376a39d
  * reverted commit "visualizer: new clutter-based visualizer plugin"
    (082eaf958b60e3830f1607114353d777c930d616) to prevent universe dependencies
  * debian/control.in:
    - rename gir-package to gir1.2-rb-3.0
    - add libdiscid0-dev, libpeas-dev (>= 0.7.3)
    - drop libgnome-media-profiles-dev
    - bump gstreamer dependencies (>= 0.10.32)
    - comment rhythmbox-plugin-coherence package since it disabled upstream
  * debian/*.install:
    - update for new source
  * debian/patches:
    - refreshed as needed
    - drop 00git-daap-password-handling.patch and 00git-dacp-enums.patch
    - fix 05_hide_on_quit.patch (LP: #780747)

 -- Rico Tzschichholz <email address hidden> Fri, 29 Jul 2011 16:41:38 +0200

Package files are locate here: http://people.ubuntu.com/~ricotz/rhythmbox/

Changed in rhythmbox (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.90.1~20110802-0ubuntu1

---------------
rhythmbox (2.90.1~20110802-0ubuntu1) oneiric; urgency=low

  * New upstream git snapshot up to commit
    5371a53f180007f7998720acf8d7d3376376a39d
  * reverted commit "visualizer: new clutter-based visualizer plugin"
    (082eaf958b60e3830f1607114353d777c930d616) to prevent universe dependencies
  * debian/control.in:
    - rename gir-package to gir1.2-rb-3.0
    - add libdiscid0-dev, libpeas-dev (>= 0.7.3)
    - drop libgnome-media-profiles-dev
    - bump gstreamer dependencies (>= 0.10.32)
    - comment rhythmbox-plugin-coherence package since it disabled upstream
  * debian/*.install:
    - update for new source
  * debian/patches:
    - refreshed as needed
    - drop 00git-daap-password-handling.patch and 00git-dacp-enums.patch
    - fix 05_hide_on_quit.patch (LP: #780747)
 -- Rico Tzschichholz <email address hidden> Fri, 29 Jul 2011 16:41:38 +0200

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers