apport package hook should not be run if it is a crash

Bug #737598 reported by Brian Murray on 2011-03-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

The apport package hook for rhythmbox asks questions about what kind of problem I'm reporting but what really happened is that rhythmbox just crashed on me. Depending on the nature of the questions in the package hook it'd probably be best to just skip the hook if the problem type is a crash.

summary: - apport package hook should be run if it is a crash
+ apport package hook should not be run if it is a crash
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: added: apport-hook
Vadim Rutkovsky (roignac) wrote :

Worked fine for me on rhythmbox crashes in recent Oneiric version. Brian, is this still reproducible>

Brian Murray (brian-murray) wrote :

It worked fine for you because the apport package hook is no longer installed by rhythmbox which is a bug in itself. You should be able to find the the package hook in /usr/share/apport/package-hooks. You would also see questions if you were to use 'ubuntu-bug rhythmbox' if it were installed.

Bryce Harrington (bryce) wrote :

The package hook is installed, just to an incorrect directory. Filed as bug #992355

Bryce Harrington (bryce) on 2012-05-01
Changed in rhythmbox (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.96-0ubuntu6

---------------
rhythmbox (2.96-0ubuntu6) quantal; urgency=low

  * debian/rhythmbox.install:
    - Fix installation of apport hook to correct
      directory. Otherwise, the hook won't be used when running ubuntu-bug
      rhythmbox.
      (LP: #992355)
    - Improve categorization wording.
      (LP: #543948)
    - Only prompt user to specify type of bug if it isn't a crash.
      (I.e., if there is no stacktrace present.)
      (LP: #737598)
 -- Bryce Harrington <email address hidden> Thu, 17 May 2012 16:29:37 -0700

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers