Rhythmbox has no apparent pause button

Bug #71228 reported by Juanjo Garcia-Ripoll on 2006-11-10
This bug affects 17 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Bilal Akhtar
Fix Released
rhythmbox (Ubuntu)
Bilal Akhtar

Bug Description

Binary package hint: rhythmbox

System: Ubuntu Edgy Eft 6.10, rhythmbox-0.9.6-0ubuntu4


When playing mp3 files in Rythmbox, the same button is used to play and pause reproduction. However the icon of the button does not change when moving from pause to play and it is confusing.

Steps to reproduce:

1 Open Rythmbox
2 Select an mp3 file
3 Press the play button, the file will begin to play, the button remains a triangle
4 Press that same button, the file stops, the icon is still a triangle.

What should happen:

When reproducing the file, the "play" button should get a different icon, ideally the two vertical bars which represent "pause" in most multimedia devices.

Related branches

Ubuntu Sponsors Team: Pending requested 2010-08-06
Jonh Wendell (wendell) on 2006-11-10
Changed in rhythmbox:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Jonh Wendell (wendell) wrote :

Thanks for your bug report. This particular bug has been filed
with the developers of the software. You can track this and make
comments here: http://bugzilla.gnome.org/show_bug.cgi?id=326066

Changed in rhythmbox:
assignee: nobody → desktop-bugs
Changed in rhythmbox:
status: Unknown → Confirmed
plikplok (plikplok) wrote :

This bug can also be find in the top edge pannel
When you right click on the rhythmox icon which is open in the top edge pannel
there is a square with or without "v"
this square should be replaced by the symbol "play" or the symbol "pause"

Changed in rhythmbox:
status: Confirmed → Triaged
Changed in hundredpapercuts:
milestone: none → lucid-round-6
status: New → Confirmed
jollywollup (jollywollup) wrote :

I actually came across this yesterday and didn't really think of it as a bug because I realized that "play" probably also means "pause". But this makes it a perfect candidate for a paper cut fix, as I imagine it shouldn't be too hard to remedy, and new users might be confused by the terminology.

Vish (vish) on 2009-12-31
Changed in hundredpapercuts:
status: Confirmed → Triaged
summary: - No pause button
+ Rhythmbox has no apparent pause button
Vish (vish) on 2010-01-24
Changed in hundredpapercuts:
importance: Undecided → Low
Matt Perry (mp) wrote :

This patch causes the Play button to toggle to a Pause button (both label and icon) on click.

Vish (vish) wrote :

@Matt Perry : Could you submit the patch upstream as well?

Rich Jones (richwjones) wrote :

There are so many rhythmbox layout/chrome issues, take a look here:

I would bust a nut if any of these got into Lucid

Matt Perry (mp) wrote :

@Vish: Done.

tags: added: patch
tags: added: patch-upstreaminput
removed: patch
David Futcher (bobbo) on 2010-06-08
tags: added: input patch-forwarded-upstream
removed: patch-upstreaminput
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-6 → maverick-round-6-sound+video
Changed in rhythmbox (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
status: Triaged → In Progress
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Bilal Akhtar (bilalakhtar)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.13.0git20100715-0ubuntu5

rhythmbox (0.13.0git20100715-0ubuntu5) maverick; urgency=low

  * debian/patches/07_pause_button.patch:
    - Play button now changes to Pause and Stop when needed. (LP: #71228)
 -- Bilal Akhtar <email address hidden> Fri, 06 Aug 2010 15:20:37 +0530

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Another one fixed!

Changed in hundredpapercuts:
status: In Progress → Fix Released
madbiologist (me-again) wrote :

Brilliant! Thanks!

One small thing - the button is not the same size in the different states. When it is a pause button it is longer than when it is a play button. Could this be changed to make it constantly the same size? Or maybe just remove the words "Play" and "Pause" altogether and just have the symbols.

madbiologist (me-again) wrote :

By "longer" I mean "wider".

Matt Perry (mp) wrote :

I'm feeling screwed over here. I wrote a patch for this in January and it's been ignored for nearly seven months. *NO ONE* on launchpad gave me any feedback on the patch. Then Bilal comes along, writes a nearly identical patch, and it's accepted and committed. What did I do wrong? How come Bilal's patch is accepted while mine was ignored? His patch hasn't even been reviewed! Who committed it and why?

I have nothing against you Bilal, I'm just annoyed with the process.

Bilal Akhtar (bilalakhtar) wrote :

Sorry, I didn't notice your patch. I just saw an easily-fixable bug, wrote a patch for it, made the debian changes for it and pushed a branch for it. Then, poked Ken on IRC and requested him to review it. When he found it fit, he got it in.

The best way of getting patches in is to download the complete source package, apply the patch for it, write an entry in debian/changelog and then push a branch and poke a sponsor. This will help you in speeding up getting patches into UBuntu.

Have a good time fixing bugs.. I am sorry for not trying to get yours in, since I didn't notice it.

Bilal Akhtar (bilalakhtar) wrote :

Filed bug #615248 to deal with the button length issue.

madbiologist (me-again) wrote :

Matt - I agree, the process is _really_ bad.

I would have applied your patch to the source code and compiled and tested it myself if I had the technical know-how. However I at the moment I am barely able to to compile anything, let alone patch it first. (Does one actually patch the source and then compile, or is the patch applied during compilation?)

It looks like you and Vish tried to follow the "normal" (and possibly the "right"?) process by forwarding your patch upstream to Gnome, however your patch was almost completely ignored. The pre-existing patch from Seemanta Dutta (which he continued to work on after you submitted your patch) was also ultimately ignored/rejected. Comments 45-49 in the upstream bug are very enlightening in this regard. So the normal process has failed. Badly.

So now Bilal's patch is in Ubuntu and Debian, but not in Gnome, which doesn't help any other non-Debian-based distributions which are shipping Rhythmbox. This of course is not Bilal's fault. This sort of failure on the part of the Rhythmbox/Gnome developers is probably one of the reasons why Banshee seems to be taking over as the music player of choice.

Bilal Akhtar (bilalakhtar) wrote :

I completely agree with what madbiologist and Matt Perry said. This is completely not a fair process. That is why I prefer to get patches into Distros first and then later think of getting it upstream. Why? Because more popular and established upstreams are very busy and don't have the time to review patches. You may call me 'impatient' which I am. I agree it is my fault, to some extent.

Same goes to some extent for the Ubuntu developers. They are also very busy and don't have the time to review each and every bug with patches. You either need to poke them manually, or, like I do, add the packaging stuff to the patch and then poke 'em. This is what I suggested Matt Perry to do. However, everyone may not know how to package. This is one case where patches are ignored. Never forget that the maverick Feature Freeze is just round the corner and we are still at just 11% progress in Operation Cleansweep.

I have been quite much successful in my packaging-and-patching journey till now, as I aim to become MOTU one day. Well, you may call me impatient again, which I agree I am. But, I suggest you patch-makers also to learn some basics of packaging and then try to get your patches into. This will also give you credit and your bug fix uploads will appear on your uploaded-packages page on your Launchpad profile, like mine https://edge.launchpad.net/~bilalakhtar/+uploaded-packages .

Vish (vish) wrote :

@Matt Perry:One of the main concern for this bug was that upstream wasnt even willing to review the patches we try to send them!
We want upstream to accept patches first.

You have done patches earlier too and they have been accepted.[iirc, they were mostly in f-spot?]
Lets test this, you submit another patch for one of the papercuts <https://bugs.launchpad.net/hundredpapercuts/+bugs?field.status%3Alist=TRIAGED> and we make sure it gets fixed? ;-)

Bilal Akhtar (bilalakhtar) wrote :

I apologize for the harsh language used by me in comment 16. I just wanted to point out some better ways of getting bugs fixed and patches accepted. I sincerely apologize for any offence caused by my comment.

Changed in rhythmbox:
importance: Unknown → Medium
Changed in rhythmbox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.