Ubuntu

Songs synced to iPhone 4 do not appear in iPod app

Reported by lucas on 2011-02-01

This bug report will be marked for expiration in 57 days if no further activity occurs. (find out why)

182
This bug affects 37 people
Affects Status Importance Assigned to Milestone
gtkpod
Incomplete
Undecided
Unassigned
banshee (Ubuntu)
Medium
Unassigned
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

Rhythmbox seems to execute a sync with the iPhone but the new songs do not appear after syncing is complete. I tested this with OS 4.1 and 4.2 on an iPhone 4.

It does see the phone's song library correctly and recognizes the right number of missing songs. One can delete songs on the phone but they are not removed from the phone's library.

Banshee seems to have similar problems. It goes through an elaborate sync process including updating the database on the phone -- or so it claims. But again, nothing seems to actually change on the phone. In fact, Banshee is all confused about what is music, what is video and what is other data on the phone.

I suspect that some underlying libs are broken. I have tried this with a freshly updated version of maverick 10.10 and also tried adding this repository for latest updates of libimobiledevice1 (v 1.0.4): ppa.launchpad.net/pmcenery/ppa/ubuntu . Incidentally, after adding this repository i can no longer browse the file content of the phone, all else is the same.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: rhythmbox 0.13.1-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Tue Feb 1 11:18:46 2011
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: rhythmbox

lucas (parra) wrote :
Luke Faraone (lfaraone) wrote :

I was able to reproduce this problem with iOS 4.3.2 on an iPhone 4, on Ubuntu 11.04 Beta.

summary: - sync with iPhone 4 broken
+ Songs synced to iPhone 4 do not appear in iPod app
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Changed in banshee (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
Luke Faraone (lfaraone) wrote :

Probably underlying upstream cause: http://gtkpod.org/bugs/index.php?do=details&task_id=35

conorsulli (conorsulli) wrote :

Confirmed not working on the Ipod touch 4g IOS version 4.3.2 also for both my ipod and my sisters (same model)..

Im guessing this bug effects all new IOS devices on 4.3.2 including the Ipad as well.

Michal Szymanski (msz-astrouw) wrote :

Same on 11.04 i386 with all updates installed, iPhone 4G iOS 4.3.1

Would jailbreaking iP fix this problem?

demoez walker (demoez) wrote :

@Michal Szymanski

I have a jailbroken iphone 4 on 4.3.1 and this does not fix the problem.

Stephan (mr-swhough) wrote :

I have a iphone 4 with IOS 4.3.2 and I am also experiencing the same problem. Not sure if this is helpful at all but I noticed

1. the files are transferred to my phone

2. the mp3 file names are the same as what they are on my computer (not the weird 4 or 5 capital letters naming convention similar to the other files transferred via Itunes)

3. I used SqliteMan to view the database file Library.itdb on my phone - they were not updated after synchronising with Rhythmbox. The db tables do not include any records for the mp3 files transferred to my phone via Rhythmbox.

Hope this helps

Stephan

Albert (albert-m) wrote :

Confirmed / reproduced on ipad 2 running iOS 4.3.3. Sync transfers files to the itunes_control folder but does not update database, thus ipod app does not list the music. Same issue for both Rhythmbox & Banshee on 11.04 with libimobiledevice1 version 1.0.6

Albert (albert-m) wrote :

Correction: 11.04 should be 10.10 (Maverick Meerkat)

Chris Childs (chris-childs47) wrote :

I have the same problem. Iphone 4 on 4.2.1 using Banshee on 11.04. Banshee and the iphone both think they have synced but nothing on the iphone in the ipod has changed (visually). Is anybody getting anywhere with this?

Luke Faraone (lfaraone) wrote :

As I pointed out in comment 3, the problem has been identified upstream in gtkpod.

The issue is that the new database format used by the iPhone cannot be parsed by gtkpod.

The problem is confirmed. Please do not post additional comments just to indicate you are also experiencing the problem; instead use the "Does this bug affect you?" link.

Haneef Mubarak (haneefmubarak) wrote :

Experiencing problem, but quick thought:

Would switching DBVersion to "2" in the "system/library/lockdown/Checkpoint.xml" help?

m0sia (m0sia) wrote :

Hi Haneef,

My iphone4 is not jailbroken yet, so I don't know if it will help. After googling for a while it seems it shall help to work around the problem. Let me know if it is a solution.

m0sia (m0sia) wrote :

Hi Hannef,

According to the following blog comments the method shall work for iphone 4 with latest firmware:
http://marcansoft.com/blog/2011/01/syncing-music-in-new-idevices-with-linux/#comments

m0sia (m0sia) wrote :

The following steps works for me:
1. Jaibreak the phone (via http://jailbreakme.com)
2. Install openssh from cydia
3. ssh to the phone
4. change DBVersion to 4 in the /system/library/lockdown/Checkpoint.xml
5. Generated HashInfo following the link http://ihash.marcansoft.com/
6. copy HashInfo to the folder /var/mobile/Media/iTunes_Control/Device/
7. Reboot the phone
8. Mounted device automatically using Ubuntu Natty (libmobiledevice, ifuse and so on already installed)
9. Sync using Banshee

dmiller309 (dmiller309) wrote :

My iPhone 3GS is using iOS 4.2 and I had just reset all of the settings. This is what I did leading up to the iPhone being filled up with "other":
1. Synced my music library with iPhone. The music didn't all fit on the iPhone, but it was listed as music.
2. Banshee doesn't have the option like Songbird to organize music folders, so I closed Banshee, moved all of my music to an external drive, started Banshee, and had Banshee import the songs back in, copying the files to their destination.
3. I plugged my iPhone into my computer and synced it with a different playlist.
At this point, Banshee says that my iPhone is completely filled with "other", and according to my iPhone there is 0 free space. The iPod app says that I don't have any content, and I have no way to remove the "other" from my iPhone so as to be able to install applications. The iPhone presented a dialog while I was looking at the iPod that there was something wrong with the pictures app that needed my attention, and when I went to the pictures app, it complained that I couldn't add any more pictures because there was no space. I tried looking at the iPhone with gtkpod, but it popped up 3 dialogs saying that I had to initialize the iPhone, and I clicked okay for the first one and cancel for the remaining dialogs. Now, whenever I start Banshee with my iPhone plugged in, it promptly crashes after consuming 100% CPU for some time. I'm kind of wondering why this feature is included in Ubuntu at all, since it fills up my iPhone with inaccessible music and consumes 100% of my CPU while crashing Banshee. I attached the terminal output of running Banshee with the iPhone plugged in.

dmiller309 (dmiller309) wrote :

Output of running Banshee with iPhone attached. The contents of the attached file probably don't pertain directly to this bug but rather to one with .gvfs on the iPhone not working, but I attached it anyway for completeness.

jp219 (jp219) on 2012-04-11
Changed in gtkpod:
status: New → Confirmed
Thag (bruce-edge) wrote :

rhythmbox's ipod support has been broken since 11.10.
The last time this worked was 11.04.

Very upsetting that an LTS release makes it out with no functional ipod support at all.
None of the media managers claiming ipod support work in 12.04.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in banshee (Ubuntu):
status: Confirmed → Incomplete
Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Changed in gtkpod:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers