Ubuntu

clicking X in the "window title" bar does not QUIT Rhythmbox

Reported by nick rundy on 2010-12-27
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

When playing music in Rhythmbox, clicking the X that is on the window title bar closes the Rhythmbox application but does not stop the music that is playing. If the user goes to Music > Quit, then the application will close and playing music will stop. But clicking the X only closes the application without stopping the music that is playing.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: rhythmbox 0.12.8-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-26.48-generic 2.6.32.24+drm33.11
Uname: Linux 2.6.32-26-generic i686
Architecture: i386
Date: Mon Dec 27 16:50:38 2010
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: rhythmbox
XsessionErrors:
 (gnome-settings-daemon:1105): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
 (polkit-gnome-authentication-agent-1:1336): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-settings-daemon:1105): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
 (gnome-settings-daemon:1105): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
 (gnome-settings-daemon:1105): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed

nick rundy (nrundy) wrote :
drizzle (darran-kelinske) wrote :

Is Rhythmbox minimized and placed in gnome-panel as an icon?

Omer Akram (om26er) wrote :

are you using indicator-applet in the panel or have you removed it?

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
nick rundy (nrundy) wrote :

Yes and No. Rhythmbox itself is closed (i.e., not minimized to bottom panel but closed--while the music keeps playing). An icon does appear in the "notification area;" however, I generally do not have the notification icon on my panel/s so I cannot see it. But while troubleshooting this I activated the notification icon and saw that it was leaving an icon.

ldillon (ldillon) wrote :

It still exhibits this behavior in Rhythmbox 0.12.8
Ubuntu 10.04.1 LTS
Linux 2.6.32-27-generic #49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010 i686 GNU/Linux

nick rundy (nrundy) wrote :

I've learned this is not a bug Idillon. It's by design because some people like to listen to music without having the window in the way. They use the notification area icon to control it once the window is closed. If you want the X to close the application and stop playback, here's what you need to do:

1. open Rhythmbox
2. Edit > Plugins
3. scroll to the end of the list and find the entry marked "Status Icon"
4. deselect "Status Icon"
5. close the window

clicking the X on the Titlebar will now close Rhythmbox and stop its playback.

I believe I tried that once but it had undesireable side effects. I personally believe this non-standard behavour is a bug, but that the developers differ in opinion. I was just hoping that they might reconsider.
--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Sebastien Bacher (seb128) wrote :

The behaviour is the one specified in the design guide on https://wiki.ubuntu.com/SoundMenu#compliance

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

see bug #658590 for an opposite issue

Sebastien Bacher (seb128) wrote :

see bug #526552 as well

Julien Olivier (julo) wrote :

This bug actually is present in natty, because even if you disable the "status icon", and do not use the sound indicator, you can't close rhythmbox by clicking on the "close" icon. Having an option to disable the "close to tray" feature is great, but only if it actually disables it :)

Julien Olivier (julo) wrote :

By the way, this works perfectly for banshee: if you disable the "sound menu integration" plugin, banshee exits when you close its main window, even if music is being played.

Julien Olivier (julo) wrote :

Sebastien: this bug is not invalid. It is real, and needs fixing.

Changed in rhythmbox (Ubuntu):
status: Invalid → New
Julien Olivier (julo) wrote :

Sebastien: just to a bit more precise: what is broken is that, if you don't use the music indicator, you can't close rhythmbox at all when it is playing music, not that it statys running when closing to the indicator.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Jani Uusitalo (uusijani) wrote :

To be even more Precise: you *can* quit RB when it's playing, but only by using Ctrl-Q or the corresponding Quit item from the menu. What you *cannot* do is quit RB when it's playing by clicking the window close button, even if you *don't use the indicator*.

To be sure, I removed the indicator-sound package so that indicator-sound doesn't appear in my indicator area at all, and still, RB's window closing button while playing music just makes the window disappear; the music keeps on playing.

With the broadly defined title that bug #526552 has, I don't think it's completely fixed yet: the specification says a "player’s own settings interface should also have a checkbox for whether the player should be present in the sound menu", and RB doesn't have that. I see no no way to disable RB's sound menu integration.

Julien Olivier (julo) wrote :

In gnome-shell, this is particularily disturbing because, once rhythmbox is closed while playing music, its launcher icon isn't highlighted anymore, so it's difficult for users to understand that Rhythmbox is actually still running. The only clue users have to understand that rhythmbox is still running (apart from the music still playing of course) may be the notification icon (if enabled), but, then, this notification icon should allow to display the main window or to quit it, but it doesn't...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers