rhythmbox crashed with SIGSEGV in rb_ipod_db_get_mount_path()

Bug #651261 reported by Jon on 2010-09-29
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: rhythmbox

TEST CASE:
1. install rhythmbox from maverick-proposed
2. plug a ipod shuffle
3. right click on it in rhythmbox
4. see rhythmbox does not crash

RHythmbox crashed trying to access Ipod Shuffle. It shows 0 songs on the Ipod. Everyhting works perfectly on version 0.12.8 in lucid.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: rhythmbox 0.13.1-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
Date: Wed Sep 29 11:52:40 2010
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcCmdline: /usr/bin/rhythmbox
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
SegvAnalysis:
 Segfault happened at: 0x5b802b6 <rb_ipod_db_get_mount_path+38>: mov (%eax),%eax
 PC (0x05b802b6) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 rb_ipod_db_get_mount_path () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
 ?? () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
 ?? () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
 rb_media_player_source_get_capacity () from /usr/lib/librhythmbox-core.so.1
 rb_sync_state_update () from /usr/lib/librhythmbox-core.so.1
Title: rhythmbox crashed with SIGSEGV in rb_ipod_db_get_mount_path()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Jon (jonbrewin) wrote :

StacktraceTop:
 rb_ipod_db_get_mount_path (ipod_db=0x0) at rb-ipod-db.c:901
 get_mount_point (source=0x9a2c6e0) at rb-ipod-source.c:1975
 impl_get_capacity (source=0x9a2c6e0)
 rb_media_player_source_get_capacity (source=0x9a2c6e0)
 rb_sync_state_update (state=0xbb051d0)

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Pedro Villavicencio (pedro) wrote :

looks like bug https://bugzilla.gnome.org/show_bug.cgi?id=618619 ;linking that report.

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Changed in rhythmbox:
importance: Unknown → Critical
status: Unknown → New
Pedro Villavicencio (pedro) wrote :
Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Changed in rhythmbox:
status: New → Fix Released
Omer Akram (om26er) wrote :

rhythmbox 0.13.2 is in natty which fixes this issue.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-12-17
description: updated
Jamie Strandboge (jdstrand) wrote :

Uploaded to maverick-proposed pending SRU approval.

Changed in rhythmbox (Ubuntu Maverick):
status: New → Confirmed

Accepted rhythmbox into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox (Ubuntu Maverick):
status: Confirmed → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) wrote :

I have been using rhyhthmbox from -proposed version for more than 2weeks and have not found any regressions, neither have reproduced this crash(I faced this too previously). verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.13.1-0ubuntu6.1

---------------
rhythmbox (0.13.1-0ubuntu6.1) maverick-proposed; urgency=low

  * debian/patches/93_dont_crash_if_multiple_feeds_are_selected.patch:
    - Don't crash if multiple podcast feeds are selected. (LP: #404255)
  * debian/patches/94_dont_crash_when_trying_to_show_properties_if_ipod_db_load_fails.patch:
    - Don't crash when right clicking on ipod to get properties. (LP: #651261)
  * debian/patches/95_specify_the_right_pointer_for_the_parser_entry-added_handler.patch:
    - Don't crash when opening .m3u file. (LP: #410510)
 -- Omer Akram <email address hidden> Tue, 14 Dec 2010 00:16:52 +0500

Changed in rhythmbox (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.