Ubuntu

rhythmbox doesn't do anything with .pls given on the command line

Reported by Robert Nasiadek on 2006-09-26
144
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Rhythmbox
New
Medium
desktop-file-utils (Ubuntu)
Low
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Sebastien Bacher
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

The problem is, RhythmBox doesn't support playlists loaded externally. So when a user chooses "open this file" in firefox, rhythmbox pops up and nothing happens.
I think the same goes for .m3u playlists.
On the other hand, it's a shame rhythmbox doesn't support external playlists well... It makes it unusable when it comes to internet radios and stuff like that.... :/

Rhythmbox is responsible for the contents of /usr/lib/mime/packages/rhythmbox

description: updated
lmierzej (lmierzej) wrote :

I have the same with pls files (very common format for Internet radio stream). If I double click pls file RhythmBox appears, but new radio station is not added to RhythmBox.

Albrecht Mühlenschulte (a7p) wrote :

Thanks for your report. Your idea might get more attention and have the possibility of being implemented if you would submit a
specification for this.

You should first check whether it already exists at the Ubuntu specs page (https://launchpad.net/distros/ubuntu/+specs) in Launchpad. If that is the case, feel free to contact the drafter of that spec about your comments/suggestions. Otherwise you can start writing a spec following the steps described in
        https://wiki.ubuntu.com/FeatureSpecifications.

This feature should not be to hard to implement - but I think you should stick to upstream with this request.

Changed in rhythmbox:
status: Unconfirmed → Rejected

The /usr/lib/mime/packages/rhythmbox file is part of the Ubuntu patch, so this is not an upstream bug.
It is a very simple bug, only one line in that file needs to be removed.
No specification needed.
No reporting upstream is needed for this incorrect file association with rhythmbox.

It would be nice if Rhythmbox did load pls files from the command line. That should be reported upstream.

Changed in rhythmbox:
status: Rejected → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? Do you have an example to point? Does "rhythmbox playlist-URI" work? It's supposed to make a radio from an http one and import a local playlist as a rhythmbox playlist according to the upstream

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Needs Info

I'm using Edgy on AMD64.

Example: http://www.irlp.net/listen_live.html links to http://live.irlp.net:8000/listen.pls

Running "rhythmbox http://live.irlp.net:8000/listen.pls" launches rhythmbox, but does not play the playlist or add a new internet radio station.

Downloading the playlist, then running "rhythmbox listen.pls" launches rhythmbox, but does not play the playlist or add a new internet radio station.

In rhythmbox you can add a new internet radio station and paste a URL into the dialog, but neither of the above commands is a shortcut to do this.

Sebastien Bacher (seb128) wrote :

Thank you for the comment, I've forwarded that upstream: http://bugzilla.gnome.org/show_bug.cgi?id=383328

Changed in rhythmbox:
status: Needs Info → Confirmed
Changed in rhythmbox:
status: Unknown → Unconfirmed
Changed in rhythmbox:
status: Unconfirmed → Fix Released
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in rhythmbox:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

That upload fixes the bug:

 rhythmbox (0.9.6.90-0ubuntu1) feisty; urgency=low
 .
   * New upstream pre-version
   * debian/control.in:
     - build with the new libgpod package
   * debian/patches/10_podcasts-with-html-mime-type.patch,
     debian/patches/90_from_cvs_fix_crash_when_disconnecting_ipod.patch,
     debian/patches/91_from_cvs_fix_crasher_when_closing_while_playing_cd.patch,
     debian/patches/92_from_cvs_set_codeset_to_utf8.patch,
     debian/patches/93_from_cvs_fix_crash_on_song_edition.patch:
     - dropped, those issues are fixed with the new version
   * plugins/audioscrobbler/audioscrobbler-ui.xml:
     - copy file from CVS, the tarball doesn't ship it

Changed in rhythmbox:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Looks like that's still happening, reopening the bug

Changed in rhythmbox:
status: Fix Released → Confirmed
Changed in rhythmbox:
status: Fix Released → Unconfirmed

this fixes it...

rhythmbox-client --play-uri=http://stream.livesets.com:8000/listen.pls

not sure where it needs to go to get firefox to use it though.

I currently have rhythmbox 0.10.0 with Ubuntu 7.04 and this is still not fixed.

How to reproduce the "bug" :

1- Go to http://di.fm/ (digitally imported) with Firefox.
2- In the menu, choose "Listen now! - a music of your choice - mp3 stream - 96k" this will ask what to do with a .pls file.
3- From Firefox, choose to open with rhythmbox.

What appends :

1- Rhythmbox opens.

That's it! Nothing else. In the radio section, there is nothing. On the other hand, while it is open, do the same operation and the radio list will get populated. This only happens when RB is close. Also, it would be nice if it would start to run the music directly, but that's another thing.

Do you have any suggestions on how to fix it? Did you see my comments
in the bug report?

On 5/17/07, Alexandre Racine <email address hidden> wrote:
> I currently have rhythmbox 0.10.0 with Ubuntu 7.04 and this is still not
> fixed.
>
> How to reproduce the "bug" :
>
> 1- Go to http://di.fm/ (digitally imported) with Firefox.
> 2- In the menu, choose "Listen now! - a music of your choice - mp3 stream - 96k" this will ask what to do with a .pls file.
> 3- From Firefox, choose to open with rhythmbox.
>
> What appends :
>
> 1- Rhythmbox opens.
>
> That's it! Nothing else. In the radio section, there is nothing. On the
> other hand, while it is open, do the same operation and the radio list
> will get populated. This only happens when RB is close. Also, it would
> be nice if it would start to run the music directly, but that's another
> thing.
>
> --
> rhythmbox doesn't do anything with .pls given on the command line
> https://bugs.launchpad.net/bugs/62430
> You received this bug notification because you are a direct subscriber
> of the bug.
>

@Steven : Yes, but I think this is a bigger problem then just play lists. The solution of writing "rhythmbox-client --play-uri=[PATH HERE]" works on the command line.

@all

Doing some tests, this is not just a play list issue, it is a whatever you are trying to play directly when RB is close, it wont work, unless you use the solution from Steven just up here.

For example, double clicking on a .MP3 file, in the file manager does nothing more then start rhythmbox. It does not play the music from the MP3.
Looking with ps, witch shows what is the actual command line, gives this :

$ ps -ef | grep rhy
racine 8536 1 23 14:51 ? 00:00:04 rhythmbox /home/racine/multimedia/mp3/musique/Classique/symphony9_beethoven_radio3.mp3
racine 8586 1 4 14:52 ? 00:00:00 /usr/lib/rhythmbox/rhythmbox-metadata unix:tmpdir=/tmp

So the file MP3 is actually on the command line.
Closing RB and doing the same thing with firefox from the http://di.fm website for example

t$ ps -ef | grep rhy
racine 9523 5291 32 14:59 ? 00:00:03 /usr/bin/rhythmbox /tmp/eurodance.pls
racine@maison01:~$ ls /tmp/eu*
/tmp/eurodance.pls

So again, the file is there, and no music.
I think that there is two solutions to the problem.

1- Just like Malcolm said in the first comment : "Rhythmbox is responsible for the contents of /usr/lib/mime/packages/rhythmbox" witch is the file associations. We could ask the programmer to change the file association like this for .MP3 and .PLS.

audio/x-mp3; rhythmbox-client --play-uri='%s'; description="MP3 audio"; test=test -n "$DISPLAY"; nametemplate=%s.mp3
audio/x-scpls; rhythmbox-client --play-uri='%s'; description="MP3 ShoutCast playlist"; test=test -n "$DISPLAY"; nametemplate=%s.pls

By the way, I did change it just like that, and it does not work, I don't know why. Can someone help on that?

2- Ask the programmer to have RB accept a default command line argument as a URL or PATH to the music. Just like "ps" show up here.

> By the way, I did change it just like that, and it does not work, I don't know why. Can someone help on that?

Did you run update-mime?

/usr/lib/mime/packages/* are used for creating /etc/mailcap.

I don't know if GNOME/KDE apps make use of /etc/mailcap or have their own MIME database.

> Did you run update-mime?

I did not before but doing it does not change anything. Except it does change the /etc/mailcap file, but nothing on the execution of RB.

Sebastien Bacher (seb128) wrote :

the GNOME application use shared-mime-info and not mailcap

Sebastien : Is there a mime editing application in GNOME? I can found in kcontrol (KDE control management) something, but nothing for GNOME.

Sebastien Bacher (seb128) wrote :

what sort of modification do you want to do? There is no editor but you can change the default association using in the properties dialog

Well, let's say I want to change the default mime of .mp3 from "rythmbox $parameter" to "rhythmbox-client --play-uri=$parameter".

What would be the steps? Thanks.

Sebastien Bacher (seb128) wrote :

right click on a mp3 in nautilus, properties, open with tab, add a new command

Mmmm, that does not really work since I don't know how to have the mp3 file as a parameter. Is this stored in a file somewhere?

Sebastien Bacher (seb128) wrote :

that's written to a .desktop in the .local/share/applications directory

I think if we have the chance to get rhytmbox doing that correctly, we should release a patch for this problem. Because I think it should be as easy as it is in iTunes: You double-click on a mp3 file (or whatever), and Rythmbox opens and adds it to the library.

If we can, we should do so.

@Sebastien : There is no .local/share/applications/.desktop file. I am using Ubuntu, would that be different? There is a mime-cache file, but it is listing mp3 with totem witch is not the software running when clicking on a mp3 file.

Sebastien Bacher (seb128) wrote :

Alexandre, you want to use an use forum or list, the bug tracker is not made to ask user questions

Changed in rhythmbox:
importance: Low → Medium
status: Confirmed → Triaged
Jim White (jim-white) wrote :

Has this problem been fixed? Is there a workaround? Does another player correctly play .pls streams? Is this the correct place to ask these questions? Thanks.

I had this problem in Ubuntu 7.04 and it persists in 7.10. RB opens but doesn't do anything with the file. Here is where the pls link I am trying to play can be found:
http://minnesota.publicradio.org/radio/services/nis/streams.shtml

I just reread the above thread, and tried clicking on the pls link after RB was already running, and in that event the stream did load as a radio station and clicking on Play worked.

Sebastien Bacher (seb128) wrote :

You can look at the bug status to know if a bug has been fixed or not yet

discord (colin.williams) wrote :

rhythmbox doesn't do anything with .pls given on the command line... this is unfortunate... If I add some line to this file will it fix it? /usr/lib/mime/packages/rhythmbox . Still no fix in 7.10 :(

Gavin McCullagh (gmccullagh) wrote :

This works for me in gutsy:

rhythmbox-client --play-uri=http://minnesota.publicradio.org/tools/play/streams/the_current.pls

but I can't quite get the mailcap entry right for firefox to be able to launch it directly.

Trevor Schauls (trevorschauls) wrote :

  This bug affects all media files opened with rhythmbox. It will open files just fine once it's opened.

beerdoctor (beerdoctor) wrote :

rhythmbox is useless for playing internet radio, if I can not find a way to do this, I will permanently install Ubuntu Gutsy.

hdante (hdante) wrote :

Hi,

I think I'm having the same problem (I'm too lazy to read all the previous comments). I wan't to select a di.fm playlist file in my browser and I expect that rhythmbox (or any other player) load the playlist and start playing it (that is, a single click means start playing the playlist). Instead the following happens:

 1) go to di.fm, click in the playlist
 2) firefox asks me to open rhythmbox, because it's associated with the pls file
 3) rhythmbox starts and nothing happens, no playlist loaded, no playlist played (it even starts by default in the "songs" section, instead of the "radio" section)
 4) if I click the playlist again, firefox asks me again to open rhythmbox
 5) this time, rhythmbox adds the playlist.
 6) then, I can click in some new entry and the music starts.

 I'm using gutsy here, updated from feisty.

ddumanis (dave-davedumanis) wrote :

I can confirm this bug. It is a ridiculous bug, given that

(a) Rhythmbox is the default Gnome music manager/player, and
(b) That is has specific options for Internet Radio, i.e., it superficially appears to be .pls capable.

Like other posters, I can play a .pls by pasting in the URL (an inconvenient and unsatisfactory method)--but not via specifying a mimetype in Firefox nor by specifying "rhythmbox" in the preferences of Streamtuner.

James Neave (roboj1m) wrote :

Hi,

I'm running Ubuntu 7.10 and I'm also afflicted by this problem.
I've got a nice workaround though, to tide you over before a proper fix becomes available.
Firefox --> Edit --> Preferences --> Content --> Manage --> Double click PLS
Select Open With and set it to /usr/bin/totem

Now clicking on Tune In links on shoutcast will actually play some music.
And it doesn't keep opening multiple copies either (which is good)

I assume this needs all the relevant gstreamer plug-ins installed to make totem work though.

Regards,

J1M.

1. Rhythmbox does not really do anything with a local .pls file.
2. Opening the the .pls file in Totem opens and plays the file.

Possible solutions:
A. Add local .pls file support in Rhythmbox (requires a patch that adds functionality)
B. Associate the .pls file with Totem by default. (simple and logical, a good work around until Rhythmbox works as intended)
C. Make firefox pass the URLs to the mozilla-totem plugin.

Go with option B.

Changed in rhythmbox:
importance: Medium → Low
milestone: none → ubuntu-8.04
Recon (recon) on 2008-02-21
Changed in rhythmbox:
status: Triaged → Confirmed
Changed in rhythmbox:
status: Confirmed → Triaged
Changed in desktop-file-utils:
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.15-1ubuntu2

---------------
desktop-file-utils (0.15-1ubuntu2) hardy; urgency=low

  * debian/defaults.list:
    - add new x-content default associations
    - use totem rather than rhythmbox on playlists (lp: #62430)

 -- Sebastien Bacher <email address hidden> Thu, 13 Mar 2008 15:38:17 +0100

Changed in desktop-file-utils:
status: Confirmed → Fix Released
Changed in rhythmbox:
milestone: ubuntu-8.04 → none
Brewster Malevich (brews) wrote :

I got rhythmbox to play .pls just fine. The problem was that my firewall was preventing the cast from working. I opened the port in my firewall and it worked fine. I don't know that this is related to your problem, but it might help.

hawkes (hawkes) wrote :

This problem still occurs here with current up-to-date hardy and seems to be related to playlist that contains link to another playlist. I try to listen to http://smoothjazz.com/streams/smoothjazz_64.pls, which containts http://64.15.67.4/listen.pls

I find in the debug output a hint from gstreamer - no suitable decoder found for text/uri. Problem occurs with all Gstreamer related programs (Banshee, Totem, Rhythmbox) and i think its a problem of GstPlaybin - but i couldn't find a bug report.

Fully patched Intrepid.

Manually added radio station with url such as the following: http://www.di.fm/mp3/trance.pls

It says connecting at the bottom right corner of the window..... but nothing more.

oops, sorry. Please ignore my post. It works at home, so it must have been the firewall.

Charlie_Smotherman (cjsmo) wrote :

For what it's worth I Just tried to play a m3u playlist from my ampache instance on a fully updated jaunty install. I can not get rythmbox to import, or play the m3u playlist.

warelock (k36khqu02) wrote :

SOLVED

I got this to work. Here's the script:

-------

#!/bin/sh
rhythmbox $1
cat $1 | grep ^File | head -1 | awk -F= '{print $2}' | xargs -i rhythmbox-client --play-uri={}

-------

I installed this as /usr/local/bin/rhythmbox-wrapper and made it executable with chmod +x /usr/local/bin/rhythmbox-wrapper. Then, just click the pls file link on the website. When Firefox asks you what to do with the file, specify "other" and point to /usr/local/bin/rhythmbox-wrapper.

Cheers!

warelock (k36khqu02) wrote :

UPDATE

Sorry... A slight change is required:

-------

#!/bin/sh
rhythmbox $1 &
cat $1 | grep ^File | head -1 | awk -F= '{print $2}' | xargs -i rhythmbox-client --play-uri={}

-------

Charlie_Smotherman (cjsmo) wrote :

This is how I solved my problem

rythmbox + python-coherence + ampache == happy ubuntu user.

Sorry for the noise.

Kantastisk (kantastisk) wrote :

Can confirm that warelock's solution works on Intrepid 8.10 amd64, Rhythmbox 0.11.6
After using this method Rhythmbox needs to be closed and reopened before the new station appears.

Thanks, dude!

Amir Noel (rimaleon) wrote :

The problem seems to be related to the fact that the end of line in downloaded pls file is in microsoft format and not unix. I have downloaded a couple of pls files using wget and then replaced the end of line in them to with the command :% s/^V^M/\r/g and them opened the file in firefox from a webserver that I run locally and rhythmbox opens it up without any problems.

In the Jaunty Jackalope the error is still present.

Using 9.10 64bit. Also here, using the "open with" does not open the files in the folder with rhythmbox. I have to drag them manually to playlist.

"Video player" is working here, I mostly use this programm to play the files.

Changed in rhythmbox:
importance: Unknown → Medium
imachine (m-jedrasik) wrote :

Still broken, fresh 10.10 install as of yesterday, updated, rhythmbox just fails to start playing anything, not only that, it closes, and it wiped my previous internet radio list contents.

what gives? ubuntu 32bit.

incidentally, it works @ home, where I too have 10.10 only 64bit and it's not a fresh install but been upgraded from 9.10 or so.

Josh (majik) wrote :

I don't understand why you would make an application that doesn't properly handle a particular file the default handler for that file.

I mean, someone had to have made a conscious decision at some point something along the lines of this: "Here is a .pls file. I'm creating an entry in the operating system's MIME database for the .pls file so it will open with Rhythmbox, even though I realize nothing will happen when the user opens the file. But I'm going to do it anyways."

I expect that it somehow involves a political decision to use Rhythmbox as the default media player because Rhythmbox is the iTunes of Ubuntu, ie a way of turning Linux into a cash machine for Jane Silber.

Bucic (bucic) wrote :

It's 2013 and I... can't believe this shit. Do you need my to run apport against THAT?

mIRROR (mirror-ftw) wrote :

bump

tags: added: raring
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.