Rhythmbox Last.fm plugin only scrobbles first song when listen to radio

Bug #594245 reported by bmaupin on 2010-06-14
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Rhythmbox
New
Medium
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

I upgraded to Ubuntu 10.04, and now my Last.fm plugin in Rhythmbox will only scrobble the first song when I'm listening to Last.fm radio. Otherwise, it seems to work just fine.

I'm using rhythmbox 0.12.8-0ubuntu6, rhythmbox-plugins 0.12.8-0ubuntu6

To test it, I just listened to the radio station "Artists similar to the stills." I listened to these songs:

Malajube - Jus De Canneberges
Land of Talk - Some Are Lakes
Two Hours Traffic - Territory
The Most Serene Republic - A Mix of Sun and Cloud
French Kicks - The Trial Of The Century

While the first one was playing, I looked at my profile on last.fm, and it said:

Malajube - Jus De Canneberges Listening now

When the song finished, it said:

Malajube - Jus De Canneberges Just listened

But none of the other songs ever showed up, either while I was listening to them or after.

It looks like other people are having the same problems, but as far as I can tell, nobody else has filed a bug report:

http://ubuntuforums.org/showthread.php?t=1477589
http://ubuntuforums.org/showthread.php?t=1417335
http://www.last.fm/group/Rhythmbox/forum/8096/_/595864/2#f12485140

I'm also attaching the output of this command, which I ran to do the above test:
rhythmbox -D audioscrobbler &> rhythmbox-debug2.txt

It looks like for each song, I get these lines:
(11:39:10) [0x9d2040] [rb_audioscrobbler_song_changed_cb] rb-audioscrobbler.c:1146: new entry: <URL>
(11:39:10) [0x9d2040] [rb_audioscrobbler_is_queueable] rb-audioscrobbler.c:484: entry <URL> is queueable

I get that for all songs, even the ones that don't get scrobbled. For the first song, I also get other lines:
(11:39:10) [0x9d2040] [rb_audioscrobbler_timeout_cb] rb-audioscrobbler.c:555: Sending now playing data
(11:39:10) [0x9d2040] [rb_audioscrobbler_perform] rb-audioscrobbler.c:696: Submitting to Audioscrobbler: s=0391c766b5ea4d9492538ed9742a4b14&a=Malajube&t=Jus%20De%20Canneberges&b=Trompe-L'oeil&l=58&n=0&m=
...
(the rest is in the log file)

I ran a similar test previously running this command. It gave different output, so I'm attaching it as well:
rhythmbox -D lastfm &> rhythmbox-debug.txt

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: rhythmbox 0.12.8-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Mon Jun 14 10:38:44 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: rhythmbox

bmaupin (bmaupin) wrote :
bmaupin (bmaupin) wrote :

I'm wondering if instead of running rhythmbox -D lastfm or rhythmbox -D audioscrobbler, something like this would be better:

rhythmbox -d 2>&1 | egrep "audioscrobbler|lastfm" > rhythmbox-debug.txt

I ran another test using that command (outputting to rhythmbox-debug3.txt), and I'm attaching the output here.

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
summary: - Rhythmbox Last.fm plugin only scrobbles first song
+ Rhythmbox Last.fm plugin only scrobbles first song when listen to radio
bmaupin (bmaupin) wrote :

This isn't a fix per se, but supposedly the last.fm plugin for Rhythmbox is being improved as part of the Google Summer of Code, so I look forward to seeing the end results:

http://www.omgubuntu.co.uk/2010/04/google-summer-of-code-projects-for.html
http://socghop.appspot.com/gsoc/student_project/show/google/gsoc2010/gnome/t127230759459

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of Rhythmbox is available on Maverick and we are wondering if this bug is still an issue for you with that version? Could you please test and comment back? Thanks in advance.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Jens Janssen (jayjay) wrote :

Problem still remains under Ubuntu 10.10.

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
Martin Stjernholm (msub) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=584804 is probably the upstream ticket for this bug. Just in case it isn't, I opened a new one https://bugzilla.gnome.org/show_bug.cgi?id=634020.

Pavelp (2pavelbox) wrote :

Rhytmbox 0.13.1
Bug still present.

Dave Fine (finerrecliner) wrote :

I'm seeing a similar problem (also using Rhythmbox 0.13.1).

Usually the last.fm plugin only scrobbles the first song and misses everything played after that. Sometimes it is able to scrobble correctly though. And one more observation: my last.fm profile will display the correct "listening now" track, but it usually won't save it in the history of my played tracks. I think I have the same issue the rest of you are seeing.

Martin Stjernholm (msub) wrote :

I never see the missing songs as "listening now" either. You might be affected by a different bug.

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New
Changed in rhythmbox (Ubuntu):
status: New → Triaged
Rhys (rimmington) wrote :

Identical problem in 11.04, Rhythmbox 0.13.3. No "listening now" on my profile either.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.