[FTBFS] rhythmbox tries to define "pause", which is already used by unistd.h

Bug #588076 reported by Martin Erik Werner on 2010-06-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: rhythmbox

Rhythmbox fails to build with the following error:

###
Making all in remote
make[3]: Entering directory `/tmp/buildd/rhythmbox-0.12.8/remote'
Making all in dbus
make[4]: Entering directory `/tmp/buildd/rhythmbox-0.12.8/remote/dbus'
\
# source='rb-client.c' object='rb-client.o' libtool=no
gcc -DHAVE_CONFIG_H -I. -I../.. -DGNOMELOCALEDIR=\""/usr/share/locale"\" -DG_LOG_DOMAIN=\"Rhythmbox\" -I../.. -I../../lib -I../../shell -I../../shell -DPIXMAP_DIR=\""/usr/share/pixmaps"\" -DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\""/usr/share"\" -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DDBUS_API_SUBJECT_TO_CHANGE -D_XOPEN_SOURCE -D__EXTENSIONS__ -D_BSD_SOURCE -g -O2 -g -Wall -O2 -c rb-client.c
rb-client.c:57: error: 'pause' redeclared as different kind of symbol
//usr/include/unistd.h:466: note: previous declaration of 'pause' was here
make[4]: *** [rb-client.o] Error 1
make[4]: Leaving directory `/tmp/buildd/rhythmbox-0.12.8/remote/dbus'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/buildd/rhythmbox-0.12.8/remote'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/buildd/rhythmbox-0.12.8'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/rhythmbox-0.12.8'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
###

"pause" is declared in <unistd.h> as such:
###
/* Suspend the process until a signal arrives.
   This always returns -1 and sets `errno' to EINTR.

   This function is a cancellation point and therefore not marked with
   __THROW. */
extern int pause (void);
###

renaming "pause" -> "rb_pasue" in rhythmbox remote/dbus/rb_client.c confirmed to work, builds and runs seemingly fine (after Bug #587534 is patched as well).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: rhythmbox 0.12.8-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.34-2.9-generic 2.6.34-rc7
Uname: Linux 2.6.34-2-generic i686
Architecture: i386
Date: Tue Jun 1 00:52:39 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
LogAlsaMixer: Error: command ['/usr/bin/amixer'] failed with exit code 1: amixer: Mixer attach default error: No such file or directory
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: rhythmbox

Martin Erik Werner (arand) wrote :
summary: - [FTBFS] rhythmbox tries to define "pause", which if already used by
+ [FTBFS] rhythmbox tries to define "pause", which is already used by
unistd.h
Micah Gersten (micahg) wrote :

Marking high since it's in main and can't build in dev release.

Changed in rhythmbox (Ubuntu):
importance: Undecided → High
status: New → Triaged
Micah Gersten (micahg) wrote :

Fixed in upstream commit: bd389d8

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Martin Erik Werner (arand) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your work on this issue, the fix has been uploaded by somebody while you were working on it though, closing the bug now

rhythmbox (0.12.8-1ubuntu2) maverick; urgency=low

  * debian/patches/02_pause_symbol.patch:
    - Fix FTBFS due to duplicate symbol in unistd.h

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: Unknown → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.