rhythmbox crashed with SIGSEGV in free()

Bug #553655 reported by Christopher "cv" on 2010-04-01
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

I use Lucid Lynx amd64 and installed all latest updates as of 2nd of April 12am(night). I previously reported other bugs and know that you like to ignore bugs but I still keep on reporting until they are fixed.

Rhythmbox crashed on start using Docky and pressing on the Rhythmbox logo.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: rhythmbox 0.12.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic x86_64
NonfreeKernelModules: wl nvidia
Architecture: amd64
CrashCounter: 1
Date: Fri Apr 2 00:19:45 2010
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcCmdline: rhythmbox
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f9063660dfd <free+29>: mov -0x8(%rdi),%rsi
 PC (0x7f9063660dfd) ok
 source "-0x8(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 free () from /lib/libc.so.6
 usb_destroy_configuration ()
 usb_free_dev () from /lib/libusb-0.1.so.4
 usb_find_devices () from /lib/libusb-0.1.so.4
 ?? () from /usr/lib/libmtp.so.8
Title: rhythmbox crashed with SIGSEGV in free()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Christopher "cv" (vchristopher) wrote :
visibility: private → public

StacktraceTop:
 *__GI___libc_free (mem=0x20) at malloc.c:3709
 usb_destroy_configuration (
 usb_free_dev (dev=0x20) at ../usb.c:293
 usb_find_devices () at ../usb.c:121
 init_usb () at libusb-glue.c:147

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Christopher "cv" (vchristopher) wrote :

As of 8pm 2nd of April, rhythmbox works again. This bug is closed.

Changed in rhythmbox (Ubuntu):
status: New → Fix Released
Christopher "cv" (vchristopher) wrote :

Ok SORRY, this bug is not fixed, my mistake. I analyzed the situation now, here it comes:

When rhythmbox is started without any music in the "Music" folder in ubuntu, it will crash, it will always crash.
After I added an album in the Music folder rhytmbox will find it and crash and the "Stores" menu is missing on the left side. If I start rhythmbox one more time "Stores" will come up and everything will work.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Christopher "cv" (vchristopher) wrote :
Download full text (6.8 KiB)

cv@cv-mbp:~$ rhythmbox
*** glibc detected *** rhythmbox: free(): invalid pointer: 0x00007f10d63995b8 ***
======= Backtrace: =========
/lib/libc.so.6(+0x775b6)[0x7f10d60925b6]
/lib/libc.so.6(cfree+0x73)[0x7f10d6098e53]
/lib/libusb-0.1.so.4(usb_destroy_configuration+0xc3)[0x7f10bee7d113]
/lib/libusb-0.1.so.4(usb_free_dev+0x9)[0x7f10bee7c8c9]
/lib/libusb-0.1.so.4(usb_find_devices+0xce)[0x7f10bee7cc9e]
/usr/lib/libmtp.so.8(+0x1caf5)[0x7f10bf0a0af5]
/usr/lib/libmtp.so.8(LIBMTP_Detect_Raw_Devices+0x1f)[0x7f10bf0a247f]
/usr/lib/rhythmbox/plugins/mtpdevice/libmtpdevice.so(+0x79b4)[0x7f10bf2d29b4]
/usr/lib/librhythmbox-core.so.0(rb_marshal_OBJECT__OBJECT+0x98)[0x7f10db42cec8]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x15e)[0x7f10d715c5de]
/usr/lib/libgobject-2.0.so.0(+0x21598)[0x7f10d7170598]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x639)[0x7f10d71718b9]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x83)[0x7f10d7172033]
/usr/lib/librhythmbox-core.so.0(+0x5979a)[0x7f10db3af79a]
/usr/lib/librhythmbox-core.so.0(rb_removable_media_manager_scan+0x20d)[0x7f10db3afa1d]
/usr/lib/librhythmbox-core.so.0(+0x48235)[0x7f10db39e235]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1f2)[0x7f10d6aa38c2]
/lib/libglib-2.0.so.0(+0x42748)[0x7f10d6aa7748]
/lib/libglib-2.0.so.0(g_main_loop_run+0x195)[0x7f10d6aa7c55]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xa7)[0x7f10da601af7]
rhythmbox(main+0x3cb)[0x403e8b]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7f10d6039c4d]
rhythmbox[0x403919]
======= Memory map: ========
00400000-00408000 r-xp 00000000 08:05 2493806 /usr/bin/rhythmbox
00607000-00608000 r--p 00007000 08:05 2493806 /usr/bin/rhythmbox
00608000-00609000 rw-p 00008000 08:05 2493806 /usr/bin/rhythmbox
00e37000-01fe3000 rw-p 00000000 00:00 0 [heap]
7f10b8431000-7f10b8470000 r-xp 00000000 08:05 2490923 /usr/lib/libibus.so.1.0.0
7f10b8470000-7f10b8670000 ---p 0003f000 08:05 2490923 /usr/lib/libibus.so.1.0.0
7f10b8670000-7f10b8672000 r--p 0003f000 08:05 2490923 /usr/lib/libibus.so.1.0.0
7f10b8672000-7f10b8673000 rw-p 00041000 08:05 2490923 /usr/lib/libibus.so.1.0.0
7f10b8673000-7f10b8674000 rw-p 00000000 00:00 0
7f10b8674000-7f10b8679000 r-xp 00000000 08:05 2490959 /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so
7f10b8679000-7f10b8879000 ---p 00005000 08:05 2490959 /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so
7f10b8879000-7f10b887a000 r--p 00005000 08:05 2490959 /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so
7f10b887a000-7f10b887b000 rw-p 00006000 08:05 2490959 /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so
7f10b887b000-7f10b8889000 r-xp 00000000 08:05 2627589 /usr/lib/rhythmbox/plugins/visualizer/libvisualizer.so
7f10b8889000-7f10b8a88000 ---p 0000e000 08:05 2627589 /usr/lib/rhythmbox/plugins/visualizer/libvisualizer.so
7f10b8a88000-7f10b8a89000 r--p 0000d000 08:05 2627589 /usr/lib/rhythmbox/plugins/visualizer/libvisualizer.so
7f10b8a89000-7f10b8a8a000 rw...

Read more...

Christopher "cv" (vchristopher) wrote :

Right now rhymthbox crashes on start up every time(see above log). I switched to banshee now since this works.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete

...well...

I did the valgrind log but have to say that rhythmbox didn't crash this time, I have no idea why it worked this time...

Valgrind-Log: http://hanfi.net/ubuntu/valgrind.log (launchpad didn't work) ;-)

My Internet connection is really unstable, it will take a while until the above link is actually working..

Sebastien Bacher (seb128) wrote :

could you try to gzip the file and add it to launchpad? or get a log without the leak-check option it's not required for a crash

Link works now. Good Luck finding the bug.

Sorry, I didn't understand your #12 omment? Could you tell me the command line to use?

Sebastien Bacher (seb128) wrote :

The log has an error indeed but lacks gtk debug symbols, could you get a new one with libgtk2.0-0-dbg installed? you can use the wiki valgrind line without the --leak-check option listed to have a short log and gzip that one too if needed that should let you upload the log to launchpad too

Ok I'll do this, it will be up today in a few minutes. (I like to add that if I launch the program with valgrind then it doesn't crash but if I launch the program form the menu or from the commandline (using rhythmbox or /usr/bin/rhythmbox) then it crashes on start up)

Sebastien Bacher (seb128) wrote :

> launch the program with valgrind then it doesn't crash

right, valgrind often workaround the crashing but lists errors anyway in the log

Sebastien Bacher (seb128) wrote :

the new logs have errors in libusb and in the mtp devices detection code but lacks symbols for those, I will have a look locally if the issue is happening there too later

Changed in rhythmbox (Ubuntu):
status: Incomplete → New

OK sounds "good". I'll check this bug very regularly, keep me informed if you make progress or need anything else from me.

Sebastien Bacher (seb128) wrote :

the issue could be bug #557623

Sebastien Bacher (seb128) wrote :

do you get the crash if you don't use the mtp option?

Pardon...

...How can I launch the program without the mtp option?

Sorry I don't do these things normally, so I'm not sure what to do, please explain me the command line. Thanks.

Sebastien Bacher, thanks for your effort. I understood now how to add the missing debug files and did a complete valgrind log now. I hope this helps you. (I also understood now how to tar.gz) ;-)

Sebastien Bacher (seb128) wrote :

you can browse apps, rhythmbox and change options in gconf-editor, thanks for the logs I think we have the details required now

Well... ...at the moment rhythmbox is not crashing at all, with or without the mtpdevice option ;-)

...but it's good to hear that you found the problem, I hope this is fixed before Lucid Final release.

Thanks and bye.

Pedro Villavicencio (pedro) wrote :

Are you still getting the crash ? Please do test and comment back, per your last comment seems to be that this is no longer an issue but we'd like to have a confirmation about that. thanks.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete

I will install beta 2 right now and tell you more afterwards. Right now rhythmbox is working but this is (in my opinion) only the case because I installed all possible debug files, so these debug files seem to skip the bug.

I think it's impolite to mark this bug as incomplete after all my effort with the valgrind logs. This is the most complete report ever.

I installed beta 2 now on the same MacBook Pro (I use a MacBook Pro by the way) and rhythmbox still crashes on startup. It is the same bug like before. This bug still exists and is not fixed.

I can also now definitely say that rhythmbox starts with no problems if the mtpdevice option is disabled using gconf-editor.
This is definitaly a mtpdevice bug.
100% sure.

If this option is enabled, rhythmbox crashes.

If this option is disabled, rhythmbox works.

Sebastien Bacher (seb128) wrote :

> I think it's impolite to mark this bug as incomplete after all my effort with the valgrind logs. This is the most complete report ever.

Sorry about that, there is some hundred bugs opened on rhythmbox and some thousand and desktop bugs and just some triagers which they do what they can with this quantity of informations. Yesterday the busquad had a rhythmbox triaging day and Pedro checked on quite some bugs for an update. Ideally we could spend one hour on every bug report to work on the issue and read every detail but it would require a lot extra capacity in the team compared to what we have so triaging is sometime done a bit quickly and errors are happening, reopening your now

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
status: New → Confirmed

Any progress developers? Rhythmbox is still crashing for me. I thouht it maybe a MacBook Pro issues, since it has quite a lot issues under Ubuntu (which is a shame)

Sebastien Bacher (seb128) wrote :

the issue is not due to the macbook configure no, but to hundred of thousand bugs which are open on launchpad right now and only a bunch of people are working on those, this one is non trivial and not the most urgent issue for lucid, it might take a while before it's worked, sorry that the software doesn't work great for you bug there is just lot to do and not so many people to do it

Alex Tomic (atomic777) wrote :

There is this link posted for what looks like the same issue:

http://speeves.erikin.com/2010/05/ubuntu-lucid-macbook-rhythmbox.html

This person also gets the problem on a Macbook pro, and, surprise, I have a Macbook pro and am experiencing the same issue.

Setting /apps/rhythmbox/plugins/mtpdevice/active = false in gconf-editor fixed the problem for me as well.

speeves (speeves) wrote :

Thanks for your note, Alex. I went looking through my comments, and it appears that we are missing:
sudo apt-get install libgnomevfs2-extra

Which fixed my problem. It adds the smb module for Gnome VFS:
* the smb module, to browse Windows shares.

http://packages.ubuntu.com/lucid/libgnomevfs2-extra

So it makes sense that turning off mtpdevice support, (which is a Microsoft protocol (http://www.directionsonmicrosoft.com/sample/DOMIS/update/2004/10oct/1004mpumsf_sb.htm)), in gconf-editor would stop the segfault issue. The fix for this problem is to add libgnomevfs2-extra as a dependency to rhythmbox-plugins.

Sebastien Bacher (seb128) wrote :

gnomevfs is not used by rhythmbox for over a year now, the comment indicated in the previous comment is of no use in lucid

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers