rhythmbox crashed with SIGSEGV on startup

Bug #549986 reported by wedderburn on 2010-03-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

crash on startup

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: rhythmbox 0.12.7git20100325-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
Architecture: i386
CrashCounter: 1
Date: Sun Mar 28 12:08:27 2010
ExecutablePath: /usr/bin/rhythmbox
ProcCmdline: rhythmbox
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x2131d0: mov %edx,0x20(%edi,%eax,4)
 PC (0x002131d0) ok
 source "%edx" ok
 destination "0x20(%edi,%eax,4)" (0x084e7f94) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? () from /lib/ld-linux.so.2
 ?? () from /lib/ld-linux.so.2
 ?? () from /lib/ld-linux.so.2
 ?? () from /lib/ld-linux.so.2
 ?? () from /lib/ld-linux.so.2
Title: rhythmbox crashed with SIGSEGV
UserGroups: adm admin audio bin cdrom couchdb dialout dip floppy fuse lpadmin mysql mythtv netdev plugdev powerdev pulse sambashare scanner vboxusers video
XsessionErrors:
 (polkit-gnome-authentication-agent-1:6357): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (bluetooth-applet:6356): Gtk-CRITICAL **: gtk_action_set_sensitive: assertion `GTK_IS_ACTION (action)' failed
 (rhythmbox:8471): Rhythmbox-WARNING **: Unable to grab media player keys: Could not get owner of name 'org.gnome.SettingsDaemon': no such name
 (rhythmbox:9175): Rhythmbox-WARNING **: Unable to grab media player keys: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

wedderburn (andrew-wedderburn) wrote :
visibility: private → public
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium

StacktraceTop:
 _dl_map_object_from_fd (name=<value optimized out>,
 _dl_map_object (loader=0x0,
 openaux (a=0xbfab5a28) at dl-deps.c:65
 _dl_catch_error (objname=<value optimized out>,
 _dl_map_object_deps (map=<value optimized out>,

tags: removed: need-i386-retrace
Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug.
Is this reproducible? If so, what specific steps should we take to recreate this bug?

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Morgan Collett (morgan) wrote :

Happens for me every time I start rhythmbox. First time I managed to click on Ubuntu One Music Store and then it crashed, but on subsequent attempts to open it, it crashes anyway within a second of the GUI opening whether or not I click on anything.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Sergio Barjola (sbarjola) wrote :

It crash to me too. Test case:

- Open rhythmbox and select Ubuntu One Music Store and exit.
- Next time that init it crash.
- Second time load ok.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Sergio Barjola (sbarjola) wrote :

I've test in Ubuntu Natty and still it's present, but now, I'm thinking that maybe it's not the same original bug reporter bug.

When I close rhythmbox and open it again (1 second after), it crash: next open after crash run ok. (Don't worry if you select ubuntu one music or not).

I've tryed to obtain a backtrace, but running from a terminal not crash.
 I think that could be a problem with the time needed to shutting down the application. From terminal, I have to wait some time from I click close and I get the command line control.

Pedro Villavicencio (pedro) wrote :

it's probably not the same, could you please enable apport and report a new bug? it's better to have separate bugs for each crash, thanks in advance. Btw i'm closing this one for now.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers