Rhythmbox Magnatune fails to load catalog in 10.04

Bug #548693 reported by mihai.ile on 2010-03-26
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

I am testing 10.04 beta1 live CD and rhythmbox fails to load magnatune catalog, just sits there and telling "Loading magnatune catalog", it does not freezes, but the catalog never comes.
I saw on other bugs like this that a "mkdir ~/.cache/rhythmbox/magnatune" resolved the issue, well in this case it did not change anything. Still fails to load the catalog.
I even tried using opendns, thought it could be something wrong with isp, but magnatune page is available in firefox, Also at the same time Ubuntu One music store does not have any problems in loading catalog/playing songs.

This bug is important as 10.04 ships with ubuntu one store and it will draw more attention to rhythmbox stores, and having a buggy magnatune plugin along with ubuntu's one working is just not fair!
What is this, a marketing decison? "We make sure Ubuntu one works while the others dont't and so we sell more!?"

Can someone confirm this bug in 10.04?

ProblemType: Bug
Architecture: amd64
Date: Fri Mar 26 10:12:29 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/rhythmbox
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: rhythmbox 0.12.7-0ubuntu5
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.32-16-generic x86_64

mihai.ile (mihai.ile) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Sergio Barjola (sbarjola) wrote :

confirmed in Ubuntu 10.04 beta1.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Sergio Barjola (sbarjola) wrote :

it's fixed in version 0.12.8.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Changed in rhythmbox:
status: Unknown → Fix Released
sabby (sabby) wrote :

Just to add to this bug, it was still a bug for me in 0.12.8 even after the fix was release, using the debug I found out the following problem

(08:59:48) [0x828040] [UpdateCheck.check_for_update] /usr/lib/rhythmbox/plugins/rb/Loader.py:350: error checking for update: Error stating file '/home/<user>/.cache/rhythmbox/magnatune/song_info.xml': No such file or directory

after doing a touch to the file stated above song_info.xml the catalog loaded without a problem. I don't have an account on gnome so if someone could pass on the info to them it would be very much appreciated. thanks.

Tomasz Chrzczonowicz (tch) wrote :

I confirm this bug isn't fixed in 0.12.8-0ubuntu7

And sabby's fix works for me too.

sabby (sabby) wrote :

Could we perhaps change this bug back to confirmed? Or should we open another bug?

Changed in rhythmbox:
importance: Unknown → Medium
Marco Schmidt (hockenberry) wrote :

After updating to ubuntu 10.10 I can confirm this bug in 10.10 too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.