rhythmbox-metadata crashed with SIGSEGV in g_slist_prepend()

Bug #543112 reported by Uphaar Agrawalla on 2010-03-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

Changed the tag of an MP3. Crash occurred after I closed the Properties box.

ProblemType: Crash
Architecture: amd64
Date: Sun Mar 21 00:42:34 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/rhythmbox/rhythmbox-metadata
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.7-0ubuntu7
ProcCmdline: /usr/lib/rhythmbox/rhythmbox-metadata unix:tmpdir=/tmp
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SegvAnalysis:
 Segfault happened at: 0x7fb422c0ccde <g_slist_prepend+30>: mov %rbp,(%rax)
 PC (0x7fb422c0ccde) ok
 source "%rbp" ok
 destination "(%rax)" (0x7fb4245820d8) in non-writable VMA region: 0x7fb4244d1000-0x7fb42459f000 r-xp /usr/lib/libgstreamer-0.10.so.0.24.1
SegvReason: writing VMA /usr/lib/libgstreamer-0.10.so.0.24.1
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 g_slist_prepend () from /lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/libgobject-2.0.so.0
 g_object_new_valist ()
 g_object_new () from /usr/lib/libgobject-2.0.so.0
Title: rhythmbox-metadata crashed with SIGSEGV in g_slist_prepend()
Uname: Linux 2.6.32-16-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Uphaar Agrawalla (uphaar) wrote :
visibility: private → public
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium

StacktraceTop:
 g_slist_find () from /lib/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/libgobject-2.0.so.0

Changed in rhythmbox (Ubuntu):
status: New → Invalid
Download full text (3.4 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1: installed version 1:4.4.3-3ubuntu3, latest version: 1:4.4.3-4ubuntu4
libuuid1: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
libk5crypto3: installed version 1.8+dfsg~alpha1-7, latest version: 1.8+dfsg~alpha1-7ubuntu1
libudev0: installed version 151-5, latest version: 151-6
libxrandr2: installed version 2:1.3.0-2build1, latest version: 2:1.3.0-3
libcups2: installed version 1.4.2-9, latest version: 1.4.2-10
libpango1.0-common: installed version 1.26.2-1, latest version: 1.26.2-1ubuntu1
sysv-rc: installed version 2.87dsf-4ubuntu15, latest version: 2.87dsf-4ubuntu16
libgtk2.0-common: installed version 2.19.7-0ubuntu1, latest version: 2.20.0-0ubuntu2
klibc-utils: installed version 1.5.15-1ubuntu4, latest version: 1.5.17-4ubuntu1
libpango1.0-0: installed version 1.26.2-1, latest version: 1.26.2-1ubuntu1
gvfs: installed version 1.5.5-0ubuntu1, latest version: 1.5.5-0ubuntu2
libglib2.0-0: installed version 2.23.5-1ubuntu3, latest version: 2.23.6-1ubuntu1
libgail18: installed version 2.19.7-0ubuntu1, latest version: 2.20.0-0ubuntu2
libklibc: installed version 1.5.15-1ubuntu4, latest version: 1.5.17-4ubuntu1
libgtk2.0-bin: installed version 2.19.7-0ubuntu1, latest version: 2.20.0-0ubuntu2
cpp-4.4: installed version 4.4.3-3ubuntu3, latest version: 4.4.3-4ubuntu4
libc-bin: installed version 2.11.1-0ubuntu4, latest version: 2.11.1-0ubuntu5
libxi6: installed version 2:1.3-2, latest version: 2:1.3-3
libgvfscommon0: installed version 1.5.5-0ubuntu1, latest version: 1.5.5-0ubuntu2
libgssapi-krb5-2: installed version 1.8+dfsg~alpha1-7, latest version: 1.8+dfsg~alpha1-7ubuntu1
util-linux: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
libgnome-keyring0: installed version 2.29.4git20100224-0ubuntu2, latest version: 2.29.4git20100322-0ubuntu2
udev: installed version 151-5, latest version: 151-6
mount: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
rhythmbox: installed version 0.12.7-0ubuntu7, latest version: 0.12.7git20100325-0ubuntu1
libstdc++6: installed version 4.4.3-3ubuntu3, latest version: 4.4.3-4ubuntu4
libc6: installed version 2.11.1-0ubuntu4, latest version: 2.11.1-0ubuntu5
libblkid1: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
gcc-4.4-base: installed version 4.4.3-3ubuntu3, latest version: 4.4.3-4ubuntu4
libgtk2.0-0: installed version 2.19.7-0ubuntu1, latest version: 2.20.0-0ubuntu2
sysvinit-utils: installed version 2.87dsf-4ubuntu15, latest version: 2.87dsf-4ubuntu16
libkrb5-3: installed version 1.8+dfsg~alpha1-7, latest version: 1.8+dfsg~alpha1-7ubuntu1
libcomerr2: installed version 1.41.10-1ubuntu3, latest version: 1.41.11-1ubuntu1
initscripts: installed version 2.87dsf-4ubuntu15, latest version: 2.87dsf-4ubuntu16
libatk1.0-0: installed version 1.29.92-0ubuntu1, latest version: 1.29.92-0ubuntu2
libgudev-1.0-0: installed version 1:151-5, latest version: 1:151-6
libkrb5support0: installed ve...

Read more...

tags: removed: need-amd64-retrace
Yuriy Vidineev (adeptg) on 2010-04-03
Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

why you're confirming a bug which was closed? Please do not do it without adding a comment explaining why.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers