Rhythmbox visualization freezes when one song finishes and another of the same format starts

Bug #534553 reported by Erik B. Andersen on 2010-03-08
100
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Rhythmbox
New
Medium
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

Rhythm boxes visualization freezes after playing one song.

To reproduce:
1. Open rhythmbox and add at least 2 songs to the play queue (some of the tests will need four or five).
2. Turn on the visualization.
3. Wait for the first song to finish playing (or even skip to close to the end).
4. Notice that the visualization freezes, even though the second song has started.
5. Click the visualization button on and off and notice the visualization is still frozen, but changes every time you cycle the visualization button.
6. Clear the play queue and start a song (if one doesn't start automatically).
7. Notice that the visualization runs faster than normal.
8. Close rhythmbox.

9. Repeat steps 1-3, except press the next button right before the end of the first song and notice that visualization doesn't freeze when the next (second) song starts. At the end of this next song, notice the visualization doesn't freeze on the third or any subsequent songs, except between albums.
10. Close rhythmbox.

11. Repeat steps 1-5, stopping with the visualization enabled.
12. Click next.
13. Notice the visualization unfreezes (and of course, you are taken to the next song), and that no subsequent song changes cause the visualization to freeze, except between albums.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: a869e808e24f1cd12a0b9ddfb6a9e84b
CheckboxSystem: fd6c484c0b5d20a2f1cd036ef0f63975
Date: Mon Mar 8 09:58:58 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.5-0ubuntu5.2
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/zsh
 LANG=en_US.UTF-8
 LC_CTYPE=C
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-20-generic x86_64

Erik B. Andersen (azendale) wrote :
description: updated
description: updated
description: updated
description: updated
description: updated
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
tags: added: likely-dup
tags: added: karmic
summary: - Rhythmbox visualization freezes when one song finishes and another
- starts
+ Rhythmbox visualization freezes when one song finishes and another of
+ the same format starts
Captain Chaos (launchpad-chaos) wrote :

I removed the likely-dup tag since there was no indication *which* bug it was supposed to be a likely duplicate of. If you want to add it back please indicate the bug in question.

Also I would like to request a higher importance. Visualisation is a core component, and it breaks completely after playing just one song; that's not a minor problem IMHO.

tags: removed: likely-dup
Sebastien Bacher (seb128) wrote :

the goal of the tag is to indicate that the bug is likely a duplicate without spending hours looking for number, if we had the number it would be closed as duplicate

tags: added: iso-testing
Pedro Villavicencio (pedro) wrote :

looks like bug 469481

Erik B. Andersen (azendale) wrote :

@Pedro Villavicencio
The bugs seem similar once it has frozen. Before that, they are different.

For example, in the other bug, the visualizations show one frame and then freeze. In this bug, the visualizations go for a whole song and then freeze when the next song happens to be the same format. (It was mp3 or ogg in this case). However, once the freeze occurs, it acts partially the same since when you disable and then re-enable the song the visualization updates once, so you get a new frame but no movement.

So, I don't really think they are the same bug, but if they figure out how to fix the other bug or vice versa, it might help fix this bug.

(I wonder if when the visualization is not working as described in both bugs when rhythmbox is in the same/similar state as the other bug, and these two bugs are two different ways to get to the same state/similar state. Is that possible? Or do I have no idea what I'm talking about?)

Erik B. Andersen (azendale) wrote :

@Captian Chaos:
If you are having this bug happen to you, and you think this bug is important, then you could set it to confirmed. I can't do that because I'm the one who reported the bug.
Thanks!

Pedro Villavicencio (pedro) wrote :

you're welcome to open a new bug at bugzilla.gnome.org i cannot reproduce the issue here.

Matt Pharoah (mr-exuberant) wrote :

I've had this issue both in 9.10 and 10.4 and was able to reproduce it on 2 different computers. It behaves for me exactly as you described every time.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
gare-calhoun (gare-calhoun) wrote :

confirm this bug on an HP quad AMD

Architecture: amd64
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: rhythmbox 0.12.5-0ubuntu5.2
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-22.60-generic
Uname: Linux 2.6.31-22-generic x86_64
UserGroups:

tags: added: apport-collected
komputes (komputes) wrote :

I can confirm this issue in Lucid 10.04, as well as today's Maverick 10.10 daily image + updates.

Rhythmbox version being used is 0.13.0git20100715-0ubuntu8. Attached is a screen capture of the issue (also had to play around with song time line to get visualization to even start). After playing the first song it freezes on the second song.

Created upstream bug:
https://bugzilla.gnome.org/show_bug.cgi?id=627312

Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
importance: Unknown → Medium
Sniper (intuicje) wrote :

Turning on crossfading backend temporary solves the problem.

Dmitriy Kodanev (dkodanev) wrote :

Thank you for advice, Sniper. It did help me! But sure, it's not the real solution. It's just like a crutch for the time being. I wish this bug to be fixed.

johny (johny454) wrote :

I'm confirming this happening on a final stable 10.10 maverick installation.
Let me know if you need some information for better tracing.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Pablo (pjferra) wrote :

Same bug in ubuntu 9.10 and ubuntu 10.04 64bits, on an Acer Aspire 5738z.
I've noticed that using totem (the same pack of visualiations) the problem does not occur.
It's a really annoying bug, since I like to let music playing with a nice visualisation on the screen, but I cannot use rithmbox for it.

Pedro Villavicencio (pedro) wrote :

we do need someone to test it on Natty though, thanks.

Erik B. Andersen (azendale) wrote :

Still freezes after second song on Natty. Will unfreeze for less than a second every five seconds.

Pjorge1036 (pjorge1036) wrote :

Same in 10.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.