Time bar does not move with song progress

Bug #532827 reported by Reinhard Meyer on 2010-03-05
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

Playing songs from an external usb device.

Entry bug condition: Selecting cross-fade with time of 3 seconds under edit/preferences/play
Result: Play time is not correctly displayed in the main window and the time bar does not move with the song progress.

This bug can be switched off by de-activating the cross-fade option.

ProblemType: Bug
Architecture: i386
Date: Fri Mar 5 18:58:22 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
NonfreeKernelModules: wl
Package: rhythmbox 0.12.5-0ubuntu5.2
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: rhythmbox
Tags: ubuntu-unr
Uname: Linux 2.6.31-19-generic i686

Reinhard Meyer (reinhard012) wrote :
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Matthew Farrell (themattatk) wrote :

This effects me as well. However, it happens to any .mp3 file that rhythmbox plays (with the cross-fade on), not just external usb devices. This does not effect my .ogg or .m4A files.

As with Reinhard, the problem ceases when I turn cross-fading off.

I am running Ubuntu 10.04 virtually via Parallels. It was a fresh install, not an upgrade. My rhythmbox package is 0.12.8-0ubuntu3.

Kip Warner (kip) wrote :

I don't have crossfade enabled and I sometimes notice this problem as well. Running Lucid's Rhythmbox 0.12.8.

Marsel (atn-marsel) wrote :

I have this happening with podcasts, but ok with other files.
Play time is correctly displayed in the main window, but the time bar does not move with the song progress and I can not move it myself.
Crossfide option disabled.

Ubuntu 10.04
Linux marsel-laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
Rhythmbox 0.12.8
amd64
LANG = en_US.utf8

(Sorry for my bad English)

rupert (r-plumridge) wrote :

I have the same problem, for me it occurs constantly, I don't have cross fading turned on.

All my music is stored on a samba network folder...

Reproduction
-> Add music on a network share.
-> Play a track

Expected Behaviour
-> The Time Slider moves along showing the progression of the song as it plays and can be dragged to move to a specific place in the song.

Actual Behaviour
-> The Time Slider doesn't not move as the song plays, the time played indicator on the rhs increases, but the Slider stays stationary and can't be dragged.

Pausing and pressing play again works as expected.

I have attached the output of rhythumbox -d for what its worth.

Ubuntu 10.04
Rhythmbox 0.12.8

Marsel (atn-marsel) wrote :

> I have this happening with podcasts, but ok with other files.

I figured out that it is not only a podcast, when I copy a podcast to a folder with music, the bug manifested itself for the file in an ordinary browser window music.

link to an example of this mp3
http://myflex.org/yf/podru/budam208.mp3

Marsel (atn-marsel) wrote :

Works fine after the upgrade :)

Good job, thanks!

Kip Warner (kip) wrote :

Mine's still cooked. Lucid's 0.12.8.

Matthew Farrell (themattatk) wrote :

Strangely, I reinstalled Ubuntu 10.04, and the problem seems to have gone away. Maybe, as Marsel said, an upgrade took place that fixed it.

Whew, well, I'm happy now. : )

Wifiguy (alex-wifiguy) wrote :

Lucid Lynx 10.04
Rhythmbox 0.12.8-0ubuntu7
My music is on a encrypted LVM ext4 partition.
I don't have crossfade enabled.
Only affects mp3, ogg plays just fine
Rhythmbox progress bar problem persists using gstreamer0.10-plugins-bad, gstreamer0.10-plugins-ugly, and gstreamer0.10-ffmpeg.
The progress bar does not work when playing mp3's in Totem with gstreamer0.10-plugins-bad but does seem to work with gstreamer0.10-plugins-ugly.
I have not tried any of the multiverse plugins.

Omer Akram (om26er) wrote :

I cannot reproduce this bug in Ubuntu 10.10 cross-fade time is set to 3.0 i restart rhythmbox and progress bar still works fine. could anyone please try with Ubuntu 10.10?

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Sander Deryckere (sanderd17) wrote :

I never noticed the problem in 10.04 (I can't remember if crossfade was enabled there), but I have the problem in 10.10:

crossfade + mp3 file results in not moving timebar.

Celsius1414 (celsius1414) wrote :

I have the problem in 10.10, but not in 10.04. Turning off crossfading and restarting Rhythmbox fixes the issue for me.

Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
Indra Ginanjar (indraginanjar) wrote :

No problem with rhythmbox on ubuntu lucid 10.04

But,
2 weeks ago i have fresh installed ubuntu maverick 10.10 (ubuntu desktop iso i've downloaded doesn't support upgrading).
Then problem arise, time slider doesn't move at all, while the play time works.

I've upgraded to rhythmbox 0.13.1-0 still the problem persist.

I noticed that a small number of mp3 files could be played without having this time slider problem. I have all gstreamer plugins 0.10 (the latest, as far as i know) installed, except the "bad" set. So i suspecting this is the source of the problem. Then i installed the "bad" set with hope this could solve the problem.
But, the problem still there.

angus73 (angus73) wrote :

Problem also happens to me with Rhythmbox 0.12.8 in Lucid x64, with cross-fade disabled, but only with some mp3 files.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers