rhythmbox-metadata assert failure: *** glibc detected *** /usr/lib/rhythmbox/rhythmbox-metadata: double free or corruption (fasttop): 0xb6d004c0 ***

Bug #532607 reported by Rus F Adrian on 2010-03-05
210
This bug affects 39 people
Affects Status Importance Assigned to Milestone
GStreamer
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Lucid by igi

Bug Description

Binary package hint: rhythmbox

* apt-cache policy rhythmbox
* rhythmbox:
 * Installed: 0.12.7-0ubuntu4
  * Candidate: 0.12.7-0ubuntu4
    * Version table:
 *** 0.12.7-0ubuntu4 0
       * 500 http://archive.ubuntu.com lucid/main Packages
       * 100 /var/lib/dpkg/status

Everytime i wanna change the song information rhythmbox crash.

Gives the error :
" Error while saving song information
Unable to create tag-writing elements "

ProblemType: Crash
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/lib/rhythmbox/rhythmbox-metadata: double free or corruption (fasttop): 0xb6d004c0 ***
Date: Fri Mar 5 14:34:09 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/rhythmbox/rhythmbox-metadata
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100305)
Package: rhythmbox 0.12.7-0ubuntu4
ProcCmdline: /usr/lib/rhythmbox/rhythmbox-metadata unix:tmpdir=/tmp
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
Signal: 6
SourcePackage: rhythmbox
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
Title: rhythmbox-metadata assert failure: *** glibc detected *** /usr/lib/rhythmbox/rhythmbox-metadata: double free or corruption (fasttop): 0xb6d004c0 ***
Uname: Linux 2.6.32-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public

StacktraceTop:
 __kernel_vsyscall ()
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:92
 __libc_message (do_abort=2,
 malloc_printerr (action=<value optimized out>,

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
PaiSand (paisand) wrote :

I have the same problem, but the difference is that I was using Mp3tag (on wine) to change the song info.

PaiSand (paisand) wrote :

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
Package: rhythmbox 0.12.8-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic-pae 2.6.32.10+drm33.1
Tags: lucid
Uname: Linux 2.6.32-19-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

apport information

apport information

apport information

apport information

igi (igor-cali) wrote : XorgLog.txt

apport information

Marcelo (marceloramone-gmail) wrote :

I have the same problem and can not edit the mp3 tags...

Jason J. Herne (hernejj) on 2010-04-08
Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

could somebody still having the issue please install the rhythmbox, gstreamer*, libglib2, libgtk2 dbgsym packages and get a new log? the one submitted is missing a lot of symbols, thanks in advance.

PaiSand (paisand) wrote :

ok, I installed those packages and did another Valgrid log

igi (igor-cali) wrote :
affects: rhythmbox → gstreamer
Miguel Mendes Ruiz (migmruiz) wrote :

I've got similar error, as described on Bug #573907

the difference to me is that my rhythmbox keeps running after it gives the error message

igi (igor-cali) wrote :

Still having this issue on lucid.

I have this issue as well... Whenever I try to change the artists name rhythmbox gives this "ERROR WHILE SAVING SONG INFORMATION: Unable to create tag-writing elements" I even ran rhythmbox as root and it still gave the error

Tommy Brunn (tommybrunn) wrote :

I have the same issue Urock described, but like Miguel Mendes Ruiz, Rhythmbox keeps running. This is also in Lucid.

Adam (adam-jackman) wrote :

I am getting the same. When running rhythmbox with the --debug flag it just states:

(10:16:20) [0x18a8040] [rhythmdb_process_stat_event] rhythmdb.c:2162: not modified:

Followed by the full address of the file. I have checked the file permissions and I have full read and write privileges.

Adam (adam-jackman) wrote :

The issue appears to be restricted to Rhythmbox as I am still able to edit the tags in Banshee.

David Baucum (maxolasersquad) wrote :

I got this error when changing the tags on any of the MP3s found at http://www.floridamemory.com/collections/folklife/folklife_cd2.cfm. However, I can modify the tags of any of the MP3s found at http://www.floridamemory.com/collections/folklife/folklife_cd4.cfm without any error message.

Id2ndR (id2ndr) wrote :
Download full text (6.6 KiB)

Here is my last stacktrace (Ubuntu 10.10)

*** glibc detected *** rhythmbox: double free or corruption (out): 0x00007fdc5c191ff0 ***
======= Backtrace: =========
/lib/libc.so.6(+0x774b6)[0x7fdc6fd404b6]
/lib/libc.so.6(cfree+0x73)[0x7fdc6fd46c83]
/lib/libglib-2.0.so.0(g_strfreev+0x25)[0x7fdc70773e55]
/usr/lib/librhythmbox-core.so.1(+0x8cc6b)[0x7fdc7534dc6b]
/usr/lib/librhythmbox-core.so.1(rb_metadata_load+0xe6)[0x7fdc7534e966]
/usr/lib/librhythmbox-core.so.1(+0xab3a1)[0x7fdc7536c3a1]
/lib/libglib-2.0.so.0(+0x697e4)[0x7fdc7077c7e4]
/lib/libpthread.so.0(+0x7971)[0x7fdc71055971]
/lib/libc.so.6(clone+0x6d)[0x7fdc6fdaf91d]
======= Memory map: ========
00400000-00408000 r-xp 00000000 08:05 261496 /usr/bin/rhythmbox
00607000-00608000 r--p 00007000 08:05 261496 /usr/bin/rhythmbox
00608000-00609000 rw-p 00008000 08:05 261496 /usr/bin/rhythmbox
01d7a000-04318000 rw-p 00000000 00:00 0 [heap]
7fdc499d5000-7fdc49bd5000 rw-p 00000000 00:00 0
7fdc49bd5000-7fdc49bd6000 ---p 00000000 00:00 0
7fdc49bd6000-7fdc4a3d6000 rw-p 00000000 00:00 0
7fdc4a3d6000-7fdc4a3d7000 ---p 00000000 00:00 0
7fdc4a3d7000-7fdc4abd7000 rw-p 00000000 00:00 0
7fdc4abd7000-7fdc4abdc000 r-xp 00000000 08:05 136646 /lib/libnss_dns-2.12.1.so
7fdc4abdc000-7fdc4addb000 ---p 00005000 08:05 136646 /lib/libnss_dns-2.12.1.so
7fdc4addb000-7fdc4addc000 r--p 00004000 08:05 136646 /lib/libnss_dns-2.12.1.so
7fdc4addc000-7fdc4addd000 rw-p 00005000 08:05 136646 /lib/libnss_dns-2.12.1.so
7fdc4addd000-7fdc4addf000 r-xp 00000000 08:05 130007 /lib/libnss_mdns4_minimal.so.2
7fdc4addf000-7fdc4afde000 ---p 00002000 08:05 130007 /lib/libnss_mdns4_minimal.so.2
7fdc4afde000-7fdc4afdf000 r--p 00001000 08:05 130007 /lib/libnss_mdns4_minimal.so.2
7fdc4afdf000-7fdc4afe0000 rw-p 00002000 08:05 130007 /lib/libnss_mdns4_minimal.so.2
7fdc4afe0000-7fdc4b040000 rw-s 00000000 00:04 1474584 /SYSV00000000 (deleted)
7fdc4b040000-7fdc4b080000 rw-p 00000000 00:00 0
7fdc4b084000-7fdc4b496000 rw-p 00000000 00:00 0
7fdc4b496000-7fdc4b497000 r-xp 00000000 08:05 270460 /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
7fdc4b497000-7fdc4b697000 ---p 00001000 08:05 270460 /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
7fdc4b697000-7fdc4b698000 r--p 00001000 08:05 270460 /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
7fdc4b698000-7fdc4b699000 rw-p 00002000 08:05 270460 /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
7fdc4b699000-7fdc4b69a000 ---p 00000000 00:00 0
7fdc4b69a000-7fdc4be9a000 rw-p 00000000 00:00 0
7fdc4be9a000-7fdc4bea8000 r-xp 00000000 08:05 404876 /usr/lib/rhythmbox/plugins/visualizer/libvisualizer.so
7fdc4bea8000-7fdc4c0a7000 ---p 0000e000 08:05 404876 /usr/lib/rhythmbox/plugins/visualizer/libvisualizer.so
7fdc4c0a7000-7fdc4c0a8000 r--p 0000d000 08:05 404876 /usr/lib/rhythmbox/plugins/...

Read more...

Anonymous (just-anonimous) wrote :

I have a similair problem. Placed music in folder home/me/Music/Alagna/Viva. "(invalid encoding)" was added automatically to the name of some of the unarchived files. When trying to open with right click->Open with Rhythmbox, it didn't open the "invalid encoding" files (it played the files which weren't added "invalid encoding"). After importing, Rhythmbox played all files.
Rhythmbox imports the music, but as unknown artist, unknown album. Tried to select all songs in album and change artist and album. Gives errors for every file and doesn't change artist and album name. Tried for each mp3 separately and it still gave error, but it changed artist/album name.
Tried to change the artist name of two(at the same time) of the mp3s which didn't have the "invalid encoding" appended at their names. It changed the artist/album names to "unknown". It seems the problem is not that artist/album names are not changed, It seems the problem is they ARE CHANGED TO "unknown".

Tried to do the same thing with another bunch of mp3s and sometimes it showed all of the following:
"Error while saving song information Internal Data stream error"
"Error while saving song information Internal GStreamer problem,; file a bug"
"Error while saving song information Internal Data stream error"
and it changed the artist/album just for some of the files. For the same bunch of mp3s, it sometimes workes for all the mp3s, sometimes just for some of them.

My suggestion would be to make Rhythmbox automatically know Folder1 is artist name and Folder2 is album name when finds a file in /home/me/Music/Folder1/Folder2.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete

Hi,

I don't use Rhythmbox now. Please, notice that I opened this bug 4 years ago!

So, I'm not able now to update the info, sorry. Maybe any other of the subscribers can do.

dino99 (9d9) wrote :

This version has expired

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Changed in gstreamer:
status: New → Invalid
To post a comment you must log in.