cannot change track information - Unable to create tag-writing elements

Bug #530372 reported by whocaresnotme on 2010-03-01
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

I'm unable to change the tags of the songs, message is:

(rhythmbox-metadata:2475): GStreamer-CRITICAL **:
Trying to dispose object "id3demux0", but it still has a parent "pipeline".
You need to let the parent manage the object instead of unreffing the object directly.

(rhythmbox-metadata:2475): GStreamer-CRITICAL **:
Trying to dispose object "id3v2mux0", but it still has a parent "pipeline".
You need to let the parent manage the object instead of unreffing the object directly.

(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:676: message of type state-changed from giostreamsink0
(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:676: message of type state-changed from typefindelement0
(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:676: message of type state-changed from urisrc
(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:676: message of type state-changed from pipeline
(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:614: got error message from typefindelement0
(20:06:14) [0x9643068] [rb_metadata_bus_handler] rb-metadata-gst.c:630: caught error: Unable to create tag-writing elements
(20:06:14) [0x9643068] [rb_metadata_dbus_save] rb-metadata-dbus-service.c:279: metadata error: Unable to create tag-writing elements
(20:06:14) [0x9643068] [send_error] rb-metadata-dbus-service.c:88: attempting to return error: Unable to create tag-writing elements
(20:06:14) [0x9c8aae8] [default_sync_metadata] rhythmdb.c:4779: error saving metadata for file:///media/cons/Music/Green%20Day/(2002)%20Pop%20Disaster%20Tour%202002/Green%20Day%20-17-%20Good%20Riddance.mp3: Unable to create tag-writing elements; reloading metadata to revert

whocaresnotme (notzenon) wrote :

I have the same problem on my Rhythmbox 0.12.5, Ubuntu 9.10.
Although the files I'm trying to modify are in WMA format.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

May you please attach an example to the report? Thanks.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Incomplete

Yes, I think this is reproducible.

The files should be in WMA format. The ones I had was ripped from a CD, unfortunately, on Windows. Transferred the files to Ubuntu machine then imported the whole folder to Ryhthmbox. Scrolled to the items, right-clicked and selected Properties. I noticed that it's not also detecting the bitrate (which I don't think is relevant to this issue).

That's what I have experienced. I encourage whocaresnotme to post his thoughts and more information.

Pedro Villavicencio (pedro) wrote :

The report is missing some information, may you please run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt ; perform the steps to reproduce the bug and attach that resulting log file to the report? Thanks in advance!.

Hi Pedro. I've tested the same procedure with another media player, Banshee, but it's able to change the data.
Here's the requested file you for debugging. Please refer to attachment.

Please take note that this is still an issue in Rhythmbox 0.12.8 on Ubuntu 10.04

geneqew (geneqew-gmail) wrote :

using 10.04 fresh install, i am unable to update tags.
attached is the log file generated..

Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=620578

summary: - I cannot change Track information
+ cannot change track information - Unable to create tag-writing elements
description: updated
Changed in rhythmbox (Ubuntu):
status: Incomplete → Triaged
Changed in rhythmbox:
status: Unknown → New
Alejandro Greppi (agreppi1) wrote :

Rhythmbox is showing to me the same message, but tags does create. Attached you'll find a log taken when creating the tag for a song of Roky Erickson. Next post you'll find the log taken reopening Rhythmbox, with tags for the song properly created.

Alejandro Greppi (agreppi1) wrote :

Attaching second log

Pedro Villavicencio (pedro) wrote :

There's no need to provide more logs for the bug report for now, if upstream requires more information I'll let you know, thanks all!.

John Baptist (jepst79) wrote :

I'll note that in my experience, this problem is not limited to WMA files: it happens in MP3 files, as well. So I'm not sure what the common element is. Would it be helpful to attach an MP3 that causes this error?

It seems that the upstream bug is still not confirmed.

Alejandro Greppi (agreppi1) wrote :

Attached you'll find an MP3 file which wouldn't allow to make the Properties change permanent.

Changed in rhythmbox:
status: New → Invalid
Changed in rhythmbox:
status: Invalid → Unknown
Pedro Villavicencio (pedro) wrote :

Upstream is asking for more information, could you please do the following, run from a command line:

$ export GST_DEBUG=*:4,GST_REGISTRY:0,GST_PLUGIN_LOADING:0
$ rhythmbox -D metadata 2>metadata-error-log

Reproduce the bug and attach that resulting metadata-error.log file to the report, that would help the upstream developers to fix the bug, thanks in advance.

Changed in rhythmbox (Ubuntu):
status: Triaged → Incomplete
Changed in rhythmbox:
status: Unknown → Incomplete

I also get this error when trying to alter the tags of any mp3-file, whether the operation is tried on one or multiple files.
When changing tags of a single file, I will get this error dialog, internally Rhythmbox seems to be using the new data, however the mp3 files themselves are not updated with new tags.
When changing tags of multiple files, i will get one error dialog per file, the internal tags seems to be erased for all except 1 of the files (?) and the mp3 files will not be updated either.

Using the current 0.12.8 version, although as far as i can remember i have experienced this error in rhythmbox ever since i moved from kubuntu to vanilla ubuntu...

Pedro Villavicencio (pedro) wrote :
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → Fix Committed
Changed in rhythmbox:
status: Incomplete → Fix Released
Changed in rhythmbox:
importance: Unknown → Critical
Omer Akram (om26er) wrote :

rhythmbox 0.13.2 is now in natty

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Brownout (brownout) wrote :

Sure, but it's still broken in the LTS and the current release.
Natty will be released in 5 months, so it's a bit early IMHO to declare the problem solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.