rhythmbox-metadata crashed with SIGSEGV in g_return_if_fail_warning()

Bug #528085 reported by James Dearing on 2010-02-25
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

I had just opened Rhythmbox, after having used Firefox to download a .flac file into my music folder, when Apport popped up and told me that Rhythmbox crashed. Rhythmbox does not apear to have actually crashed, as I was still able to play music with it.

ProblemType: Crash
Architecture: i386
CheckboxSubmission: e16a3c3aa60748b6e4d4198e252ad64c
CheckboxSystem: abf102d6ef41328208f5c1554651535a
Date: Thu Feb 25 14:05:40 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/rhythmbox/rhythmbox-metadata
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.6git20100223-0ubuntu1
ProcCmdline: /usr/lib/rhythmbox/rhythmbox-metadata unix:tmpdir=/tmp
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x9e7566 <g_slice_alloc+262>: mov (%edx),%ecx
 PC (0x009e7566) ok
 source "(%edx)" (0x00000359) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 g_return_if_fail_warning () from /lib/libglib-2.0.so.0
 g_object_ref () from /usr/lib/libgobject-2.0.so.0
 gst_object_ref () from /usr/lib/libgstreamer-0.10.so.0
 gst_registry_feature_filter ()
 ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin.so
Title: rhythmbox-metadata crashed with SIGSEGV in g_return_if_fail_warning()
Uname: Linux 2.6.32-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (polkit-gnome-authentication-agent-1:1203): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

James Dearing (dearingj) wrote :

StacktraceTop:
 g_return_if_fail_warning () from /lib/libglib-2.0.so.0
 g_object_ref () from /usr/lib/libgobject-2.0.so.0
 gst_object_ref (object=0x899e920) at gstobject.c:299
 gst_registry_feature_filter (registry=0x88d7400,
 gst_decode_bin_init (decode_bin=0x89e7460)

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Marcelo (marceloramone-gmail) wrote :

In my case, the problem occurs when I try to edit mp3 tags, (is impossible) and apport advise the program has crashed

Pedro Villavicencio (pedro) wrote :

Is this still an issue with rhythmbox 0.12.8 ? If so, could somebody report a new bug so we can compare the backtraces? there's no new duplicate of this issue with latest rhythmbox. Thanks.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
pepness (pepness) wrote :

THE PROBLEM OCCURS WHEN T TRY TO EDIT TAGS

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=616664

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Invalid

Upstream bug has been marked as duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=615175

Changed in rhythmbox:
status: Invalid → Unknown
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
importance: Unknown → Critical
dino99 (9d9) wrote :

This version has expired

Changed in rhythmbox (Ubuntu):
status: Triaged → Invalid
Changed in rhythmbox:
importance: Critical → Undecided
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.