Rhythmbox pauses and says could not start playback:Internal GStreamer error: pad problem.

Bug #526711 reported by Noah on 2010-02-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

I am using Ubuntu studio 9.10 and Rhythmbox 0.12.5.
Roughly every hour (I have never got the exact time) the song pauses and a red circle with a line through appears in one of the columns. When I try to play the song again I get the error:

Could not start playback

Internal GStreamer error: pad problem ...

I then have to restart Rhythmbox and it's fine. (actually I have to close it, start it again twice as the first time the icon in the system tray dosent appear and the problem is still there, i think this is because I do this too quickly).

I do use an mp3 decoder for all my music. (if this helps)

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 1c3f536f85cd2f400af56b870136fb9c
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Tue Feb 23 20:36:21 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.5-0ubuntu5.2
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.152-rt
SourcePackage: rhythmbox
Uname: Linux 2.6.31-9-rt i686

Noah (noahdsmith) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better, however the report is missing some information, may you please run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt ; perform the steps to reproduce the bug and attach that resulting log file to the report? Thanks in advance!.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Noah (noahdsmith) wrote :

Here is a debug thingy

Noah (noahdsmith) wrote :

I forgot to mention that while I ran the debug I tried also to rip a CD which I had already done previously. It asked me whether I wanted to overwrite the file and so I cliked no. It then gave the error: Could not load profile mime type". I hope that this does not effect this.

Charlie Kravetz (charlie-tca) wrote :

Thank you for the attachment.

(rhythmbox:3600): GStreamer-WARNING **: Element bin2 already has parent
(19:40:33) [0x84cd028] [set_state_and_wait] rb-player-gst.c:585: got error from stream: Internal GStreamer error: pad problem. Please file a bug at http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer. (gstplaysink.c(1656): gen_audio_chain (): /GstPlayBin2:playbin20/GstPlaySink:playsink0:
Failed to configure the audio sink.)
(19:40:33) [0x84cd028] [set_state_and_wait] rb-player-gst.c:530: setting playbin state to READY

(rhythmbox:3600): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed

This particular bug has already been reported and is a duplicate of bug 502570, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers