Rhythmbox notification icon click hide/show

Bug #525875 reported by maki7143 on 2010-02-22
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: rhythmbox

In rhythmbox 0.12.6 i can't click on the notification icon to hide/show it. Instead I need to acces the tray icon menu and click on show rhytmbox.

ProblemType: Bug
Architecture: i386
Date: Mon Feb 22 17:50:47 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: wl
Package: rhythmbox 0.12.6git20100218-0ubuntu1
ProcEnviron:
 LANGUAGE=sv_SE.utf8
 LANG=sv_SE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.32-14-generic i686

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's not a bug though but how the new appindicators wok in lucid

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Invalid
importance: Low → Wishlist
ttp (human-ttp) wrote :

Are you crazy? Please restore the previous behaviour, current behaviour is horrible. If I need context menu I will click with right button.

ttp (human-ttp) wrote :

It isn't a wishlist, and it isn't invalid report. It's a usability bug. Why should I use two clicks instead of one?

Changed in rhythmbox (Ubuntu):
status: Invalid → New
ttp (human-ttp) wrote :

Do you know how to use right mouse button? Just move context menu to the right mouse button and restore previous behaviour for left mouse button or make this "feature" configurable. Gnome developers said that this is ubuntu only behaviour.
The only reason that makes me happy that you did not do the same "feature" for pidgin.

Jorge Castro (jorge) wrote :

Hi ttp,

This isn't a bug it's a deliberate design decision, please see this wiki page.
https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators/

Discussion of this can occur on the Ayatana mailing list.

Changed in rhythmbox (Ubuntu):
status: New → Invalid

I already read this wiki page. What can I say? Tell us all the address where
you buy the hemp.
So who is responsible for this issue? Where to send a duplicate of this bug?
Do they use this application every day? So how they can make such decision?
This is most terrible decision ever! There are will be a lot of dissatisfied
users after 10.04 release.

ttp (human-ttp) wrote :

So tell me what should I do to restore the main window in one click using your new "feature"?

Changed in rhythmbox (Ubuntu):
status: Invalid → New
Jorge Castro (jorge) wrote :

Like I said the place to discuss this is on the ayatana mailing list: https://launchpad.net/~ayatana

Please move the discussion there, design decision discussion should happen on the list and not in the bug tracker, thanks!

Changed in rhythmbox (Ubuntu):
status: New → Invalid
kisaa (kisaa-mail) wrote :

It is very uncomfortable - click on icon, find the Item, click again. Please, return old program behavior or give choice for users!
And - why main window still visible in bottom panel when minimized? how can I hide it?

Gaëtan de Menten (gdementen) wrote :

+1 on revert to old behavior. I just upgraded to lucid beta2 and found this issue immediately. It is not only stupid to require more actions from the user to do the same thing, but also inconsistent with the very goal of that design decision: to reduce inconsistencies.

Currently, I have 6 applications in my notification area: xchat, liferea, pidgin, skype, NetworkManager and rhythmbox. They all behave the same, *except* for rhythmbox: left-click = show/hide, right-click = menu with options. To that, you can also add Tomboy, which also behaves the same even if it is an applet. How is the current situation more consistent than having rhythmbox use the same behavior as other applications as it does upstream?

_dan_ (dan-void) wrote :

This is just stupid.

Pat Suwalski (pat-suwalski) wrote :

Indeed, it would be nice to have the old behaviour back. The new behaviour is inconsistent and hard to use.

HeWhoE (hewhoe) wrote :

I too prefer the old sensible behavior of single-left-click to show/hide.

Fingel (unholysponger) wrote :

This is driving me crazy. This "feature" causes a huge drop in usability. Not to mention the hover to see playing song is gone as well.

Tired of losing cash in the market.
This year our penny stock picks returned over 450% together!
Time to make a change in your investment strategies.

Totally Free Newsletter.

--->>> www.awesomebeststocksnow.com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.