MPEG 2 files continue to play when rhythmbox is paused

Bug #510506 reported by Alex Watson on 2010-01-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Although this may be related to bug #242206, I believe it is a separate issue. When playing music in Rhythmbox everything works fine. However, if a certain song is played, which I have discovered is MPEG 2 layer 3 audio, when I click pause it will continue playing even though Rhythmbox shows it is paused. If I click on another song after that it will play the new song and continue to play the song that is stuck on. I have to close Rhythmbox to stop the song from playing over other songs. It only happens with MPEG 2 audio. All of my other songs are MPEG 1 audio mp3s.

Rhythmbox version: 0.12.5
Package version: 0.12.5-0ubuntu5.1

I expected the song to stop when I click Pause.
The song continued playing after I clicked pause, and when I selected another song it would continue to play in the background over the other song.

Pedro Villavicencio (pedro) wrote :

do you get the same behavior with totem ? may you attach an example file to the report? Thanks in advance.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Alex Watson (alexfromapex) wrote :

Here is one of the culprit files. I tried playing songs back to back with these MPEG 2 mp3s in Totem and everything worked as it should.

Pedro Villavicencio (pedro) wrote :

Hello Alex, thanks for the file. It works fine here, pausing it does pause the song, could you get a rhythmbox log with: rhythmbox --debug &> rhythmbox-debug.txt ; reproduce the issue and attach the file to the report? Thanks in advance!.

Nigel Babu (nigelbabu) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
digitalbear (s1b1c) wrote :

i have similar problems as stated

mpeg 2 layer 3 will not pause, using play/pause button, and continues to play even when another track has been selected, resulting in two audio files playing at once...

mpeg 1 layer 3 works correctly in all playback/pause situations from what i have noticed. but when mpeg 2 layer 3 comes into anyone situation, it cannot be controlled.

Ubuntu 10.04 64-bit
rhythmbox 0.13.0

modified rhythmbox --debug output

started mpeg2 layer 3 playback, unsuccessful pause...then i exited program with audio still playing

digitalbear (s1b1c) on 2010-11-28
Changed in rhythmbox (Ubuntu):
status: Invalid → In Progress
Changed in rhythmbox (Ubuntu):
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers