"unable to start playback pipeline" (other apps work)

Bug #468577 reported by NeilA on 2009-11-01
60
This bug affects 14 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

Newly installed Ubuntu 9.1 8.04 worked OK with same hardware.
This error message appears when trying to play any source in Rhythmbox but other applications seem to play normally.
Preferred output device is Ext USB interface but problem same with internal speakers.

ProblemType: Bug
Architecture: i386
Date: Sun Nov 1 21:39:46 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: rhythmbox 0.12.5-0ubuntu4
ProcEnviron:
 LANG=en_PH.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-14-generic i686

NeilA (neilnmarcia) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
NeilA (neilnmarcia) wrote :

Have since installed Audacity and Audacious which work fine.
Rhythmbox behavior has changed but remains reproducible.
New Info:
If I select a source from within Rythmbox library I get a File error. Same if I try to Import file by browsing. See RB01.png.
However, if I right click on audio file in File Browser and try to play with Rhythmbox, I get Pipeline error. See RB02.png
NeilA

NeilA (neilnmarcia) wrote :

Screen shot RB01.png

Sebastien Bacher (seb128) wrote :

Is the file listed there availabe? Could you get a rhythmbox --debug log to get details on the issue?

How do I do that?

NeilA

At 05:55 PM 11/2/2009, you wrote:
>Is the file listed there availabe? Could you get a rhythmbox --debug log
>to get details on the issue?
>
>--
>"unable to start playback pipeline" (other apps work)
>https://bugs.launchpad.net/bugs/468577
>You received this bug notification because you are a direct subscriber
>of the bug.
>
>Status in “rhythmbox” package in Ubuntu: Incomplete
>
>Bug description:
>Binary package hint: rhythmbox
>
>Newly installed Ubuntu 9.1 8.04 worked OK with same hardware.
>This error message appears when trying to play any source in
>Rhythmbox but other applications seem to play normally.
>Preferred output device is Ext USB interface but problem same with
>internal speakers.
>
>ProblemType: Bug
>Architecture: i386
>Date: Sun Nov 1 21:39:46 2009
>DistroRelease: Ubuntu 9.10
>ExecutablePath: /usr/bin/rhythmbox
>InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
>Package: rhythmbox 0.12.5-0ubuntu4
>ProcEnviron:
> LANG=en_PH.UTF-8
> SHELL=/bin/bash
>ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
>SourcePackage: rhythmbox
>Uname: Linux 2.6.31-14-generic i686

I removed Rhythmbox with Synaptic, then reinstalled, and it started working again.

Brian T. Austin (btafssp) wrote :

Same problem for me - I uninstalled and reinstalled via Synaptic, and all good to go.

Ian Enticott (ian-enticott) wrote :

I also had this problem particularly with the BBC asx streams - but on re-installing from Ubuntu Software Centre I noticed that it recommended installing python-coherence. I installed this and all gstreamer plugins and I can now play these streams after a second or so of buffering.

tsingi (graham-rick) wrote :

I'm having this problem, RhythmBox gave me an error about failing to start the playback pipeline. I don't remember the exact wording, I can't get it to display the message again.

Everything was working fine until Amarok crashed.

Amarok is cool, but it plays hell with my sound settings, this is not the first time.

I've started the fix by totally removing Amarok.

Next, I'll investigate ALSA utilities. I know I can fix it, but I always forget how.

NeilA (neilnmarcia) wrote :

My problem was associated with the installation of 9.10.
First I 'upgraded' with the online version. Several applications including Rhythmbox then malfunctioned.
Then I burned a CD and re-installed from that - some problems disappeared but I still could not get my audio set-up right.
Finally I erased the entire partition and made a clean installation. All is now well.
Seems that something hanging over from 8.04 is not properly updated during installation of 9.10.
Perhaps with time and patience I could have tracked down the precise problem but life's too short!

Alex (jelly) wrote :

I have this error message as many other users on ubuntu-fr forums while playing certain web radios.

I'm using a plugin created by segler-alex (ppa available) in order to access web radios. Certain web radios url are simply obsolete in the database provided by the dev of the plugin. Here's what Rhythmbox (actually Gstreamer) says in terminal:

jelly@superdupont:~$ rhythmbox --gst-debug-level=1

0:00:59.922836820 11272 0x48e28e0 ERROR mmssrc gstmms.c:445:gst_mms_start:<source> Could not connect to this stream, redirecting to rtsp

In frontend Rhythmbox gives the "pipeline" error message.

So it seems that Gstreamer doesn't like redirections.. If I correct the plugin with the new url, it works fine.

I understand that the original bug described here is quite different. But I think it just might be a Gstreamer issue for everyone.

Alex.

bol1 (mb2215) wrote :

I'm also having this problem with RhythmBox after a clean install of 9.10 I get the error "Unable to start playback pipeline" This happens when I try to play an audio CD in Rhythmbox but not when playing audio files already saved on the PC.

I believe it maybe linked to this though? Sometimes when I double click on the Rhythmbox desktop icon the little wheel will spin around for a few secs but it won't open. Then when I click a second time it opens.
Again if I insert a CD and the msg box come up asking what to do, i.e launch Rhythmbox. I click on open and it tries to open but fails. If I theneject and reinsert the CD and try again it always opens second time.

Omer Akram (om26er) wrote :

thanks for the bug report and sorry for the inconvenience. We believe that this issue have been fixed in the latest version of Ubuntu hence are closing this bug but if the issue is still there for you with ubuntu-10.04 or 10.10 please feel free to re-open this bug.

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers