downloaded podcasts episodes disappear from list

Bug #451176 reported by Ralf Czaska on 2009-10-14
94
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Karmic by Michael Hackett

Bug Description

Binary package hint: rhythmbox

New Podcast Episdodes are downloaded - the files are saved in the folder - but when the status reaches 100%, the episode disappears from the list in rhythmbox after 1 oder 2 seconds. I can't play it.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 14 12:55:43 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.5-0ubuntu3
ProcEnviron:
 LANG=de_DE.UTF-8
 PATH=(custom, user)
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-14-generic i686

Related branches

Ralf Czaska (longfried) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Could you give a podcast url example?

Ralf Czaska (longfried) wrote :

It happens with all feeds for me. Example: http://chaosradio.ccc.de/chaosradio_express-latest.rss

Pedro Villavicencio (pedro) wrote :

cannot reproduce here, could you get a rhythmbox debug log? please run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt ; reproduce the issue and attach that resulting file to the report, thanks.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Ralf Czaska (longfried) wrote :

I think this bugreport is about the same thing: https://bugzilla.gnome.org/show_bug.cgi?id=590474

Now I started rhythmbox with --debug, clicked an episode to download it, an after reaching 100% the episode disappears.
Debug-File ist almost empty.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Triaged

I've managed to work out what triggers this bug, if you have selected the "Watch my library for new files" option in the Music tab of the preferences dialog AND you download podcasts into the folder (or sub folder) of the one being watched then the podcasts disappear from the feed window.

For example, I watch the folder

/home/steve/Music

and store my podcasts in

/home/steve/Music/Podcasts

This gives two workarounds for now,

1) Leave the podcasts where they are, but uncheck the "Watch my library for new files" option.
2) Move the podcasts to a folder which is not being watched

I have chosen to move my podcasts to

/home/steve/Podcasts

and no longer see this problem. Could the original submitter (or anyone else seeing this problem) confirm my workarounds?

Hopefully someone can now recreate this bug and try to find a proper solution.

Michael Fötsch (foetsch) wrote :

> Could the original submitter (or anyone else seeing this problem) confirm my workarounds?

I can confirm this. This is actually the workaround suggested in the Gnome bug Ralf linked to earlier: https://bugzilla.gnome.org/show_bug.cgi?id=590474

1) Leave the podcasts where they are, but uncheck the "Watch my library for new files" option.
This option works for me, many thanks. Superb.

stuart221 (stuart221) wrote :

Uncheck the watch may library did not work for me

Fixed upstream now.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.6-0ubuntu1

---------------
rhythmbox (0.12.6-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Context pane plugin
    - Power management plugin reworked to use new D-Bus API
    - MTP plugin reworked to do everything asynchronously
    - Volume slider levels match what PulseAudio displays
    - Playback pipeline filter interfaces actually work properly now
    - Much improved visualization performance when crossfading is enabled
    Bugs fixed:
    499048 - Filter insertion and removal on non-xfade backend is not robust.
    499051 - xfade backend doesn't play nice with LADSPA filters
    499052 - Filter removal on xfade backend is not robust.
    534981 - Add multi threading to MTP Support (lp: #235726)
    564772 - MTP plugin crash when I plug-in my Creative Zen 32Gb
    564800 - GnomeGoals: Remove deprecated GTK+ symbols
    589845 - im-status: use mission control dbus interface (lp: #424499)
    590474 - Podcast entry disappears from display during download (lp: #451176)
    594901 - Rhythmbox fails to display cover image from id3 tag (lp: #426329)
    595966 - leaked string in rb_stock_icons_init
    596573 - [PATCH] Do not use gnome-power-manager for inhibits,
             instead use gnome-session
    597706 - rhythmbox crashed with SIGSEGV in g_object_get() (lp: #445047)
    597708 - rhythmbox crashed with SIGSEGV in rb_source_get_config_widget()
             (lp: #444526)
    597708 - DAAP plugin doesn't link to libsoup
    598135 - Should init error before call libhal_device_get_property_string
    598302 - Use GDK spawn functions to handle multi-screen
    598613 - Rhythmbox shows cover art of previous track in Notification Bubble
             if current track has no cover art (lp: #451086)
    598955 - Use Cubic volume when StreaVolume interface is available
    600058 - Feed is not parsed when title tag is empty (lp: #468323)
    600513 - Generates invalid Brasero project
    600549 - Crash when transferring a track over MTP with a slash in
             the track title
    600624 - track information is not displayed correctly sometimes
             when playing internet radios (lp: #467308)
    600995 - Elapsed time indicator is wrong when seeking (lp: #474145)
    601352 - Crash while editing automatic playlist
    601460 - Rhythmbox gets laggy when copying music to iPod
    601528 - Play button doesn't work after finishing a playlist (lp: #474155)
    602615 - rhythmbox fails to build if python bindings are built and ld's
             --no-add-needed is used
    New and updated translations
  * debian/patches/05_brasero_burn_xml.patch:
    - the change is in the new version
  * debian/patches/90_autoconf.patch:
    - new version update
  * debian/patches/91_git_change_fix_inhibit_use.patch
    - the change is in the new version
 -- Sebastien Bacher <email address hidden> Mon, 23 Nov 2009 11:45:02 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Kev (ukev) wrote :

Will there be a fix for karmic, too?

Sebastien Bacher (seb128) wrote :

the change is not likely going to karmic no, lucid will be available in one month and efforts are focussed on it now, this issue is a small one and users who handled it until now without changing software or operating system can probably wait until lucid

now it works well for me...

Liu Zhongjun

On Fri, Mar 19, 2010 at 1:27 AM, Sebastien Bacher <email address hidden> wrote:

> the change is not likely going to karmic no, lucid will be available in
> one month and efforts are focussed on it now, this issue is a small one
> and users who handled it until now without changing software or
> operating system can probably wait until lucid
>
> --
> downloaded podcasts episodes disappear from list
> https://bugs.launchpad.net/bugs/451176
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Rhythmbox Music Management Application: Unknown
> Status in “rhythmbox” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: rhythmbox
>
> New Podcast Episdodes are downloaded - the files are saved in the folder -
> but when the status reaches 100%, the episode disappears from the list in
> rhythmbox after 1 oder 2 seconds. I can't play it.
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Oct 14 12:55:43 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/rhythmbox
> NonfreeKernelModules: nvidia
> Package: rhythmbox 0.12.5-0ubuntu3
> ProcEnviron:
> LANG=de_DE.UTF-8
> PATH=(custom, user)
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
> SourcePackage: rhythmbox
> Uname: Linux 2.6.31-14-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/rhythmbox/+bug/451176/+subscribe
>

W. Bourgeois (roundsoftstudio) wrote :

Sorry, i'm using 0.12.8 version, and this bug is STILL there.
And when I try to remove the podcast, rhythmbox crashes.

liu (liuzhongjun) wrote :

true, it's not working properly. But at least I can download fluently the
new pods...
I hope it'll be fixed.
Best wishes,
Liu Zhongjun

On Wed, May 12, 2010 at 4:43 PM, W. Bourgeois <email address hidden>wrote:

> Sorry, i'm using 0.12.8 version, and this bug is STILL there.
> And when I try to remove the podcast, rhythmbox crashes.
>
> --
> downloaded podcasts episodes disappear from list
> https://bugs.launchpad.net/bugs/451176
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Rhythmbox Music Management Application: Unknown
> Status in “rhythmbox” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: rhythmbox
>
> New Podcast Episdodes are downloaded - the files are saved in the folder -
> but when the status reaches 100%, the episode disappears from the list in
> rhythmbox after 1 oder 2 seconds. I can't play it.
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Oct 14 12:55:43 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/rhythmbox
> NonfreeKernelModules: nvidia
> Package: rhythmbox 0.12.5-0ubuntu3
> ProcEnviron:
> LANG=de_DE.UTF-8
> PATH=(custom, user)
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
> SourcePackage: rhythmbox
> Uname: Linux 2.6.31-14-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/rhythmbox/+bug/451176/+subscribe
>

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.