The autoaudiosink element is missing

Bug #442157 reported by Lennart Hildebrandt on 2009-10-04
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

When I want to play mp3-music, Rhythmbox gives me the error "The autoaudiosink element is missing". When he then try to get the package for this problem, he cant find any. Therefor I can't play any music.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 4 13:46:00 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.5-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-11-generic i686

Lennart Hildebrandt (lh) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is pulseaudio running?

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Do you have a way to trigger the issue or was that a one timer?

Lennart Hildebrandt (lh) wrote :

I'm a very beginner, who want to help in this amazing project called Ubuntu, so I'm not quite sure how to help ... but I try.

pulseaudio is installed. When I type this name into the terminal, there comes the following message:
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.
So it seems to be off. I turned it off to get my sound work in version 9.04. There was a problem between alsa and pulseaudio.

What do you mean with "a one timer"? An error, which disappeared after the first time? Sadly not ...

Another info, which is maybe important too: I get this error after upgrading from 9.04 to 9.10. Before this upgrade happens everything works fine with Rhythmbox.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Jeremy Powell (molesmoke) wrote :

I am suffering the same problem. The first time I try to play an mp3 in rythmbox, there is no sound but the app behaves like it is playing. If I then try to play another mp3 I get the message "The autoaudiosink element is missing". MP3s play fine in mplayer.

Jeremy Powell (molesmoke) wrote :

Checked the gstreamer documentation and it says autoaudiosink is part of the "good" plugin set - which is installed.
Also the following command generates a test tone:
gst-launch -v -m audiotestsrc ! audioconvert ! audioresample ! autoaudiosink

Output is attached

Jeremy Powell (molesmoke) wrote :

Some further info:

There is no audio output for wav or ogg files (not just mp3s).
The message "The autoaudiosink element is missing" is only displayed when I have changed my sound preferences to: "Digital Stereo (IEC958) Output + Analog Stero Input" in the hardware tab. Otherwise there is no sound but the message is not displayed.
Repeatedly trying to play files causes rhythmbox to hang (no cpu usage). I have reported this as bug #461899.

KoalaAirlines (mariusns) wrote :

The guys at gentoo have the same problem, and nailed it down to a gconf bug
using compile option for gst-plugins-gconf, on ubuntu gstreamer-good.

--with-default-audiosink=autoaudiosink

http://bugs.gentoo.org/230419

Can someone fix this

Jeremy Powell (molesmoke) wrote :

Seems to me from the debian/control file that this (--with-default-audiosink=autoaudiosink) is already set for gstreamer0.10-plugins-good:

ifeq ($(DEB_HOST_ARCH_OS),linux)
DEFAULT_AUDIOSINK = autoaudiosink
DEFAULT_AUDIOSRC = alsasrc
DEFAULT_VIDEOSINK = autovideosink
DEFAULT_VIDEOSRC = v4l2src
DEFAULT_VISUALIZER = goom
else
DEFAULT_AUDIOSINK = autoaudiosink
DEFAULT_AUDIOSRC = osssrc
DEFAULT_VIDEOSINK = autovideosink
DEFAULT_VIDEOSRC = videotestsrc
DEFAULT_VISUALIZER = goom
endif

DEB_CONFIGURE_EXTRA_FLAGS += \
        --disable-examples \
        --enable-DEBUG \
        --enable-debug \
        --with-package-name=$(GST_PACKAGE_NAME) \
        --with-package-origin=$(GST_PACKAGE_ORIGIN) \
        --enable-gtk-doc \
        --enable-experimental \
        --with-default-audiosink=$(DEFAULT_AUDIOSINK) \
        --with-default-audiosrc=$(DEFAULT_AUDIOSRC) \
        --with-default-videosink=$(DEFAULT_VIDEOSINK) \
        --with-default-videosrc=$(DEFAULT_VIDEOSRC) \
        --with-default-visualizer=$(DEFAULT_VISUALIZER)

KoalaAirlines (mariusns) wrote :

But should there be any entries in gconf for autoaudiosink as well as audiosink and the others?
/system/gstreamer/0.10/default/*

I tried this but nothing happend, (I'm no progammer) ;)

Only a guess!

KoalaAirlines (mariusns) wrote :

yea as mentioned gconf. If you add:

audiosink = autoaudiosink
musicaudiosink = autoaudiosink
autoaudiosink = halaudiosink uid=/org/freedesktop/Hal/devices/pci_8086_27d8_sound_card_0_alsa_playback_0

This will fix the playback. But I dont know if the last line is required!
Try out and see what happens.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Fix Committed
Jeremy Powell (molesmoke) wrote :

After some fiddling, I added the following lines to my system in gconf-editor:
audiosink = halaudiosink udi=/org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_playback_1
musicaudiosink = halaudiosink udi=/org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_playback_1
autoaudiosink = halaudiosink udi=/org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_playback_1

The autoaudiosink key was not originally present and audiosink was a different value. Although, of course these are specific to my hardware. It didn't seem to have any effect at first until altering my sound preferences again using the GUI. All now appears to be working, including not hanging on selecting new tracks. Not exactly sure what has fixed it. Will investigate further when I have more time. Need to get the volume control working next...

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
DataMatrix (datamatrixbg) wrote :

I have changed
audiosink = autoaudiosink
chataudiosink = autoaudiosink
musicaudiosink = autoaudiosink
autoaudiosink is not defined, but sound plays fine now. I've also noticed that videosink=autovideosink that is also not defined. Probably this is an internal setting that you don't need to define yourself like having key like
autoaudiosink = halaudiosink udi=/org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_playback_1

obeliksz (obeliksz) wrote :

I have the same problem... So what to do exactly?

Florian Lentsch (lentschi) wrote :

@obeliskz
Hmm... I don't actually know too much about the internals of the Ubuntu audio system - but for me changing some of the gconf values to do alsa* did the trick (see attached screenshot). Apparently it depends on your sound card which of the above solutions will help...

To be able to change the gstreamer gconf values do the following (If that's what you don't know how to do):
1) Press ALT+F2 to open the Run dialog.
2) Enter 'gconf-editor' and press ENTER.
3) Open the gconf path '/system/gstreamer/0.10/default' (on the left side) and change the values as described (on the right side)

John Doe (johndoe32102002) wrote :

I am still getting this error with other programs as well such as Subtitle Editor.
"autovideosink element is missing"
I have both gstreamer good and bad plugins installed. The sound works fine on my system (using pulseaudio which I had to compile from source to get to work).

Omer Akram (om26er) wrote :

thanks for the bug report. Is this still an issue in Ubuntu 11.04?

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers