ignore play command after queue finished

Bug #440828 reported by Prunus dulcis on 2009-10-02
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Low
rhythmbox (Debian)
Fix Released
Unknown
rhythmbox (Ubuntu)
Low
Unassigned
Karmic
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

When I clicked in the notification area icon with right click and then in the upcoming menu with left click on 'Play', the menu button changes accordingly and the play button in the rhythmbox main window changes as well. But the music does not start playing and the music-position-bar does not move.

Only if I click on 'Play' twice, the music starts with the correct file.
This is reproducible everytime, all music files in current queue have finished and I use either the play button in the rhythmbox window or the notification area icon to start playing again. Also double-clicking on another music file does show the same non-playing behaviour.

It all seems to be linked to the current queue being finished. Only then I have so far observed this problem of ignoring the play command.

So steps to reproduce.

1. Open rhythmbox
2. Select an album, a music file whatever (choose the last one, because this only happens if rhythmbox stops playing on its own [because of end of queue])
3. If you want it fast, use the search-position-bar to go near the end of the music file
4. press Play-Button (in programm or notification-icon) or double click on another music file or another album or select another album or music file and press the button
5. it does not start playing although the buttons say it has started

[don't know if this is important, I only tested this with ogg-files]

ProblemType: Bug
Architecture: i386
Date: Fri Oct 2 21:01:39 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.5-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-11-generic i686

Prunus dulcis (prunus-dulcis) wrote :
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Ilya Barygin (randomaction) wrote :

I can confirm this with mp3 files and 0.12.5-0ubuntu4.

Found two upstream bugs with similar symptoms:
https://bugzilla.gnome.org/show_bug.cgi?id=598548
https://bugzilla.gnome.org/show_bug.cgi?id=599571

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
summary: - rhythmbox does ignore play command after queue finished
+ ignore play command after queue finished
Changed in rhythmbox (Ubuntu):
assignee: nobody → Ilya Barygin (randomaction)
Ilya Barygin (randomaction) wrote :

SRU justification.

This is a minor but annoying bug that already collected a couple of duplicates.
It was fixed in upstream version 0.12.6 and thus in Lucid. The patch posted here is taken from upstream (http://git.gnome.org/browse/rhythmbox/commit/?id=d655375d6321ce91ba51cf0a5fe217333b62ad6b).

TEST CASE:
1. Open rhythmbox.
2. Select an album, start the last track.
3. Use the search-position-bar to go near the end of the music file.
4. Wait until the playback finishes.
5. Press Play-Button (in program or notification-icon) OR double click on another music file or another album OR select another album or music file and press the button
6. The play button will push in, the album art will load and the song will get the "Playing" icon next to it, but it won't be playing.

"It's just a one-line change!" And this patch was used in Debian (version 0.12.5-2). It survives upstream until now.

Changed in rhythmbox (Ubuntu):
assignee: Ilya Barygin (randomaction) → nobody
Sebastien Bacher (seb128) wrote :

Thank you for your work there

Changed in rhythmbox (Ubuntu Karmic):
importance: Undecided → Low
Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Changed in rhythmbox (Ubuntu):
status: Fix Released → Triaged
Martin Pitt (pitti) wrote :

Sponsored

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Changed in rhythmbox (Ubuntu Karmic):
status: New → In Progress
Martin Pitt (pitti) wrote :

Won't accept into karmic-proposed until bug 451086 gets verified.

Accepted rhythmbox into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Uphaar Agrawalla (uphaar) wrote :

Can confirm that before installing the update, the bug was reproducible. After installing the fix it is no longer reproducible.

Martin Pitt (pitti) on 2010-01-17
tags: added: verification-done
removed: verification-needed
Download full text (3.2 KiB)

Problem solved for me too.

Thanks,
Daniel

--- On Sat, 1/16/10, Martin Pitt <email address hidden> wrote:

> From: Martin Pitt <email address hidden>
> Subject: [Bug 440828] Re: ignore play command after queue finished
> To: <email address hidden>
> Received: Saturday, January 16, 2010, 11:18 AM
> Accepted rhythmbox into
> karmic-proposed, the package will build now and
> be available in a few hours. Please test and give feedback
> here. See
> https://wiki.ubuntu.com/Testing/EnableProposed for
> documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Changed in: rhythmbox (Ubuntu Karmic)
>        Status: In Progress =>
> Fix Committed
>
> ** Tags added: verification-needed
>
> --
> ignore play command after queue finished
> https://bugs.launchpad.net/bugs/440828
> You received this bug notification because you are a direct
> subscriber
> of a duplicate bug.
>
> Status in The Rhythmbox Music Management Application:
> Unknown
> Status in “rhythmbox” package in Ubuntu: Fix Released
> Status in “rhythmbox” source package in Karmic: Fix
> Committed
> Status in “rhythmbox” package in Debian: Unknown
>
> Bug description:
> Binary package hint: rhythmbox
>
> When I clicked in the notification area icon with right
> click and then in the upcoming menu with left click on
> 'Play', the menu button changes accordingly and the play
> button in the rhythmbox main window changes as well. But the
> music does not start playing and the music-position-bar does
> not move.
>
> Only if I click on 'Play' twice, the music starts with the
> correct file.
> This is reproducible everytime, all music files in current
> queue have finished and I use either the play button in the
> rhythmbox window or the notification area icon to start
> playing again. Also double-clicking on another music file
> does show the same non-playing behaviour.
>
> It all seems to be linked to the current queue being
> finished. Only then I have so far observed this problem of
> ignoring the play command.
>
> So steps to reproduce.
>
> 1. Open rhythmbox
> 2. Select an album, a music file whatever (choose the last
> one, because this only happens if rhythmbox stops playing on
> its own [because of end of queue])
> 3. If you want it fast, use the search-position-bar to go
> near the end of the music file
> 4. press Play-Button (in programm or notification-icon) or
> double click on another music file or another album or
> select another album or music file and press the button
> 5. it does not start playing although the buttons say it
> has started
>
> [don't know if this is important, I only tested this with
> ogg-files]
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Oct  2 21:01:39 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/rhythmbox
> Package: rhythmbox 0.12.5-0ubuntu1
> ProcEnviron:
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
> SourcePackage: rhythmbox
> Uname: Linux 2.6.31-11-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/rhythmbox/+bug/440828/+subscribe
>

      __________________________________________________________________
Looking for t...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu5.2

---------------
rhythmbox (0.12.5-0ubuntu5.2) karmic-proposed; urgency=low

  * debian/patches/07_track_finished.patch:
    - Clear the track status when read has finished. This will allow
      tracks to start after playlist has finished. (LP: #440828)
 -- Ilya Barygin <email address hidden> Sat, 26 Dec 2009 22:17:25 +0300

Changed in rhythmbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Low
status: Unknown → Fix Released
Changed in rhythmbox (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.