Rhythmbox fails to download podcast

Bug #437454 reported by Justin Dugger on 2009-09-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
gvfs (Ubuntu)
Medium
Unassigned
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

For some reason, since September 15th, Rhythmbox fails to download podcasts from "60 second science" (http://rss.sciam.com/sciam/60secsciencepodcast)

I've dug out a podcast URL from the XML for sept 25th and wget downloads the podcast fine.

Matthew Woerly (nattgew) wrote :

Output from rhythmbox -d

(19:07:02) [0xf96040] [rb_podcast_manager_next_file] rb-podcast-manager.c:653: looking for something to download
(19:07:02) [0xf96040] [rb_podcast_manager_next_file] rb-podcast-manager.c:679: processing http://www.pheedo.com/e/74e28d20cc2f526d69d84655b2b17be2/podcast.mp3?e_id=E9A8F927-04B7-FC3B-1D5C7AEDA824B572&ref=p_itune
(19:07:03) [0xf96040] [download_file_info_cb] rb-podcast-manager.c:724: got file info results for http://www.pheedo.com/e/74e28d20cc2f526d69d84655b2b17be2/podcast.mp3?e_id=E9A8F927-04B7-FC3B-1D5C7AEDA824B572&ref=p_itune
(19:07:03) [0xf96040] [download_file_info_cb] rb-podcast-manager.c:735: file info query failed: HTTP Client Error: Forbidden

affects: ubuntu → rhythmbox (Ubuntu)
Justin Dugger (jldugger) wrote :

An excerpt From "rhythmbox -d":
(19:55:01) [0x8c3f408] [rb_podcast_source_cmd_download_post] rb-podcast-source.c:1305: Add to download action
(19:55:01) [0x8c3f408] [rb_podcast_manager_download_entry] rb-podcast-manager.c:500: Adding podcast episode http://www.pheedo.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune to download list
(19:55:01) [0x8c3f408] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys
(19:55:01) [0x8c3f408] [rb_podcast_manager_next_file] rb-podcast-manager.c:653: looking for something to download
(19:55:01) [0x8c3f408] [rb_podcast_manager_next_file] rb-podcast-manager.c:679: processing http://www.pheedo.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
(19:55:02) [0x8c3f408] [download_file_info_cb] rb-podcast-manager.c:724: got file info results for http://www.pheedo.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
(19:55:02) [0x8c3f408] [download_file_info_cb] rb-podcast-manager.c:735: file info query failed: HTTP Client Error: Forbidden
(19:55:02) [0x8c3f408] [rb_podcast_manager_next_file] rb-podcast-manager.c:653: looking for something to download
(19:55:02) [0x8c3f408] [rb_podcast_manager_next_file] rb-podcast-manager.c:667: download queue is empty

Justin Dugger (jldugger) wrote :

And a log from wget:
~ $ wget http://www.pheedo.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
--2009-09-26 20:54:49-- http://www.pheedo.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD
Resolving www.pheedo.com... [1] 10220
198.145.117.105
Connecting to www.pheedo.com|198.145.117.105|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://www.pheedcontent.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD [following]
--2009-09-26 20:54:49-- http://www.pheedcontent.com/e/b7f9489601ab23c2b3e3516d44e5ac9b/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD
Resolving www.pheedcontent.com... 198.145.117.111
Connecting to www.pheedcontent.com|198.145.117.111|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://www.sciam.com/podcast/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune [following]
--2009-09-26 20:54:49-- http://www.sciam.com/podcast/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
Resolving www.sciam.com... 63.131.142.246
Connecting to www.sciam.com|63.131.142.246|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://www.scientificamerican.com/podcast/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune [following]
--2009-09-26 20:54:49-- http://www.scientificamerican.com/podcast/podcast.mp3?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
Resolving www.scientificamerican.com... 63.131.142.246
Reusing existing connection to www.sciam.com:80.
HTTP request sent, awaiting response... 302 Found
Location: http://www.scientificamerican.com/podcast/podcast.cfm?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune [following]
--2009-09-26 20:54:49-- http://www.scientificamerican.com/podcast/podcast.cfm?e_id=EF83BDDD-E77B-CCA5-72F76C3AD1DE71CD&ref=p_itune
Reusing existing connection to www.sciam.com:80.
HTTP request sent, awaiting response... 302 Found
Location: http://podcast.sciam.com/daily/sa_d_podcast_090925.mp3 [following]
--2009-09-26 20:54:49-- http://podcast.sciam.com/daily/sa_d_podcast_090925.mp3
Resolving podcast.sciam.com... 63.131.142.243
Connecting to podcast.sciam.com|63.131.142.243|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1293012 (1.2M) [audio/mpeg]
Saving to: `sa_d_podcast_090925.mp3'

100%[=============================================================================================================================================================>] 1,293,012 167K/s in 7.4s

2009-09-26 20:54:57 (170 KB/s) - `sa_d_podcast_090925.mp3' saved [1293012/1293012]

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Matthew Woerly (nattgew) on 2009-09-28
Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown
Pedro Villavicencio (pedro) wrote :

Thanks for sent it upstream.

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Changed in rhythmbox (Ubuntu):
importance: Low → Medium
Robert Ancell (robert-ancell) wrote :
Changed in rhythmbox (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Changed in gvfs (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.4.0-0ubuntu5

---------------
gvfs (1.4.0-0ubuntu5) karmic; urgency=low

  * debian/patches/03_http_input_query_info.patch:
    - Support querying information from HTTP input streams, Required for
      Rhythmbox podcast bug (LP: #437454)

 -- Robert Ancell <email address hidden> Thu, 15 Oct 2009 13:42:25 +1100

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu4

---------------
rhythmbox (0.12.5-0ubuntu4) karmic; urgency=low

  * debian/patches/04_podcast_query_info.patch:
    - Fix downloading podcasts through buggy servers (LP: #437454)

 -- Robert Ancell <email address hidden> Thu, 15 Oct 2009 16:43:55 +1100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: Unknown → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.