hangs on some songs

Bug #427215 reported by Sam Liddicott on 2009-09-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
High
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

On karmic with rhythmbox 0.12.4-1ubuntu1, rhythmbox gui hangs (won't even redraw) when starting next song.

trailing output of --debug is here:

(08:59:51) [0xa43040] [tick_cb] rb-shell-player.c:3513: tick: [file:///home/music/CD/Chris%20Isaak%20-%20Heart%20Shaped%20World%20-%20Kings%20of%20the%20Highway.m4a, 283183445000:286000000000(0)]
(08:59:51) [0x1a34070] [rb_shell_player_handle_eos] rb-shell-player.c:904: handling eos for file:///home/music/CD/Chris%20Isaak%20-%20Heart%20Shaped%20World%20-%20Kings%20of%20the%20Highway.m4a
(08:59:51) [0x1a34070] [rhythmdb_query_model_base_row_deleted] rhythmdb-query-model.c:2449: deleting entry 0x173a5e0 from base model 0xe6a810 to model 0xe97cb0
(08:59:51) [0x1a34070] [rb_entry_view_row_deleted_cb] rb-entry-view.c:2160: row deleted
(08:59:51) [0x1a34070] [rb_entry_view_row_deleted_cb] rb-entry-view.c:2160: row deleted
(08:59:51) [0x1a34070] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:713: deleting "Pop": refcount: 2
(08:59:51) [0x1a34070] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:713: deleting "Chris Isaak": refcount: 1
(08:59:51) [0x1a34070] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:713: deleting "Unknown": refcount: 8
(08:59:51) [0x1a34070] [impl_open] rb-player-gst.c:695: setting new uri to file:///home/music/CD/Doc%20Mclean/American%20Pie/01-american_pie_(complete_original_version)_320_lame_cbr.mp3
(08:59:51) [0x1a34070] [impl_play] rb-player-gst.c:740: current track finishing -> just setting URI on playbin
(08:59:51) [0x1a34070] [playing_stream_cb] rb-shell-player.c:3429: new playing stream: file:///home/music/CD/Doc%20Mclean/American%20Pie/01-american_pie_(complete_original_version)_320_lame_cbr.mp3
(08:59:51) [0x1a34070] [rb_header_sync] rb-header.c:434: syncing with entry = file:///home/music/CD/Doc%20Mclean/American%20Pie/01-american_pie_(complete_original_version)_320_lame_cbr.mp3
(08:59:51) [0x1a34070] [should_notify] rb-status-icon-plugin.c:474: shell is visible, not notifying
(08:59:51) [0x1a34070] [rb_shell_player_sync_with_source] rb-shell-player.c:2897: playing source: 0xe64050, active entry: 0x7f008408e030
(08:59:51) [0x1a34070] [rb_shell_set_window_title] rb-shell.c:2011: setting title to "Don McLean - American Pie (Complete Origin"
(08:59:51) [0x1a34070] [show_controls] rb-visualizer-plugin.c:866: showing controls
(08:59:51) [0x1a34070] [rb_shell_player_sync_buttons] rb-shell-player.c:2992: syncing with source 0xe64050
(08:59:51) [0x1a34070] [show_controls] rb-visualizer-plugin.c:866: showing controls
(08:59:51) [0x1a34070] [impl_set_replaygain] rb-player-gst.c:891: Scale : 0.970510 New volume : 0.020711

Or if I play "American Pie" first, it hangs right away (but the music keeps on playing [just that track])
(09:01:40) [0x196e040] [rb_gst_process_tag_string] rb-player-gst-helper.c:230: tag audio-codec doesn't correspond to a metadata field we're interested in
(09:01:40) [0x196e040] [process_tag] rb-player-gst.c:189: emitting info field 20
(09:01:40) [0x196e040] [set_state_and_wait] rb-player-gst.c:608: playbin reached state PAUSED
(09:01:40) [0x196e040] [set_state_and_wait] rb-player-gst.c:608: playbin reached state PLAYING
(09:01:40) [0x196e040] [playing_stream_cb] rb-shell-player.c:3429: new playing stream: file:///home/music/CD/Doc%20Mclean/American%20Pie/01-american_pie_(complete_original_version)_320_lame_cbr.mp3
(09:01:40) [0x196e040] [rb_header_sync] rb-header.c:434: syncing with entry = file:///home/music/CD/Doc%20Mclean/American%20Pie/01-american_pie_(complete_original_version)_320_lame_cbr.mp3
(09:01:40) [0x196e040] [should_notify] rb-status-icon-plugin.c:474: shell is visible, not notifying
(09:01:40) [0x196e040] [rb_shell_player_sync_with_source] rb-shell-player.c:2897: playing source: 0x1d8f050, active entry: 0x7f3d700bee60
(09:01:40) [0x196e040] [rb_shell_set_window_title] rb-shell.c:2011: setting title to "Don McLean - American Pie (Complete Origin"
(09:01:40) [0x196e040] [show_controls] rb-visualizer-plugin.c:866: showing controls
(09:01:40) [0x196e040] [rb_shell_player_sync_buttons] rb-shell-player.c:2992: syncing with source 0x1d8f050
(09:01:40) [0x196e040] [show_controls] rb-visualizer-plugin.c:866: showing controls
(09:01:40) [0x196e040] [rb_player_gst_find_element_with_property] rb-player-gst-helper.c:121: iterating bin looking for property volume
(09:01:40) [0x196e040] [find_property_element] rb-player-gst-helper.c:99: didn't find property "volume" on element bin3
(09:01:40) [0x196e040] [find_property_element] rb-player-gst-helper.c:96: found property "volume" on element pulsesink0
(09:01:40) [0x196e040] [impl_set_replaygain] rb-player-gst.c:891: Scale : 0.970510 New volume : 0.020102

The problem seems to be related to particular tracks. I these tests it will always hang at "American Pie" but transitions fine through to other tracks.

Totem can play this track (or transition to it) without any problem.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sam Liddicott (sam-liddicott) wrote :

Fair enough; but I thought launchpad was supposed to do that...

aghagahgh I'd almost rather use banshee (actually, I am) rather than navigate gnomes bugzilla to fix rythmbox - however as Sebastian was good enough to tell me what to do, I'd be slack not to do it....

* idea * use "report problem" from rhythmbox itself! [hmm it uses ubuntu launchpad]

Filed upstream as: https://bugzilla.gnome.org/show_bug.cgi?id=594728

Sebastien Bacher (seb128) wrote :

> but I thought launchpad was supposed to do that...

the ubuntu bug triagers try to send upstream issues to the upstream bug tracker for user, there is a lot of bugs though and not so many bug triagers, to send issues upstream it's also better to get those to reply to questions, you seem the only one to get that bug so far so it's better if you send it yourself there

thanks for sending the bug to the upstream bug tracker

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Sam Liddicott (sam-liddicott) wrote :

fixed up-stream. The work-around is to disable replaygain in the meantime.

Sam Liddicott (sam-liddicott) wrote :

Or it seems, to enable cross-fading

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Changed in rhythmbox:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu1

---------------
rhythmbox (0.12.5-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - New cover art search code using discogs.com and MusicBrainz, replacing
      the Amazon cover art search that no longer works
    - Updated Coherence UPnP plugin
    - Clicking on the status icon summons the main window to the current
      workspace
    Bugs fixed:
    410684 - MusicBrainz cover art search
    590184 - Update .desktop file for new GenericName conventions
    592404 - use correct icon name for the throbber
    592763 - fix some button definitions so the button-images setting works
    593494 - display location column in playlists if enabled
    594008 - fix reading of symlinks with non-ASCII targets (lp :#426981)
    594124 - fix incorrect variable name in gio chunk loader
    594419 - disable non-functional lyricwiki search (lp: #425871)
    594728 - deadlock setting replaygain-adjusted volume (lp: #427215)
    New and updated translations
  * debian/patches/02_media-player-info-rename.patch:
    - the change is in the new version

 -- Sebastien Bacher <email address hidden> Fri, 18 Sep 2009 15:11:47 +0200

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
derfinsterling (markus-finster) wrote :

I have 0.12.5 installed on Jaunty, but the problem persists.

Jamal Fanaian (jamalta) wrote :

I am running Rhythmbox 0.12.6-1ubuntu8 on Lucid and the issue still exists. It also happened before I upgraded to Lucid, with whatever version is in Karmic.

Changed in rhythmbox:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.