Rhythmbox fails to stop suspend process in karmic

Bug #417491 reported by Andres Mujica on 2009-08-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

In Jaunty and previous releases, when you activated the Power Manager plugin in Rhythmbox it wouldn't suspend while listening to music as expected.

In Karmic, this is not happening anymore

Seems similar to the issue described here:

http://www.nabble.com/-Bug-33000--serpentine,-NEW:-Uses-wrong-dbus-name-for-gnome-powermanager-td12413361.html

The output available is this:

(rhythmbox:8025): Rhythmbox-WARNING **: Failed to invoke org.gnome.PowerManager.Inhibit: Method "Inhibit" with signature "ss" on interface "org.gnome.PowerManager" doesn't exist

ProblemType: Bug
Architecture: amd64
Date: Sat Aug 22 15:36:02 2009
DistroRelease: Ubuntu 9.10
Package: rhythmbox 0.12.3-1ubuntu2
ProcEnviron:
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-5-generic x86_64

Related branches

Andres Mujica (andres.mujica) wrote :
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Jeff Fortin Tam (kiddo) wrote :

Upstream gnome has a patch for this, but they seem unsure about applying it. Maybe Ubuntu can help here, either by refining the patch so that it satisfies upstream, or by servicing the ubuntu user base by applying the patch to the ubuntu packages, so that there are no "bad surprises" when Karmic final is released.

I would really hate to loose this feature, I depend on this to use my laptop as a music player in the public transit.

Changed in rhythmbox (Ubuntu):
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
tags: added: regression-potential
Changed in rhythmbox (Ubuntu):
milestone: none → ubuntu-9.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu2

---------------
rhythmbox (0.12.5-0ubuntu2) karmic; urgency=low

  * debian/patches/91_git_change_fix_inhibit_use.patch:
    - git change to fix the current gnome-session inhibit
      (lp: #417491)

 -- Sebastien Bacher <email address hidden> Thu, 08 Oct 2009 11:10:30 +0200

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
Matthew Gregg (mcg) wrote :

Bug #49260 looks like a dup of this bug.

Changed in rhythmbox:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.