error ripping audio CD with rhythmbox

Bug #412619 reported by Boniek on 2009-08-12
94
This bug affects 22 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

When I try rip audio CD for a second time it asks whether to overwrite file or not if I click "no" i get error "Unable to locate encoding profile for mime-type". Also I have to close rhythmbox and launch it again if I choose to rip anything else

affects: ubuntu → rhythmbox (Ubuntu)
Pedro Villavicencio (pedro) wrote :

Thanks for the report, please run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt perform the operation to reproduce the bug and attach that resulting file to the report, thanks.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Boniek (boniek12p) wrote :

I've added debug

Pedro Villavicencio (pedro) wrote :

(11:58:28) [0x18976c0] [error_cb] rb-removable-media-manager.c:962: Error transferring track to file:///home/boniek/Muzyka/US3/Hand%20On%20The%20Torch/12%20-%20Make%20Tracks.sr1: Unable to locate encoding profile for mime-type
(11:58:28) [0x18976c0] [error_cb] rb-removable-media-manager.c:962: Error transferring track to file:///home/boniek/Muzyka/US3/Hand%20On%20The%20Torch/13%20-%20The%20Darkside.sr1: Unable to locate encoding profile for mime-type

log shows, is that the error you're getting on the ui?

Boniek (boniek12p) wrote :

"Unable to locate encoding profile for mime-type" - yes

Marco Agudelo (magudelo) wrote :

Same problem here with 09.10

(00:40:20) [0x99da028] [do_transfer] rb-removable-media-manager.c:1176: starting transfer of cdda://15#/dev/sr0 to file:///db02/Documents%20and%20Settings/All%20Users/Documents/My%20Music/Rafael%20Brito%20-%20Se%20Canta%20Venezolano/15%20-%20Cuando%20A%20Ti%20Te%20De%20La%20Gana%20(Versi%C3%B3n%20Salsa).sr0
(00:40:20) [0x99da028] [error_cb] rb-removable-media-manager.c:1099: Error transferring track to file:///db02/Documents%20and%20Settings/All%20Users/Documents/My%20Music/Rafael%20Brito%20-%20Se%20Canta%20Venezolano/15%20-%20Cuando%20A%20Ti%20Te%20De%20La%20Gana%20(Versi%C3%B3n%20Salsa).sr0: Unable to locate encoding profile for mime-type

Pedro Villavicencio (pedro) wrote :

what kind of file are those? could you execute file on them and paste the output? ie: file blah.sr0 ; Thanks.

Asher (asher-zoomsolution) wrote :

I noticed that if you edit->preferences and then select a different encoding type it will work other then OGG.

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Victor Engmark (victor-engmark) wrote :

Confirming this bug - I set preferred format to FLAC, and after ripping a few CDs it stopped working and gave the same error messages. This using an original audio CD.

Confirmed also that a work-around is to restart Rhythmbox.

Cannot view or run "file" on the disc contents because of the following error in Nautilus: Error: DBus error org.freedesktop.DBus.Error.ServiceUnknown: The name :1.148 was not provided by any .service files
Please select another viewer and try again.

Please reopen the bug.

Changed in rhythmbox (Ubuntu):
status: Invalid → New
Reinout van Rees (reinout) wrote :

I get the same error message, also when re-ripping a cd that was only partly ripped (as I closed the lid of my laptop).

I tried setting the preferred format to something else than the mp3 I normally use and noticed that the entire mp3 option was now missing from the dropdown! Yeah, that "Unable to locate encoding profile for mime-type" error message makes sense if the entire mp3 mime-type is somehow gone/crashed/whatever.

Nigel Babu (nigelbabu) wrote :

Please do not reopen the bug report without providing additional information. Execute 'file' on the files that you are seeing this error and paste the output, ie: file blah.sr0 ;
Thanks.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Nigel Babu (nigelbabu) wrote :

Thank you for your bug reports. This error seems to happen when ejecting the CD during the rip. It is either intentional eject or some other underlying problem. If some could check in Lucid and the newer version of rhythmbox if this happens, we can report to the developers of the software to try and fix this. If you can reproduce this bug in Lucid, please attach any relevant updated logs.

Kebap (leckerkebap) wrote :

I can confirm getting this error in Lucid. I did now restart rythmbox with debug command, lets see if the error happens again.

Michael Ireland (irelands-the) wrote :

Just an addendum:

Running Ubuntu 9.10 (haven't updated yet) on a Phenom quadcore & 8GB ram. No other applications running. >400GB free on target drive.

Exact scenario:

Ripping CDs for backup into FLAC format. After ripping about 40 discs, I was about to eject a CD and slip in the next to back up. I mistakenly clicked the 'copy to library' button instead of the 'eject cd' button from the right-click menu. It asked me if I wanted to overwrite the file corresponding to the first track on the CD. I chose no. It asked me about the second, I also clicked no. I then clicked rapidly in the location of the NO button so as to get through all 12 tracks. I was then presented with 12 new windows in sequence with the error indicated by the original poster.

I ejected the disc from the drive via right-click menu, and put a fresh CD in the drive to back up. It was recognized and I selected the 'copy to library' option from the right-click menu. I was immediately presented with this same error.

If I get any further information, I will post it here.

Bob M Brown (gurubob) wrote :

Hi,

I came to this thread after aborting a CD rip partway through and have managed to boil this error down to the following.

Rhythmbox 0.12.8, Ubuntu 10.04.
Prefered media type: CD Quality, MP3 (.mp3 type)

Steps to reproduce:

1. Select some tracks to rip from a CD (e.g. tracks 1 and 2)
2. Right click the CD in the navigator pane and choose Extract To Library. Let it complete.
3. Select tracks 1 and 2 again.
4. Right click the CD in the navigator pane and choose Extract To Library. For me there was no prompt here to overwrite the file, ripping of track one began again. Hit Ctrl-C in the console to kill Rhythmbox.
5. Restart Rhythmbox, select tracks 1 and 2 again, right click the CD in the navigator pane and choose Extract To Library.
6. When asked if you want to overwrite track 1, choose No.
7. The error message "Unable to locate encoding profile for mime-type" is given.

Output of file on the first track is:
filename.mp3: Audio file with ID3 version 2.4.0, contains: MPEG ADTS, layer III, v1, 128 kbps, 44.1 kHz, Stereo

If I can provide more info please let me know.

-B.

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions