rhythmbox crashed with SIGSEGV in rb_shell_guess_source_for_uri()

Bug #410510 reported by Nicolay Doytchev on 2009-08-07
180
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

TEST CASE:
1. install rhythmbox from maverick-proposed
2. open a .m3u file
3. see rhythmbox does not crash.

I tried to open a .m3u w/ a stream in it which resulted in the aforementioned crash.
I have ubuntu-restricted-modules installed.

ProblemType: Crash
Architecture: i386
Date: Fri Aug 7 17:50:07 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.3-1ubuntu1
ProcCmdline: rhythmbox
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SegvAnalysis:
 Segfault happened at: 0x8065235 <rb_shell_guess_source_for_uri+37>: mov 0xc(%eax),%eax
 PC (0x08065235) ok
 source "0xc(%eax)" (0x0000005c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 rb_shell_guess_source_for_uri ()
 ?? ()
 ?? () from /usr/lib/libtotem-plparser.so.12
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in rb_shell_guess_source_for_uri()
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Nicolay Doytchev (lightrush) wrote :

StacktraceTop:rb_shell_guess_source_for_uri (shell=0x50,
handle_playlist_entry_cb (playlist=0xa296e40,
totemplparser_marshal_VOID__STRING_BOXED (
IA__g_closure_invoke (closure=0xa2c5600, return_value=0x0,
signal_emit_unlocked_R (node=<value optimized out>,

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=591841

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
visibility: private → public

Another test case to use (which caused me to hit this bug) is when eg firefox opened rhythmbox with:

http://www.sky.fm/mp3/urbanjamz.pls

Jack Leigh (leighman) wrote :

Same problem. Trying to listen to an internet stream, .m3u.

iGadget (igadget) wrote :

Adding the url of my internet radio station ( http://shoutcast.omroep.nl:8104/ ) to Rhythmbox manually seems to be working fine. Opening the .pls file results in the crash mentioned above.

gietos (t-root-onsky-ru) wrote :

.pls playlist (http://listen.di.fm/public3/chilloutdreams.pls) opened from firefox with rhythmbox crashes last one

Changed in rhythmbox:
importance: Unknown → Critical
Anders Bruun Olsen (abo-dsl.dk) wrote :

It seems that rhythmbox crashes in different ways on my system when opening a .pls from di.fm:

[ 3771.742303] rhythmbox[2573] general protection ip:7f435d324461 sp:7fffdc3b2340 error:0 in librhythmbox-core.so.1.1.0[7f435d2d8000+149000]
[ 3968.141587] rhythmbox[2635] general protection ip:7f1b9ba63461 sp:7fff544db550 error:0 in librhythmbox-core.so.1.1.0[7f1b9ba17000+149000]
[ 3982.405509] rhythmbox[2667]: segfault at 7fff2cf9f880 ip 00007fff2cf9f880 sp 00007fff2cf9f6a8 error 15
[ 4543.822265] rhythmbox[2945]: segfault at 24000000045d ip 00007f5e226f9413 sp 00007ffff1e3de58 error 4 in librhythmbox-core.so.1.1.0[7f5e22692000+149000]
[ 4705.019296] rhythmbox[3023] general protection ip:7f83e18c0461 sp:7ffffe5244f0 error:0 in librhythmbox-core.so.1.1.0[7f83e1874000+149000]

Each of these crashes occurred when trying to run "rhythmbox listen.pls" from a terminal window with rhythmbox already running.

Guybrush88 (guybrush) wrote :

i got this crash while i was importing some songs into rhythmbox on maverick. i also had my ipod classic connected to the computer

Pedro Villavicencio (pedro) wrote :
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Committed
Changed in rhythmbox:
status: New → Fix Released
Changed in rhythmbox (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Omer Akram (om26er) wrote :

rhythmbox 0.13.2 is in natty.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-12-17
description: updated
Jamie Strandboge (jdstrand) wrote :

Uploaded to maverick-proposed, pending ubuntu-sru approval.

Changed in rhythmbox (Ubuntu Maverick):
status: Triaged → Confirmed

Accepted rhythmbox into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox (Ubuntu Maverick):
status: Confirmed → Fix Committed
tags: added: verification-needed
Fabri Velas (fabrivelas) wrote :

Packages from maverick-proposed fix this fault, thanks.

Omer Akram (om26er) on 2011-02-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.13.1-0ubuntu6.1

---------------
rhythmbox (0.13.1-0ubuntu6.1) maverick-proposed; urgency=low

  * debian/patches/93_dont_crash_if_multiple_feeds_are_selected.patch:
    - Don't crash if multiple podcast feeds are selected. (LP: #404255)
  * debian/patches/94_dont_crash_when_trying_to_show_properties_if_ipod_db_load_fails.patch:
    - Don't crash when right clicking on ipod to get properties. (LP: #651261)
  * debian/patches/95_specify_the_right_pointer_for_the_parser_entry-added_handler.patch:
    - Don't crash when opening .m3u file. (LP: #410510)
 -- Omer Akram <email address hidden> Tue, 14 Dec 2010 00:16:52 +0500

Changed in rhythmbox (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.