can not rename artist mp3 tags

Bug #385892 reported by nelson2k
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When I right click on a song, or multiple songs, and I change the artist name, rhythmbox changes it properly, but after a few seconds it undoes the changes and returns to the previous artist name.
This bug does not apply to the song name or any other property, just the artist property.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.0-0ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.28-11-generic x86_64

Revision history for this message
nelson2k (nelson2k) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

thanks for the report, it does change that here, could ou get a rhythmbox debug log and attach an example to the report? please get a debug log with: rhythmbox --debug &> rhythmbox-debug.txt and attach the resulting file to the report, thanks.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Revision history for this message
paulo r (paulor0) wrote :

Opened rhythmbox, clicked on Recently Added, and then tried to rename artist name from "Quejas de Bandoneon (tango 1924 Orq. Anibal Troilo)" to just "Anibal Troilo" on the file:
/shared/mp3/tango/Various/La Historia del Tango/01-Quejas de Bandoneon (tango 1924 Orq. Anibal Troilo)-Quejas de Bandoneon (tango 1924 Orq. Anibal Troilo).mp3

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
paulo r (paulor0) wrote :

ubuntu is 9.10 with latest updates installed;
rhythmbox is 0.12.5

Revision history for this message
simonkaspar (simonkaspar) wrote :

hi, i have the same problem under Lucid Lynx. However, it's the same when i try to edit the tags in easytag or another media player, so i don't think this is a rhythmbox-issue! My music folder has reading+writing permission, but somehow the system doesn't act like it.

Revision history for this message
Walter Garcia-Fontes (walter-garcia) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Paul White (paulw2u) wrote :

Bug didn't expire due to assignment
No response to comment #7 for further information
or any comments to suggest bug still exists for over 5 years
Artist name changeable here with rhythmbox 3.4.3 so closing as fixed

Changed in rhythmbox (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers