rhythmbox does not update podcast feed

Bug #377189 reported by mikeberner on 2009-05-16
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

when subscribing to new feed, rhythmbox downloads new episodes as it should. when restarting rhythmbox, the program does not download new episodes any more. only thing that works is deleting feed and re-installing.
os: ubuntu 9.04
rhythmbox version: 0.12.0.-0ubuntu4
expected new episodes to download automatically or to be able to download them by pressing the refresh (aktualisieren in german version) button.
instead nothing happens

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.0-0ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.28-11-generic i686

Related branches

mikeberner (bernerfamily) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. I can't confirm the issue there but it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Jay Luker (lbjay-reallywow) wrote :

I'm having this same problem. FYI, I have found (and bumped) what I think is the corresponding bug over at https://bugzilla.gnome.org/show_bug.cgi?id=588170

Thanks, linking the bug here and accordingly setting the bug to "triaged".

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Neil Perry (nperry) wrote :

I believe https://bugzilla.gnome.org/show_bug.cgi?id=551402 is more relevant to this bug,

I didn't know that you guys were already aware of the problem. I know
that it will get fixed until then I'm kind of forced to boot windows
and use iTunes.
Thanks Joe

On Dec 11, 2009, at 1:25 PM, Neil Perry <email address hidden> wrote:

> I believe https://bugzilla.gnome.org/show_bug.cgi?id=551402 is more
> relevant to this bug,
>
> ** Bug watch added: GNOME Bug Tracker #551402
> https://bugzilla.gnome.org/show_bug.cgi?id=551402
>
> ** Changed in: rhythmbox
> Remote watch: GNOME Bug Tracker #588170 => GNOME Bug Tracker #551402
>
> --
> rhythmbox does not update podcast feed
> https://bugs.launchpad.net/bugs/377189
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The Rhythmbox Music Management Application: Unknown
> Status in “rhythmbox” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: rhythmbox
>
> when subscribing to new feed, rhythmbox downloads new episodes as it
> should. when restarting rhythmbox, the program does not download new
> episodes any more. only thing that works is deleting feed and re-
> installing.
> os: ubuntu 9.04
> rhythmbox version: 0.12.0.-0ubuntu4
> expected new episodes to download automatically or to be able to
> download them by pressing the refresh (aktualisieren in german
> version) button.
> instead nothing happens
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/rhythmbox
> Package: rhythmbox 0.12.0-0ubuntu4
> ProcEnviron:
> PATH=(custom, user)
> LANG=de_CH.UTF-8
> SHELL=/bin/bash
> SourcePackage: rhythmbox
> Uname: Linux 2.6.28-11-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/rhythmbox/+bug/377189/+subscribe

Andy Buchanan (andy-buchanans) wrote :

I am also experiencing this problem on 9.10.

This podcast does not auto-update. http://feeds.feedburner.com/marshill/podcast

If I remove it and add it again, new episodes appear. I suspected the problem might be to do with my transparent proxy, so I temporarily disabled it, but this made no difference. If I load the URL with wget or in a web browser.

The dates do not appear to be in any sort of ambiguous format as suggested in the Gnome bugzilla bug.

The other bug that this is a duplicate off removed the "papercut" status because Banshee was due to become the default player in Ubuntu 9.10, replacing Rhythmbox, but I believe this was changed and Rhythmbox is still the default player; this means that this /is/ a papercut.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.7-0ubuntu8

---------------
rhythmbox (0.12.7-0ubuntu8) lucid; urgency=low

  * updated patches ordering
  * debian/patches/12_git_correctly_unref_entry.patch:
    - git change to correct unref entries and avoid leaking
  * debian/patches/13_git_gvfs_unmount_mtp_devices.patch:
    - git change to unmount gphoto gvfs mounts so the mtp code can use those
      (lp: #348287)
  * debian/patches/14_git_null_protect.patch:
    - git change to protect against null property values
  * debian/patches/15_git_correct_podcast_update.patch:
    - git change to correctly update the podcasts lists (lp: #377189)
  * debian/patches/16_git_magnatune_fixes.patch:
    - git fixes to the magnatune code
  * debian/patches/17_git_tags_buffer.patch,
    debian/patches/18_git_notify_art_change.patch:
    - git changes to fix embedded cover not been displayed sometime
      (lp: #533748)
  * debian/patches/19_git_no_mtp_on_afc_devices.patch:
    - git change to not have mtp take over ipod for afc devices
 -- Sebastien Bacher <email address hidden> Tue, 23 Mar 2010 01:16:15 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released

Great that this bug has been fixed!

sorry for the stupid question, I'm just a computer illiterate that doesn't want to use windows...

How do I get and install this new version of rhythmbox?
If I look in my "Synaptic Package Manager" i find only the version that is already installed on my computer ( 0.12.5-0ubuntu5.2 )
Thanks

Zeno Gantner (zeno-gantner) wrote :

Hi Paolo.

the package will be available in Lucid Lynx, which will be released in two weeks:
https://wiki.ubuntu.com/LucidLynx

If you can't wait (or want to help finding last-minute bugs), you can upgrade
to the Beta version of Lucid Lynx right now:
http://www.sizzledcore.com/2010/03/22/how-to-upgrade-ubuntu-9-10-to-ubuntu-10-04-beta-1/

Best,
  Zeno

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.