rhythmbox need support for easy-codec-installation

Bug #37671 reported by Adam Lydick on 2006-04-02
80
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
Baltix
Undecided
Unassigned
rhythmbox (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

In feisty easy-codec-installation https://wiki.ubuntu.com/EasyCodecInstallation allow applications to easily install any codec that they need. It is currently supported by totem, but not rhythmbox.

-- old decsription --
Rhythmbox (via gstreamer) lacks out-of-the-box support for mp3. This is by-design. However, the error message that is shown isn't very helpul. It currently reads:

"Playback Error: You do not have a decoder installed to handle this file. You might need to install the necessary plugins."

It would be nice if the error message stated *what* the missing codec was. Obviously this isn't possible (there are an unbounded number of codecs and containers) in all cases, but it would be nice to give the user some helpful information for the most common codecs: AAC, MP3, WMA, ...

Related branches

Sebastien Bacher (seb128) wrote :

Thanks for your bug. There is already a specification about that: https://wiki.ubuntu.com/EasyCodecInstallation

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Chris Wagner (chris-wagner) wrote :

It's probably okay to close this now, with the EasyCodecInstallation spec implemented, no?

Sebastien Bacher (seb128) wrote :

totem has been modified for easy-codec-installation, rhythmbox not yet

will_in_wi (will-in-wi) wrote :

The title should probably be changed to reflect the easy-codec-installation spec getting implemented in RB.

sam tygier (samtygier) on 2007-03-24
description: updated

To me, Rhythmbox is the "natural" music player, not Totem. It'd be really helpful if easy-codec-installation could be implemented for Rhthmbox.

pirast (pirast) wrote :

A new user will probably double click on the video / music file, and not use Rhythmbox directly.

Rhythmbox easy-codec installation and Totem-mozilla easy-codec installation is a nice to have though, which is (for Rhythmbox) described in the spec, but it is not that worse when it is not available in Feisty.

alextj (alextj) wrote :

For me, first thing after installing a fresh Ubuntu Feisty system is to check out my music collection, so naturally I look for Music Player in Applications menu.

Rhythmbox nicely welcomes me and offers to locate my music files! I select the music folder with my MP3s and OGGs, complete the wizard, but the biggest part of my collection just does not appear on my playlist!

Rhythmbox doesn't give me any error messages, it just silently excludes my MP3s from playlist, which is rather confusing for someone who doesn't know anything about media formats.

"Why is half of the music missing from playlist?" - my friend wonders. I start explaining him about codecs and that Easy Codec Installation only works when you open files from file browser (Nautilus) that will launch Totem that will install the codecs... To which he says "That's stupid?". I bet he is right.

Rhythmbox is the only "Music Player" on Ubuntu installed by default. Please, make it work, apply Easy Codec Installation to Rhythmbox as well. Going through not so obvious steps of first opening music files in a Movie Player in order to install MP3 support for your Music Player sounds silly.

For most people there is no music without MP3s. Most of portable music players (usually named "MP3 players") unfortunately do not support OGG. Do not include non-free formats in system, but make it easy to install them when needed. Thank you!

Sebastien Bacher (seb128) wrote :

alextj, could you subscribe when you comment to a bug so you get replies to your comment? Nice that you have interest in Ubuntu, such comment are not useful though. We know that this would be nice to have, the thing is that we have thousand of bugs open and only a very limited number of maintainers working on them so it can take time to go there

Hi Sebastien. Do you know what work/changes this bug will involve? Or
perhaps you know who implemented the easy-codec-installation component
for Totem? I may be interested in working on this, especially if
someone can point me in the right direction.

Sebastien Bacher (seb128) wrote :

Chris, Tim-Philipp Müller working on totem (http://bugzilla.gnome.org/show_bug.cgi?id=394697), if you want to work on it maybe asking on #rhythmbox or sending a mail on their list or comment on bugzilla could be a start

Changed in rhythmbox:
status: Unknown → Confirmed
Changed in rhythmbox:
status: New → Unknown
Changed in rhythmbox:
status: Unknown → Confirmed
beerfan (beerfan) wrote :

This feature is still very much needed.

I just updated my laptop to Gutsy beta and pulled up Rhythmbox to play some music shared on my desktop computer with avahi/firefly. Playing an mp3 doesn't even show any message at all but if you examine the song properties then there is a message about codec support.

I think the argument that users will only browse with nautilus and double-click music files is naive at best and avoiding the real issue at worst. Gutsy is great about doing the right thing with respect to missing components in most cases so this lack in Rhythmbox is all the more obvious.

Sebastien Bacher (seb128) wrote :

What "argument that users will only browse with nautilus and double-click music"? Where did you read that? The issue is only a lack of manpower to fix the thousand of desktop bugs open immediatly, it's likely to be fixed next cycle though

Changed in rhythmbox:
status: Confirmed → Triaged
Changed in rhythmbox:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

Fixed upstream, thanks.

Changed in rhythmbox:
status: Triaged → Fix Committed
unggnu (unggnu) wrote :

I still have this issue with current Hardy and I think it is important for thinks like Internet radio and so on.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.4-0ubuntu1

---------------
rhythmbox (0.11.4-0ubuntu1) hardy; urgency=low

  * New upstream version:
    - Support automatic GStreamer plugin installation (LP: #37671)
    - Improved cross-fading backend
    - Improved Podcast feed support, including Atom and APML (LP: #114846)
    - Add optional mozilla plugin to handle itms:// links
    - Fade volume when pausing and unpausing
    - Improve performance and stability of MTP device support (LP: #163609)
    - Stop putting deleted tracks on iPods in the Garbage Bin
    - Support PSPs with newer firmware
    - Improvements to the Coherence-based UPnP support
    - Minor improvements to Python bindings for plugins
  * debian/control.in:
    - Build-Depends on firefox-dev for the itunes browser plugin
    - updated totem-plparser and gstreamer requirements
  * debian/patches/06_oggradios.patch:
    - move the patch to the debian directory so it's not applied,
      upstream commited the change to SVN but that's likely an error

 -- Sebastien Bacher <email address hidden> Fri, 21 Dec 2007 15:30:03 +0100

Changed in rhythmbox:
status: Fix Committed → Fix Released
Elvis (elatsa77) on 2010-03-18
Changed in rhythmbox (Ubuntu):
status: Fix Released → Incomplete
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs without a comment, this bug is fixed so closing it again now

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.