0.9.0 Crashes after starting

Bug #3763 reported by Nathan Sprangers on 2005-11-01
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Crashes just a few seconds after starting with this error:

GLib-ERROR **: gmem.c:141: failed to allocate 1999580988 bytes
aborting...

Occurs with rhythmbox 0.9.0 from Breezy, running on PPC.

Changed in rhythmbox:
assignee: nobody → gnome
assignee: nobody → gnome
Sitsofe Wheeler (sitsofe) wrote :

Any chance you can attach a stack trace using the instructions outlined on http://live.gnome.org/GettingTraces ?

Nathan Sprangers (farruinn) wrote :

Unfortunately (hur, hur) I have resolved the issue by switching apps/rhythmbox/first_time_flag to true in the gconf editor. I have requested that a person from www.ubuntuforums.org who gets the same glib error to attach the stack trace.

Backtrace obtained by running 'gdb rhythmbox' then 'run' and 'thread apply all bt' at the gdb prompt

Backtrace obtained from starting rhythmbox then running 'gdb rhythmbox <pid>'
Output was different, so I've included both outputs.

It seems the problem is iPod related - it only occurs when my 30 GB Firewire/USB iPod is mounted.

Sebastien Bacher (seb128) wrote :

Thanks for the backtraces, they are not really useful though. Did you get them after the crash? Could you get one while using a debug package (https://wiki.ubuntu.com/DebuggingProgramCrash)?

Changed in rhythmbox:
status: New → NeedInfo
status: New → NeedInfo
Daniel Holbach (dholbach) wrote :

Do you still have the problem?

Changed in rhythmbox:
assignee: gnome → desktop-bugs
Nathan Sprangers (farruinn) wrote :

Yes, sorry for not following up on this sooner.

The backtraces are the same even with a debugging version of rhythmbox and libc6-dbg installed.

Backtrace with breakpoint at gmem.c:141

Installed:
rhythmbox-dbg
libc6-dgb
libglib2.0-0-dgb

run
backtrace

Looking like this is caused by the library database on my iPod. Banshee crashes with the attached messages about an incompatible database version, and gtkpod gives a warning about it containing extended info (that is ignored - gtkpod has no other problems with this iPod).

Nathan Sprangers (farruinn) wrote :

Sod it, I don't know what's causing this but it's resolved in a later version of Rhythmbox. Version 0.9.3 on the Dapper Beta LiveCD doesn't have this problem. This bug should be closed.

Lionel Dricot (ploum) on 2006-04-27
Changed in rhythmbox:
status: Needs Info → Fix Released
Sebastien Bacher (seb128) wrote :

bug closed, thank you for the comments and the work on that

Changed in rhythmbox:
status: Unconfirmed → Rejected
assignee: gnome → nobody
resto05 (ejsm12) on 2009-12-03
Changed in rhythmbox (Ubuntu):
status: Fix Released → Fix Committed
Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in rhythmbox:
assignee: nobody → Patrick (neumann-patrick1003)
assignee: Patrick (neumann-patrick1003) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers