Lyrics plugin not showing anything

Bug #374778 reported by Launchpad650 on 2009-05-11
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Hi, I'm using Jaunty with Rhythmbox 0.12.0. I searched the other posts about the lyrics plugin having bugs, but I can't get mine to work at all. I activate the plugin, but when I select "View Lyrics" on any song, a blank lyrics box pops up. Any suggestions?

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.0-0ubuntu4
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.28-11-generic i686

Launchpad650 (balanc-nick) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Could you add a song example?

 This will help us to find and resolve the problem.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Launchpad650 (balanc-nick) wrote :

Hello.

Yes, it's reproducible. I've actually never gotten the lyrics to work, and I just installed Ubuntu a few weeks ago. I go to edit > plugins and make sure the Song Lyrics option is checked. Then I select a song, say,

I Want It That Way, by the Backstreet Boys. All the information is filled out (Song title, artist, album, etc.), and the album art is fetched fine, but when I go to view > song lyrics, a the lyrics window pops up, but it is blank.

Can I mention to, that every time I load up Rhythmbox, it asks to search for plugins, but it can never find the packages, saying the requested plugin is

application/x-sqlite3 decoder

can you tell me what this is?

Sebastien Bacher (seb128) wrote :

the song might have no lyric on the website used to get the lyrics, could you add a buggy mp3 example to the bug?

the sqlite error is probably due to a sqlite file in your library directory

Launchpad650 (balanc-nick) wrote :

hmm, well it seems to be like this for every one of my mp3s, and most of my songs are well-known.

Sebastien Bacher (seb128) wrote :

there is works fine, without an example not easy to say if that's due to your song, your internet access or rhythmbox though

Sebastien Bacher (seb128) wrote :

there is works fine, without an example not easy to say if that's due to your song, your internet access or rhythmbox though

Launchpad650 (balanc-nick) wrote :

okay, sure. Sorry, it didn't click for some reason that you wanted an attachment.

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
blitzxp (blitz-xp) wrote :

Did you Configure the Song Lyrics plugin ? You can enable some search engines that are disabled by default.. that may get it to show some lyrics..

zasq (zasq) wrote :

Hi! I have the same problem as the bug reporter. I upgraded from intrepid to jaunty. Now Rhythmbox shows the Lyrics I had already downloaded in intrepid. But if I want to download the lyrics of a new song, it kind of freezes with the line "Nach Liedtexten suchen..." (that is "searching for lyrics"). Nothing else happens.
I have the plugin enabled and configured.
Any more ideas?
Any more information I can provide?
Thanks!

Sebastien Bacher (seb128) wrote :

The ubuntu team doesn't have the ressources to work on this specific issue but it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Victor Vargas (kamus) wrote :

I cannot reproduce this problem in Jaunty, lyrics plugin works fine for me, is slowly, but works.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Download full text (110.1 KiB)

Same/similar problems here.

1. I can see the search engines listed in plugin settings. And I have enabled only the working ones, and that's leoslyrics.com and lyricwiki.org. Other 3 (astraweb.com, lyrc.com.ar and winampcn.com) ain't functional lyrics search engines, what you can see by yourself by typing those adresses in a web browser.

2. With these two working engines enabled, the song "Last One To Die" by Rancid wont display lyrics at all. Just blank text box.

2. HTML source code is displayed, not the lyrics. Even when i disable the search engine that delivers me this kind of result (lyricwiki.org), I still get this. Example: song "Damnation" by Rancid:

"<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
 <title>MediaWiki API</title>
</head>
<body>
<pre>
<span style="color:blue;">&lt;?xml version=&quot;1.0&quot;?&gt;</span>
<span style="color:blue;">&lt;api&gt;</span>
  <span style="color:blue;">&lt;error code=&quot;help&quot; info=&quot;&quot; xml:space=&quot;preserve&quot;&gt;</span>

  <b>******************************************************************</b>
  <b>** **</b>
  <b>** This is an auto-generated MediaWiki API documentation page **</b>
  <b>** **</b>
  <b>** Documentation and Examples: **</b>
  ** <a href="http://www.mediawiki.org/wiki/API">http://www.mediawiki.org/wiki/API</a> **
  <b>** **</b>
  <b>******************************************************************</b>

  Status: All features shown on this page should be working, but the API
                   is still in active development, and may change at any time.
                   Make sure to monitor our mailing list for any updates.

  Documentation: <a href="http://www.mediawiki.org/wiki/API">http://www.mediawiki.org/wiki/API</a>
  Mailing list: <a href="http://lists.wikimedia.org/mailman/listinfo/mediawiki-api">http://lists.wikimedia.org/mailman/listinfo/mediawiki-api</a>
  Bugs &amp; Requests: <a href="http://bugzilla.wikimedia.org/buglist.cgi?component=API&amp;bug_status=NEW&amp;bug_status=ASSIGNED&amp;bug_status=REOPENED&amp;order=bugs.delta_ts">http://bugzilla.wikimedia.org/buglist.cgi?component=API&amp;bug_status=NEW&amp;bug_status=ASSIGNED&amp;bug_status=REOPENED&amp;order=bugs.delta_ts</a>

Parameters:
  format - The format of the output
                   One value: json, jsonfm, php, phpfm, wddx, wddxfm, xml, xmlfm, yaml, yamlfm, rawfm, txt, txtfm, dbg, dbgfm
                   Default: xmlfm
  action - What action you would like to perform
                   One value: insert, update, delete, wdelete, featuredcontent, partnerwikiconfig, ajaxlogin, imagethumb, theschwartz, lyrics, uploadlogo, foundersettings, createmultiplepages, login, logout, query, expandtemplates, parse, opensearch, feedwatchlist, help, paraminfo, purge, rollback, undelete, protect, block, unblock, move, edit, emailuser, watch, patrol, import
                   ...

Sebastien Bacher (seb128) wrote :

the new comment seems rather to be bug #452929

Goyo (goyodiaz) wrote :

Status should change to wontfix, I guess.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers