Ubuntu

[Dapper] Rhythmbox sometimes refuses to load files in directories with non-ascii names

Reported by Robin Sonefors on 2006-03-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I used Sound Juicer under Dapper to rip an album by a group called Slagsmålsklubben, which ended up in a directory with that name. Rhythmbox couldn't find it, even if I manually added the directory, or any sub-directory.

I renamed the directory to Slagsmalsklubben, and Rhythmbox happily found and played the album. Renamed it back, and I could not play it anymore.

Apparently, it doesn't matter if the files themself have non-ascii characters in their names, or if their ID3-tags contains non-ascii characters, since the songs seem to load and play just fine when the directory, but not any files, is renamed.

I also had an old directory with a ISO-8859-coded ü (my system is UTF-8), wich Rhythmbox also missed. However, strangely enough, that one was picked up after I replaced it with a UTF-8 ü.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Are those song displayed with an "invalid utf-8" information from nautilus?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Robin Sonefors (ozamosi) wrote :

The ISO-ones are, but not the other.

Sebastien Bacher (seb128) wrote :

What locale do you use? Could you attach or put an URL to download an example of a .mp3 having that issue?

Robin Sonefors (ozamosi) wrote :

Ok, I've dug into this a little deeper. Strangely enough, this seems to have nothing to do with locales - loads of my songs never gets added. When I run rhythmbox -d, it tells me "[0x868a578] [queue_stat_uri] rhythmdb.c:1789 (22:38:50): queueing stat for "filenames""

I also noted that when I manualy add the folder Slagsmålsklubben after having added my entire music folder, it does not get added. However, after deleting the music-db, and only adding that folder, it gets added just fine.

Robin Sonefors (ozamosi) wrote :

the row from rhythmbox -d is repeated for every song that I can't find in my playlist.

Sebastien Bacher (seb128) wrote :

Do you still have the issue? Could you attach an example? Does "gst-launch-0.10 -t filesrc location=/path/to/my/musicfile ! decodebin ! fakesink" on those songs work fine?

Robin Sonefors (ozamosi) wrote :

As I said, it doesn't seem to be the actual filenames that is the issue - I think one of the (probably broken) songs in my music directory just stops the import in some way.

Unfortunatly, I just threw my music collection away, so I can't really comment much more on this bug. A friend of mine has the music collection I had. He's running Gentoo, and he claims he witness this thing in "every music player except amaroK", so it's probably not rhythmbox's fault.

So. The app is wrong, and the description is wrong, although somewhere there really is a bug, but I can't really test it. Should this bug be closed?

Sebastien Bacher (seb128) wrote :

I'm marking that bug as rejected for now since it works now and you have no example triggering the issue. If you get the issue again you can run "rhythmbox -d" to figure what song has the issue. Feel free to reopen if you get the issue again

Changed in rhythmbox:
status: Needs Info → Rejected
sara (ms-sara-griffin) wrote :

i have marked this bug as confirmed as yes it will play the files but it will not display the names of the files so it wont dispplay chinease file names, or arabic... so slightly different but to do with the same thing?

Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers