magnatune catalog is not displayed by rhythmbox

Bug #354821 reported by rodomiro on 2009-04-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Expected to happen
Magnatune catalog to be loaded and displayed after having clicked Magnatune entry of the lateral panel.

Happened instead
After loading the Magnatune catalog, Rhythmbox continues displaying the Magnatunes' presentation page.
It is possible to listen tracks but impossible to browse them as a list.
However, Play, Previous and Next buttons work well and cover image is correctly displayed.

How to recreate
 1- Open Rhythmbox from Aplicationes menu.
 2- Clic the lateral panel Magnatune entry.
 3- Wait the Magnatune catalog to be loaded
 4- Catalog will be composed of 75 item and will never be displayed

lsb_release -rd
Description: Ubuntu 8.04.2
Release: 8.04

apt-cache policy rhythmbox
rhythmbox:
  Instalados: 0.11.5-0ubuntu8
  Candidato: 0.11.5-0ubuntu8
  Tabla de versión:
 *** 0.11.5-0ubuntu8 0
        500 http://fr.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.5-0ubuntu6 0
        500 http://fr.archive.ubuntu.com hardy/main Packages

ProblemType: Bug
Architecture: i386
Date: Fri Apr 3 21:37:06 2009
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: ath_hal fglrx
Package: rhythmbox 0.11.5-0ubuntu8
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-23-generic i686

Related branches

rodomiro (rodomiro) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

thank you for your bug report, to be confirmed by a magnatune user, would be worth trying on jaunty too

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Confirming, same behavior on Jaunty, the magnatune welcome page never goes away.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

rodomiro, may you please get a rhythmbox log with rhythmbox --debug &> rhythmbox-debug.txt perform the operation to reproduce the bug and attach that resulting file to the report? thanks.

What i'm getting here is:

Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/rb/Loader.py", line 85, in _read_cb
    if (self._callback_gdk(data) is not False) and data:
  File "/usr/lib/rhythmbox/plugins/rb/Loader.py", line 73, in _callback_gdk
    v = self._callback(result)
  File "/usr/lib/rhythmbox/plugins/rb/Loader.py", line 69, in _callback
    return self.callback(result, self.total, *self.args)
  File "/usr/lib/rhythmbox/plugins/magnatune/MagnatuneSource.py", line 322, in __catalogue_chunk_cb
    parser.feed(result)
  File "/usr/lib/python2.6/xml/sax/expatreader.py", line 211, in feed
    self._err_handler.fatalError(exc)
  File "/usr/lib/python2.6/xml/sax/handler.py", line 38, in fatalError
    raise exception
xml.sax._exceptions.SAXParseException: <unknown>:1658:24: not well-formed (invalid token)

could it be due to that the plugin is not supporting the new api? there's a bug upstream about it: http://bugzilla.gnome.org/show_bug.cgi?id=533727

jjcool (stefan-ziel) wrote :

There is an invalid character on the position accused by the SAXParseException

~/.gnome2/rhythmbox/magnatune/song_info.xml (line 1658 column 24)

jjcool (stefan-ziel) wrote :

removing this characters it comes to work again

Pedro Villavicencio (pedro) wrote :

Right, fix is available at http://bugzilla.gnome.org/show_bug.cgi?id=574465 and the commit on the svn is http://svn.gnome.org/viewvc/rhythmbox?view=revision&revision=6274; marking this as fix committed

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Committed
Changed in rhythmbox:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.0-0ubuntu4

---------------
rhythmbox (0.12.0-0ubuntu4) jaunty; urgency=low

  * debian/patches/94_svn_change_fix_magnatune_loading.patch:
    - svn change to fix the magnatune catalog loading (lp: #354821)

 -- Sebastien Bacher <email address hidden> Tue, 07 Apr 2009 22:10:46 +0200

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.