rhythmbox can't open mtp devices when already mounted by gvfs

Bug #348287 reported by Saivann Carignan on 2009-03-25
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

In jaunty alpha 6, my creative zen vision :M 30g is automatically mounted by gvfs when plugged in. Accordingly, GNOME ask what to do when I plug the device and the only choice is rhythmbox, however when opening rhythmbox (with mtp plugin enabled), the device does not appear anywhere. When launched in a terminal, rhythmbox prints : "LIBMTP PANIC: Unable to initialize device"

Rhythmbox is only able to detect and use the device if I open it while the device is NOT mounted by gvfs.

rhythmbox : 0.12.0-0ubuntu1
gvfs : 1.2.0-0ubuntu1
libmtp8 : 0.3.0-1ubuntu3

Related branches

Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's known upstream on http://bugzilla.gnome.org/show_bug.cgi?id=520121

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in rhythmbox:
status: Unknown → Confirmed
scotty2 (granny6989) wrote :

This is/was part of another bug that I was having regarding the same problem. Problem is that gphoto/gvfs shouldn't be grabbing hold of the Zen players.

Looking at the 'mounted' Zen. It shows it's properties as a gphoto2 filesystem. Once again, the issue seems to be that gphoto2 is mounting the Zen, which it should not be doing. It's not a camera or camera device. It can handle pictures, but only for viewing, and is easily loaded through Gnomad2.

I'm back to the 'double mount', where the Zen is mounted by the filesystem, and just as it releases, is remounted by gphoto2. It's then locked (docked) to the system through gphoto, and becomes unavailable for the programs that work with it - Gnomad2, and Rhythmbox. Until I manually(through desktop) go in and unmount, the Zen can't work with the programs that it's supposed to. Once unmounted it seems to work as expected, I haven't noticed any other problems other than this mount/gphoto2 issue.

So the gphoto error is gone, but gphoto should not be grabbing hold of the Zen player.

S*

Castruita (fmcastruita) wrote :

I confirm this on latest ubuntu jaunty's version, i have to unmount my MTP device (ZEN 4GB) from gphoto/gvfs first then launch Rhythmbox to get detected.

jordilin (jordilin) wrote :

I am using Ubuntu Jaunty 64 bit and I get the same problem:

rhythmbox
PTP: Opening session
LIBMTP PANIC: Unable to read device information on device 6 on bus 0, trying to continue

jordilin (jordilin) wrote :

I compiled 0.3.6 of libmtp and works. I posted workaround in here:

http://jordilin.wordpress.com/2009/05/04/libmtp-and-ubuntu-jaunty-mtp-devices-rhythmbox/

Alex Perry (perry-alex) wrote :

I just compiled libmtp version 1.0.0 and still receive the 'LIBMTP PANIC: Unable to read device information on device 6 on bus 0' message when trying to access my Nokia N95.

Luca Ferretti (elle.uca) wrote :

The issue was just fixed on git master[1]. Any hope to include this patch in for 10.04?

[1] http://git.gnome.org/browse/rhythmbox/commit/?id=adcf9ea14a700f3824aa6c0b01127d4ed2308fc7

Saivann Carignan (oxmosys) wrote :

I build rhythmbox in my PPA with this patch included. Since I don't have a MTP device anymore, can someone test it and give feedback if the patch fixes the issue?

PPA :
https://launchpad.net/~saivann/+archive/ppa

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.7-0ubuntu8

---------------
rhythmbox (0.12.7-0ubuntu8) lucid; urgency=low

  * updated patches ordering
  * debian/patches/12_git_correctly_unref_entry.patch:
    - git change to correct unref entries and avoid leaking
  * debian/patches/13_git_gvfs_unmount_mtp_devices.patch:
    - git change to unmount gphoto gvfs mounts so the mtp code can use those
      (lp: #348287)
  * debian/patches/14_git_null_protect.patch:
    - git change to protect against null property values
  * debian/patches/15_git_correct_podcast_update.patch:
    - git change to correctly update the podcasts lists (lp: #377189)
  * debian/patches/16_git_magnatune_fixes.patch:
    - git fixes to the magnatune code
  * debian/patches/17_git_tags_buffer.patch,
    debian/patches/18_git_notify_art_change.patch:
    - git changes to fix embedded cover not been displayed sometime
      (lp: #533748)
  * debian/patches/19_git_no_mtp_on_afc_devices.patch:
    - git change to not have mtp take over ipod for afc devices
 -- Sebastien Bacher <email address hidden> Tue, 23 Mar 2010 01:16:15 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: Confirmed → Fix Released
Martin Pool (mbp) wrote :

Scotty@6, you're probably hitting bug 544944.

Seba78 (teo78) wrote :

En mi caso el reproductor mtp que falla al momento en que rhythmbox intenta abrirlo es un teléfono celular Samsung SGH-F250L, en modo mtp.

Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.