rhythmbox doesn't resume lastfm tracks

Bug #347784 reported by Benjamin_L
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When pausing lastfm playback and trying to resume, it doesn't work, it shows a one way street icon and doesn't play at all. It would be nice to have resume like in banshee or at least it should skip the currently playing track so there's music at all.

Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your bug report, what ubuntu version do you use?
that should be sent to bugzilla.gnome.org by a lastfm user

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Benjamin_L (benjamin-lebsanft) wrote :

This is latest jaunty, 64bit, rhythmbox 0.12.0. But the behaviour was the same for several releases.

Should I open a gnome bug?

Revision history for this message
Benjamin_L (benjamin-lebsanft) wrote :
Changed in rhythmbox:
status: Unknown → New
Revision history for this message
Andreas Moog (ampelbein) wrote :

Thanks for opening bug report upstream.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
myxiplx (myxiplx) wrote :

I've also seen this behaviour, but it appears to be a little more complex than just not being able to resume. Quite a lot of the last.fm behaviour appears buggy. Apologies if this should have been filed as a separate bug, however I believe it is all related and has the same root cause.

One of the first times I tried to pause and resume a track, I had an error appear saying the appropriate codec could not be found, I didn't get the details I'm afraid but it said something about html content. This has only appeared once so far.

Every time I pause & resume, I get the stop symbol and can't resume playback. From that point on I can't go back to listen to that track. In fact, any attempt to rewind a track, or go back to a previous track also causes this problem.

I have also had this happen once on the last track of a set list, in a way that appeared to prevent RhythmBox requesting more tracks from last.fm. I couldn't begin playing the last track, nor could I scroll down to get new tracks, nor could I go back to any previously listened to songs - any attempt to do so ended up putting a stop symbol next to those songs. In the end I had to select a new station, and then go back to the original station to start listening again.

The fact that the last.fm web player only has stop & skip buttons makes me think that quite a few of the standard rhythmbox behavious need changing or disabling to support this properly. My suggestion would be that when playing from last.fm:

- Previous, repeat & shuffle functions should be disabled.
- Pause should be mapped to stop
- Previously listened to tracks should be greyed out, to prevent users attempting to go back to them.

Mapping pause to stop may be a little controversial (and might be better as an optional setting for last.fm playback). However, since RhythmBox doesn't have dedicated stop or pause buttons I feel it would be an acceptable move, and I for one would appreciate being able to use my keyboards play/pause button with last.fm in the same way I use it for everything else.

And in fact, now I've written this, I wonder if the lack of pause functionality at last.fm expains the codec error too. If RhythmBox is expecting to be able to pause & resume a track, but last.fm instead starts on a new track, I wonder if that could occasionally cause RhythmBox to get confused over what to expect? If last.fm is at that point sending a new track list instead of streaming music, could that explain the codec error?

Revision history for this message
Benjamin_L (benjamin-lebsanft) wrote :

I see the same things but fact is, banshee can resume last.fm tracks, so it should be possible for rhythmbox too.

Revision history for this message
Loco Ulysses (locoulysses) wrote :

If I'm playing last.fm in Rhythmbox, then I double click on an empty (non-last.fm) playlist the music stops, but if I double click on last.fm again it starts back up where it was. Obviously pausing is possible. The point that Last.fm doesn't allow it on the website though is

As for the other things, internet radio has to follow certain legislation (DMCA) and court rulings (http://www.broadcastlawblog.com/tags/internet-radio-fees/) regarding interactivity. Internet radio stations already have to pay general licensing fees to play music at all (unlike regular radio), and if they are "interactive" (ie. let people specifically choose the songs they want to hear and when to hear them) then they must negotiate/pay licensing fees individually for each song. Apparently replaying a song, or being able to skip ahead indefinitely is considered too much control.

Look at Pandora, for instance. Even paid subscribers have a limit to how many songs they can skip in a given period, and can never go back/replay a song.

Revision history for this message
ignoch (ignoch-gmail) wrote :

I have a error when put my last.fm login and pass. It says "Request Failed: Cannot connect to destination". In the queue, i have a 27 tracks waiting to scroll, but if i run "rhythmbox -D lastfm" says:

(16:18:33) [0x23c8040] [create_handshake_request] rb-lastfm-source.c:1594: logging in
(16:18:33) [0x23c8040] [handle_handshake_response] rb-lastfm-source.c:1675: response body: session=d4c925ade00c2a42930431c837a39007
(16:18:33) [0x23c8040] [handle_handshake_response] rb-lastfm-source.c:1690: session ID: d4c925ade00c2a42930431c837a39007
(16:18:33) [0x23c8040] [handle_handshake_response] rb-lastfm-source.c:1695: stream url:
(16:18:33) [0x23c8040] [process_queue] rb-lastfm-source.c:1486: request queue is empty
(16:18:38) [0x23c8040] [on_gconf_changed_cb] rb-lastfm-source.c:358: GConf key updated: "/apps/rhythmbox/audioscrobbler/password"

I try to change the credentials many times with the same result.

Revision history for this message
ignoch (ignoch-gmail) wrote :

apparently the server is down

Changed in rhythmbox:
importance: Unknown → Low
Changed in rhythmbox:
status: New → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.