rhythmbox crashed with SIGSEGV in g_main_context_dispatch()

Bug #346877 reported by Tuomas Aavikko on 2009-03-22
106
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Running up-to-date jaunty

steps to reproduce:
1. open rhythmbox
2. Use search: to narrow the results of playlist,
example, I have 11k files on library so wanting play "titles" that contain "ghost of tom joad"
That'll give me 3 results.
3. Click play (No shuffle/repeat is on)
4. Listen the songs
5.When playlist is finished, rhythmbox crashes

[ 111.155928] rhythmbox[3475]: segfault at 38 ip 00007f40107c63b6 sp 00007fff18c16ef0 error 4 in librhythmbox-core.so.0.0.0[7f4010761000+92000]
[ 1116.661157] rhythmbox[3689]: segfault at 38 ip 00007faa170313b6 sp 00007fff1f4829f0 error 4 in librhythmbox-core.so.0.0.0[7faa16fcc000+92000]

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.0-0ubuntu1
ProcCmdline: rhythmbox
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? () from /usr/lib/librhythmbox-core.so.0
 ?? () from /usr/lib/librhythmbox-core.so.0
 ?? () from /usr/lib/libgstreamer-0.10.so.0
 g_main_context_dispatch ()
 ?? () from /usr/lib/libglib-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in g_main_context_dispatch()
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Tuomas Aavikko (taavikko) wrote :
visibility: private → public
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
Tuomas Aavikko (taavikko) wrote :

It doesn't matter if there's 1 song or 30 selected, crash happens every time.

setting "gstreamer-properties" to "autodetect(pulseaudio)" or "alsa" has no effect
So used audio-output module isn't or at least shouldn't be the cause.

René López (elmago79) wrote :

I have exactly the same behaviour here.

StacktraceTop:unlink_blocked_cb (pad=<value optimized out>,
rb_player_gst_xfade_bus_cb (
gst_bus_source_dispatch (source=0x3adf810,
IA__g_main_context_dispatch (context=0x220a5e0)
g_main_context_iterate (context=0x220a5e0, block=1,

When playlist is finished, rhythmbox crashes

when i launch rhythmbox in a terminal, i get the following message when it crash at the end of a reproduction list:

(rhythmbox:21253): GStreamer-CRITICAL **: gst_pad_unlink: assertion `GST_IS_PAD (sinkpad)' failed

(rhythmbox:21253): Rhythmbox-WARNING **: Couldn't unlink stream file:///home/damian/M%C3%BAsica/Yeah%20Yeah%20Yeahs%20-%20It's%20Blitz%20%5Bmp3-192-2009%5D/10%20-%20Little%20Shadow.mp3: things will probably go quite badly from here on
Fallo de segmentación (core dumped)

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a '.crash' file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

 If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

 If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

 If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.
 I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
status: New → Invalid
Tuomas Aavikko (taavikko) wrote :

@sebastian,

I used the file in /var/crash to report this issue.

But indeed apport isn't running by default as it is disabled in "system services" or "startup apps"
in which ever it was located.

Sebastien Bacher (seb128) wrote :

sorry I got confused by the new comments and didn't notice the retracing before in my emails

Changed in rhythmbox (Ubuntu):
status: Invalid → New

2009/3/26 Sebastien Bacher <email address hidden>

> sorry I got confused by the new comments and didn't notice the retracing
> before in my emails
>
> Shouldn't this be marked as "confirmed" since there's at least 3
dublicates, and few more reporting this as confirmed?

If someone could test if this triggered by enabling "cross-fading" ?
I'm on vacation, and nowhere near my Jaunty running GNOME.

>Läski<

Sebastien Bacher (seb128) wrote :

That's http://bugzilla.gnome.org/show_bug.cgi?id=576031 and already fixed to svn

Changed in rhythmbox (Ubuntu):
status: New → Fix Committed
Changed in rhythmbox:
status: Unknown → Fix Released
Changed in rhythmbox (Ubuntu):
milestone: none → ubuntu-9.04
Gustavo Carneiro (gjc) wrote :

Yes, it is due to cross-fade.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.0-0ubuntu2

---------------
rhythmbox (0.12.0-0ubuntu2) jaunty; urgency=low

  * debian/patches/90_svn_change_fix_crasher.patch:
    - svn change to fix a crasher (lp: #346877, #346514)
  * debian/patches/91_svn_change_decodebin2_fix_chained_ogg.patch:
    - svn change to use decodebin2 that should fix the playing of chained ogg
      (lp: #127374)
  * debian/patches/92_svn_change_fix_psp_nokia770_crasher.patch:
    - svn change to fix a crash with psp and nokia770 devices (lp: #183797)
  * debian/patches/93_svn_change_fix_device_change_crasher.patch:
    - svn change to fix a crash on device change (lp: #73059)

 -- Sebastien Bacher <email address hidden> Wed, 01 Apr 2009 21:50:31 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.