Rhythmbox crashes at the end of CD

Bug #346514 reported by Franklin Bynum on 2009-03-21
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Jaunty by Alexey Osipov

Bug Description

Binary package hint: rhythmbox

Steps to reproduce:
1. Open rhythmbox
2. Start cd playback
3. Skip to last track, move track progress slider to a few seconds before the
end of track
4. Let track finish
5. Crash

Terminal output is:

(rhythmbox:16454): GStreamer-CRITICAL **: gst_pad_unlink: assertion `GST_IS_PAD
(sinkpad)' failed

(rhythmbox:16454): Rhythmbox-WARNING **: Couldn't unlink stream
cdda://15#/dev/sr0: things will probably go quite badly from here on

Using version 0.12.0-0ubuntu1 in jaunty.

Related branches

Franklin Bynum (frabyn) wrote :
Changed in rhythmbox:
status: Unknown → New
Alexey Osipov (lion-simba) wrote :

Confirm bug.

Bug is there not only with CD playback, but with any album from media library.

Same version of rhythmbox.

Don't know how important is it: I've uninstalled pulseaudio. gstreamer works directly with ALSA for me.

Changed in rhythmbox:
status: New → Invalid
Andreas Moog (ampelbein) on 2009-03-23
Changed in rhythmbox:
status: Invalid → Unknown
Andreas Moog (ampelbein) wrote :

Probably fixed in trunk according to upstream, i'm building a version with the patch included in my ppa right now. Please test if the issue is fixed for you and report back here or upstream, thanks.

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in rhythmbox:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed to svn now

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Alexey Osipov (lion-simba) wrote :

When this fix will be in 9.04 repo?

Strange Peer (intp-16708) wrote :

hello,

I've tested the patch and it fixes the problem, thanks you !

nice work :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.0-0ubuntu2

---------------
rhythmbox (0.12.0-0ubuntu2) jaunty; urgency=low

  * debian/patches/90_svn_change_fix_crasher.patch:
    - svn change to fix a crasher (lp: #346877, #346514)
  * debian/patches/91_svn_change_decodebin2_fix_chained_ogg.patch:
    - svn change to use decodebin2 that should fix the playing of chained ogg
      (lp: #127374)
  * debian/patches/92_svn_change_fix_psp_nokia770_crasher.patch:
    - svn change to fix a crash with psp and nokia770 devices (lp: #183797)
  * debian/patches/93_svn_change_fix_device_change_crasher.patch:
    - svn change to fix a crash on device change (lp: #73059)

 -- Sebastien Bacher <email address hidden> Wed, 01 Apr 2009 21:50:31 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.