Rhythmbox tries to find a codec for a m3u/html file

Bug #343707 reported by Evgeny Kuznetsov on 2009-03-16
174
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Jaunty by Martin Pitt

Bug Description

Binary package hint: rhythmbox

Every time I start Rhythmbox it asks me to search for a missing codec, and never finds one. That's not surprising, as it searches for text/html codec, which obviously does not exist.

I must say that of all the *.txt files that reside in my library folder, this is the only one that causes such problems, other text files are safely ignored by Rhythmbox. Perhaps, Rhythmbox should ignore this file as well, but it doesn't.

This behaviour was introduced after upgrade to Jaunty Alpha. In Intrepid the file was ignored as it should be.
Rhythmbox is version 0.11.99.1-0ubuntu1 on 64-bit Jaunty with all latest updates.

Pedro Villavicencio (pedro) wrote :

thanks for the report, not confirming, what i get there with the same file is an import error "The MIME type of the file could not be identified". May you please get a rhyhthmbox debug log? run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt perform the operation to reproduce the bug and attach the resulting file to the report, if possible first delete your rhyhtmbox database to have a clean install. thanks.

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Evgeny Kuznetsov (nekr0z) wrote :

I did run Rhythmbox, waited for a "search for missing codec" window to appear, allowed it to search, waited until Rhythmbox confirmed it had found no suitable codec, then closed the window and exited Rhythmbox. Debug file is attached.

Pedro, could you please tell me where the database is, so that I could clear it? ~/.gnome2/rhythmbox/ is empty.

Pedro Villavicencio (pedro) wrote :

Evgeny is at ~/.local/share/rhythmbox could you delete it and try again? thanks.

Pedro Villavicencio (pedro) wrote :

Please also paste the output of the command line, it should say something about the codec.

Evgeny Kuznetsov (nekr0z) wrote :

Thanks, Pedro. With ~/.local/share/rhythmbox/rhythmdb.xml removed I have the same behaviour (except for the fact that it takes much longer to rescan the library and naturally much longer for "Install missing multimedia codecs" window to appear. Debug is attached.

When run in debug mode, Rhythmbox produces nothing in console. Here's the output of Rhythmbox run in usual mode (i. e. command "rhythmbox" in console):

(rhythmbox:18742): Rhythmbox-WARNING **: Could not open device /dev/radio0
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html
Rhythmbox-Message: No installation candidate for missing plugins found.
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing

Christoph Langner (chrissss) wrote :

I can confirm this issue. Rhytmbox tries to download codecs for text files. When i rescan my library (which i happens every time i start Rhytmbox) i get the following messages when i start Rhytmbox in debug mode...

$ rhythmbox -d
[...]
(09:26:03) [0x284fc30] [action_thread_main] rhythmdb.c:2891: executing RHYTHMDB_ACTION_LOAD for "file:///media/data_extern/mp3/Gentleman/1999_Trodin_On/Gentleman%20-%20Trodin%20On.m3u"
(09:26:03) [0x16cd500] [rhythmdb_process_one_event] rhythmdb.c:2486: processing RHYTHMDB_EVENT_METADATA_LOAD
(09:26:03) [0x16cd500] [rhythmdb_process_metadata_load] rhythmdb.c:2392: missing plugins during metadata load for file:///media/data_extern/mp3/Gentleman/2004_Confidence/Gentleman%20-%20Confidence.m3u (event = 0x7f4fbc04c290)
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|audio/x-mpegurl decoder|decoder-audio/x-mpegurl
(09:26:03) [0x16cd500] [missing_plugins_event] rb-missing-plugins.c:226: gst_install_plugins_async() result = 200
(09:26:03) [0x16cd500] [rhythmdb_process_metadata_load] rhythmdb.c:2402: processing missing plugins
[...]
(09:28:59) [0x31190a0] [action_thread_main] rhythmdb.c:2891: executing RHYTHMDB_ACTION_LOAD for "file:///media/data_extern/mp3/Jack_Johnson/2005_In_Between_Dreams/Jack%20Johnson%20-%20In%20Between%20Dreams.m3u"
(09:28:59) [0x1648500] [rhythmdb_process_one_event] rhythmdb.c:2486: processing RHYTHMDB_EVENT_METADATA_LOAD
(09:28:59) [0x1648500] [rhythmdb_process_metadata_load] rhythmdb.c:2392: missing plugins during metadata load for file:///media/data_extern/mp3/James_Blunt/2006_Monkey_on_My_Shoulder_EP/somelink.url (event = 0x7f1040401330)
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|application/x-mswinurl decoder|decoder-application/x-mswinurl
(09:28:59) [0x1648500] [missing_plugins_event] rb-missing-plugins.c:226: gst_install_plugins_async() result = 200
(09:28:59) [0x1648500] [rhythmdb_process_metadata_load] rhythmdb.c:2402: processing missing plugins
[...]

Changed in rhythmbox:
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Confirmed, it looks for plugins for m3u and url files with

Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|audio/x-mpegurl decoder|decoder-audio/x-mpegurl
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|application/x-mswinurl decoder|decoder-application/x-mswinurl

but it doesn't for .txt files and there's nothing on the log it just add an import error.

Evgeny Kuznetsov (nekr0z) wrote :

Pedro, what about
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox-metadata|Декодер text/html|decoder-text/html
Rhythmbox-Message: No installation candidate for missing plugins found.
?

If that's not "looking for plugins for .txt files", then what is?

Pedro Villavicencio (pedro) wrote :

Evgeny, please read the log file you had provided, it says: (07:32:12) [0x269f500] [rhythmdb_process_metadata_load] rhythmdb.c:2392: missing plugins during metadata load for file:///home/evgeny/music/%D0%97%D0%B0%D1%85%D0%B0%D1%80%20%D0%9C%D0%B0%D0%B9/2004%20%D0%91%D0%B5%D0%B7%20%D0%B0%D0%BD%D1%81%D0%B0%D0%BC%D0%B1%D0%BB%D1%8F/06%20%D0%9D%D0%B0%D1%85%D1%83%D0%B9!.mp3 (event = 0x4193a80) that's why you get that message, the .txt file is not taking into consideration:

(07:35:33) [0xa3d700] [rb_metadata_load] rb-metadata-gst.c:1018: loading metadata for uri: file:///home/evgeny/music/The%20Beatles/1967%20Sgt.%20Pepper's%20Lonely%20Hearts%20Club%20Band/What%20is%20UHQR.txt
(07:35:33) [0xa3d700] [rb_metadata_load] rb-metadata-gst.c:1073: going to PAUSED for metadata, uri: file:///home/evgeny/music/The%20Beatles/1967%20Sgt.%20Pepper's%20Lonely%20Hearts%20Club%20Band/What%20is%20UHQR.txt
(07:35:33) [0xa3d700] [rb_metadata_load] rb-metadata-gst.c:1098: failed to go to PAUSED for file:///home/evgeny/music/The%20Beatles/1967%20Sgt.%20Pepper's%20Lonely%20Hearts%20Club%20Band/What%20is%20UHQR.txt
(07:35:33) [0x269f500] [rhythmdb_add_import_error_entry] rhythmdb.c:2148: adding import error for file:///home/evgeny/music/The%20Beatles/1967%20Sgt.%20Pepper's%20Lonely%20Hearts%20Club%20Band/What%20is%20UHQR.txt: Невозможно установить тип MIME файла

Thanks.

summary: - Rhythmbox tries to find a codec for a text file
+ Rhythmbox tries to find a codec for a m3u/html file
Evgeny Kuznetsov (nekr0z) wrote :

Thanks for pointing that out, Pedro. But there seems to be more of a bug then: Rhythmbox doesn't seem to know what it's searching for. See screenshot, it definitely thinks it looks for text/html.

Alexey Osipov (lion-simba) wrote :

Confrim this bug.
I've made a list of MIME-types, which rhythmbox tries search decoders for. Here it is:

application/x-7z-compressed
audio/x-mpegurl
audio/x-riff
audio/x-imelody
text/html
application/x-mswinurl
audio/x-scpls
application/rtf

It's very annoying clicking Cancel button multiple time EVERY TIME you launch rhythmbox. So I think this bug's importance should be elevated to "medium" at least.

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue after today gstreamer update?

Evgeny Kuznetsov (nekr0z) wrote :

Sebastian, if "today gstreamer update" is, for example, gstreamer0.10-plugins-base ver. 0.10.22-5, then it doesn't fix the issue. Otherwise the update you're taking about didn't hit the mirrors yet.

lloydlloyd (lloydlloyd) wrote :

I've noticed this same problem. Getting a message searching for "application/rtf decoder" codec.

Changed in rhythmbox (Ubuntu):
assignee: desktop-bugs → robert-ancell
Sebastien Bacher (seb128) wrote :

the issue is not a duplicate no, the other bug is about a valid request, a codec required not being available where this one is about mimetypes which are not multimedia formats and should not request any codec

Robert Ancell (robert-ancell) wrote :

I've tried the following an am unable to reproduce:
1. Create a new music folder ~/Music2
2. Open Rhythmbox and point it at this folder and set it to watch
3. Delete ~/.local/share/rhythmbox and start Rhythmbox (no issues)
4. Repeat 3 with the file Evgeny attached (no issues)
5. Repeat 3 after adding 2 MP3 files (no issues)
6. Repeat 3 after adding test.m3u which contains the names of the two MP3 files (no issues)
7. Repeat 3 after modifying test.m3u to have a thousand lines (no issues)

Observed behaviour:
Rhythmbox opens and short time later shows the correct MP3 tracks detected

I have (latest Jaunty):
rhythmbox 0.12.0-0ubuntu4
gstreamer 0.10.22-5

Can someone confirm they get the issue with the above versions and attach the minimum number of files required to trigger this problem. Please also attach ~/.local/share/rhythmbox/rhythmdb.xml if this is occuring.

Robert: glad you try to tackle that, at last! ;-)

I've a few logs that can be interesting to you, with a file triggering this. See attached log excerpt, where you can find:
(09:57:12) [0x8cd1408] [rhythmdb_add_import_error_entry] rhythmdb.c:2148: adding import error for [FILE1]: Empty file
(09:57:12) [0x8cd1408] [rhythmdb_entry_new] rhythmdb.c:1613: emitting entry added
[...]
(09:57:12) [0xa01dc60] [rb_metadata_bus_handler] rb-metadata-gst.c:946: message of type state-changed from id3demux0
(09:57:12) [0xa01dc60] [rb_metadata_bus_handler] rb-metadata-gst.c:946: message of type state-changed from id3demux0
(09:57:12) [0xa01dc60] [rb_metadata_handle_missing_plugin_message] rb-metadata-gst.c:864: got missing-plugin message from decodebin: gstreamer|0.10|rhythmbox-metadata|ID3 tag demuxer|decoder-application/x-id3
(09:57:12) [0xa01dc60] [rb_metadata_bus_handler] rb-metadata-gst.c:884: got error message from decodebin
(09:57:12) [0xa01dc60] [rb_metadata_bus_handler] rb-metadata-gst.c:900: caught error: A ID3 tag demuxer plugin is required to play this stream, but not installed.
(09:57:12) [0xa01dc60] [rb_metadata_load] rb-metadata-gst.c:1098: failed to go to PAUSED for [FILE2]
(09:57:12) [0xa01dc60] [rb_metadata_get_missing_plugins] rb-metadata-gst.c:1513: adding [gstreamer|0.10|rhythmbox-metadata|ID3 tag demuxer|decoder-application/x-id3,ID3 tag demuxer] to return data

So you can see that an empty MP3 file seems to trigger the problem, and the other one is actually corrupt, only 2,1KB, and I cannot read ID3 tag from it. I attached it too, that can be a useful testcase.

Robert Ancell (robert-ancell) wrote :

Thanks Milan, copying that MP3 to ~/Music2 causes the problem for me.

Evgeny Kuznetsov (nekr0z) wrote :

Robert, I'm sorry for the inconvenience I've caused. The file I've attached (I originally believed that was the file causing problems) appeared to be not connected to this issue. The described behaviour in my case was caused by a couple of MP3s that were downloaded incorrectly (there were 404 pages instead of mp3s in those files), and the files provided by Milan are a good illustration for the case.

Robert Ancell (robert-ancell) wrote :

Evgeny, no problem! Your effort is greatly appreciated.

The information we have here is making me think the issue is relating to corrupted files where rhythmbox/gstreamer is going "I can't decode this file, so I must not have a valid decoder" instead of "I can't decode this file, so it must be corrupt". If anyone has a file which is a valid track/playlist etc but causes the codec dialog to appear please attach.

Robert, have you tried with an empty .mp3 file? On my setup, it seemed to be sufficient to trigger this kind of "invalid MP3 file" case - which is obviously ridiculous!

Robert Ancell (robert-ancell) wrote :

Milan, I tried:
$ touch ~/Music2/empty.mp3
$ rhythmbox
but it correctly marks it as a failed import and doesn't trigged the codec dialog for me.

Robert Ancell (robert-ancell) wrote :

I've linked this to the upstream report which has a comment about the same thing ocurring:
http://bugzilla.gnome.org/show_bug.cgi?id=537113

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Changed in rhythmbox:
status: Unknown → New
Robert Ancell (robert-ancell) wrote :

Rhythmbox reports this is a problem in the GStreamer 'decodebin' module. Rhythmbox is planning to switch to 'decodebin2' which does not have this problem.

Has the problem:
gst-launch-0.10 -tm filesrc location=broken.mp3 ! decodebin ! fakesink silent=true

Doesn't have the problem:
gst-launch-0.10 -tm filesrc location=broken.mp3 ! decodebin2 ! fakesink silent=true

Changed in rhythmbox (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in rhythmbox:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug is fixed upstream now

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Triaged → Fix Committed
john mall (mantikor) wrote :

Hello Sebastian,

rhythmbox under karmic koala 9.10 is still asking for the:

- ID3 tag demuxer-
and a
- rfc822 decoder-

plugin. Is that fixed in the karmic package too?

apt-cache policy show me:

rhythmbox:
  Installed: 0.12.2-0ubuntu2
  Candidate: 0.12.2-0ubuntu2
  Version table:
 *** 0.12.2-0ubuntu2 0

/lprofil

john mall (mantikor) wrote :

Hello Sebastian,

rhythmbox under karmic koala 9.10 is still asking for the:

- ID3 tag demuxer-
and a
- rfc822 decoder-

plugin. Is that fixed in the karmic package too?

apt-cache policy show me:

rhythmbox:
  Installed: 0.12.2-0ubuntu2
  Candidate: 0.12.2-0ubuntu2
  Version table:
 *** 0.12.2-0ubuntu2 0

No, the bug is marked as "Fix committed", which means that the package with the fix has not yet been released in Karmic. That will come with the next version of Rhythmbox.

This is now fixed in karmic with the update of rhythmbox to version 0.12.3-1ubuntu1. Closing the bug.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Evgeny Kuznetsov (nekr0z) wrote :

Excuse me, Martin, perhaps, this here is not the proper place to ask this question, but how can the bug be closed while there is still a fully supported Ubuntu version (9.04) suffering from this bug, and the fix was not backported to it?

Sebastien Bacher (seb128) wrote :

bugs are closed when fixed in the current unstable version, a jaunty task can be added if the version is a candidate for a jaunty upload too

This bug might qualifie for a Stable Release Update (SRU) (https://wiki.ubuntu.com/StableReleaseUpdates#Procedure) since it seems to be an annoying regression that is only present in Jaunty, as the reporter states.

I will have a look at the code which is responsible for getting this fixed and report back.

Ok...It should not be too hard to get this fix into jaunty. I made a debdiff which includes the necessary changes to prevent the plugin installer from being started for files which are not "audio-only". Accordingly nominating the bug for jaunty and subscribing the sponsors for main.

Note for the sponsors:
I was suffering from the bug when trying it with the file the reporter provided. After applying the patch, the annoying plugin installer has gone (of course only for files that are not "audio-only")

The diff is about 2500 lines and seems to do very much, but there are only changes in the "metadata" folder and something of the code was moved to "rhythmdb/rhythmdb.c".

Given that the patch fixes something very annoying and penetrating that disturb the user experience, I think it qualifies for SRU.

Sorry, I should have subscribed ubuntu-sru instead of ubuntu-main-sponsors.

Martin Pitt (pitti) wrote :

This just seems to be a corner case, doesn't cause data loss, and the proposed patch is very intrusive and thus regression prone. I don't feel that this is a good SRU candidate according to https://wiki.ubuntu.com/StableReleaseUpdates#When .

Reopening, the broken MP3 I provided some time ago still triggers the problem in Karmic. I've reported that upstream.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
affects: rhythmbox (Ubuntu) → gstreamer0.10 (Ubuntu)

The fix in GStreamer is available with decodebin2, Rhythmbox should switch to it at some point.

affects: gstreamer0.10 (Ubuntu) → rhythmbox (Ubuntu)
linex83 (linex83) wrote :

This bug is still not fixed in 9.04, how come?

angelogia (angelogia) wrote :

This bug is still not fixed in Karmic and Rhythmbox 0.12.5

stevepb (steveb-dude) wrote :

I can confirm this bug in Jaunty Jackalope 9.04.
Some .mp3 files trigger the error message :

Missing plugin: gstreamer|0.10|rhythmbox-metadata|application/x-mswinurl decoder|decoder-application/x-mswinurl

And does not play.

I have also identified another issue, perhaps I should report this as a seperate BUG.

META information of some music files is displayed incorrectly and a different song is played.
All META data is valid in the library, however does not match up with the file that actually plays.

colinjones (colin-a-jones) wrote :

I can confirm that this bug is still not fixed karmic/rb 0.12.5 it triggers the same messages on every start up for my .id3 files (used by another media player, moving them is not an option!). Whether it is using either filenames or filetypes, surely it can't be that hard to provide the option to tell it to ignore certain files when they are first encountered? In the .local/share/rhythmbox/rhythmdb.xml it already seems to be doing this for files like desktop.ini, why can this not be extended?

The problem is known upstream and will be fixed at some point, hope this can be in Lucid. Some files aren't read correctly with the current GStreamer libs, developers upstream plan to move to decodebin2 for metadata, which is known to fix the problem.

darren (darrenm) wrote :

March, almost Lucid beta and the id3 tag demuxer bug still isn't fixed in Rhythmbox. It's the default music player in the distro so it's kind of embarrassing that such an obvious bug still exists.

ninjai (steve-staticg) wrote :

I can confirm with darren on this. And I agree, it is pretty embarrassing. I've updated and updated and still no fix.

So close, and yet so far.

I have been giving Ubuntu 10.04 beta 2 a test drive, hoping to use it at work (and finally break free from Windows!)

Two days in to a delightful experience (my word, Lucid is sexy!), I ran in to this bug.

After battling with half a dozen other media players, I discovered that Rhythmbox is miles ahead of them all... save for this one fatal flaw. Since I use this feature on an almost daily basis, back to Windows I go, disappointed and defeated.

I can put up with a lot of rough edges, but I gotta have my tunes.

Dale: Use the workaround. I'm rather concerned about people that won't find out this temporary solution, but you can easily escape this bug.

Elly (elaineci37) wrote :

What's the workaround? I'm still getting this bug on my Ubuntu 10.04 beta_amd64.

John R (john-maxpower) wrote :

Still in Lucid, but the workaround is to just remove the gnome-codec-install package:

sudo apt-get remove --purge gnome-codec-install

Next time you start Rhythmbox - it shouldn't prompt you for any codecs. You'll probably have all of the codecs you need by now anyway...

Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.