Most mp3 files listed with "Unknown" length

Bug #334082 reported by Arancaytar on 2009-02-24
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

TESTCASE:
1) Add files from comments #4 and #21 in the collection
2) Search for these files (search terms: "Greensleeves" and "Beowulf")
3) Check track length

Result: track length is 'Undefined'
Expected Result: track lengths are 0:49 and 0:56

--- Original Report ---
Binary package hint: rhythmbox

After scanning my music folder with rhythmbox, about half of the mp3 tracks in the library are listed as having a length and bitrate of "Unknown". The files play without any problem, but while they are playing, the slider does not move.

I've played and indexed these same files in Songbird, WinAmp, iTunes, VLC and WMP, none of which had any related issues, so this is more likely to be a rhythmbox bug than file corruption.

1.) OS release: Ubuntu 8.10
2.) rhythmbox version: 0.11.6svn20081008-0ubuntu4.3
3.) Playable, uncorrupted MP3 files should be displayed with their correct length
4.) A large portion (about half) of MP3 files do not have a length listed.

If needed, I can provide a small, self-made MP3 file that exhibits this problem.

ProblemType: Bug
Architecture: i386DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.6svn20081008-0ubuntu4.3
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: rhythmbox
Uname: Linux 2.6.27-11-generic i686

Arancaytar (arancaytar) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you add a mp3 example to the bug? Could you also run "dpkg -l | grep gst" and add the log the bug to show codecs are installed?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

could you also run "gst-launch -t playbin uri=file:///directory/example/sound" and copy the log to the bug?

Arancaytar (arancaytar) wrote :
Download full text (3.4 KiB)

Here's the dpkg output:

ii bluez-gstreamer 4.12-0ubuntu5 Bluetooth gstreamer support
ii gstreamer0.10-alsa 0.10.21-3 GStreamer plugin for ALSA
ii gstreamer0.10-ffmpeg 0.10.5-1 FFmpeg plugin for GStreamer
ii gstreamer0.10-fluendo-mpegdemux 0.10.15-1 GStreamer plugin for demuxing of MPEG2 strea
ii gstreamer0.10-gnomevfs 0.10.21-3 GStreamer plugin for GnomeVFS
ii gstreamer0.10-plugins-bad 0.10.8-1 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-base 0.10.21-3 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-apps 0.10.21-3 GStreamer helper programs from the "base" se
ii gstreamer0.10-plugins-good 0.10.10.4-1ubuntu1 GStreamer plugins from the "good" set
ii gstreamer0.10-plugins-ugly 0.10.9-1ubuntu0.1 GStreamer plugins from the "ugly" set
ii gstreamer0.10-pulseaudio 0.10.10.4-1ubuntu1 GStreamer plugin for PulseAudio
ii gstreamer0.10-schroedinger 1.0.5-1 GStreamer plugin for encoding/decoding of Di
ii gstreamer0.10-tools 0.10.21-4 Tools for use with GStreamer
ii gstreamer0.10-x 0.10.21-3 GStreamer plugins for X11 and Pango
ii libgstreamer-plugins-base0.10-0 0.10.21-3 GStreamer libraries from the "base" set
ii libgstreamer0.10-0 0.10.21-4 Core GStreamer libraries and elements
ii python-gst0.10 0.10.13-1 generic media-playing framework (Python bind
ii synfigstudio 0.61.08-1build1 vector-based 2D animation package (graphical
ii totem-gstreamer 2.24.3-0ubuntu1 A simple media player for the GNOME desktop

Here's the log of playing the attached mp3 file:

FOUND TAG : found by element "id3demux0".
          artist: Arancaytar
            date: 2007-01-01
           album: Greensleeves
                : TCO
FOUND TAG : found by element "mpegaudioparse0".
     audio codec: MPEG 1 Audio, Layer 3 (MP3)
FOUND TAG : found by element "mpegaudioparse0".
         bitrate: 128000
         has crc: TRUE
    channel mode: mono
FOUND TAG : found by element "mad0".
           layer: 3
            mode: mono
        emphasis: none
         bitrate: 128000
New clock: GstAudioSinkClock
Got EOS from element "playbin0".
Execution ended after 49107522634 ns.

And the stderr output, just in case that's needed:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipe...

Read more...

Sebastien Bacher (seb128) wrote :

do you get the issue if you uninstall gstreamer0.10-fluendo-mpegdemux?

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Jan (jankap) wrote :

I've reopened this thread again, because i have this bug, too.

I'm using Ubuntu 9.04 up to date.

gstreamer0.10-fluendo-mpegdemux is not even installed here.

mp3info displays the correct lenght, but rhythmbox does not.

If you need infos, just ask, I'll answer :)

Changed in rhythmbox (Ubuntu):
status: Invalid → Incomplete
Jan (jankap) wrote :

I need to make an addition: It only occurs if i play the files from a mapped CIFS share. Maybe the problem is not in rhythmbox..

Jan (jankap) on 2009-05-12
Changed in rhythmbox (Ubuntu):
status: Incomplete → New
Said Babayev (phoenix49) wrote :

It also happens when playing local files.

JF (jfuchs) wrote :

I have the same Problem with a new Ubuntu 9.04 (64bit) Installation
For all my MP3s (all local) the time is shown as unknown. I can play the MP3 files but the seekbar cant be set to middle of the song for example. OGG is working fine. Also I can play the MP3s fine with totem and there i can set the seekbar...

Loic Dreux (loic.dreux) wrote :

I've same problem.

Selmi (selmi) wrote :

same problem and also maybe because of 'uknown' length my mp3 tracks never get scrobbled to lastfm

Selmi (selmi) wrote :

if everything works, now it should attach more information collected by 'report problem', i hope it will help

Selmi (selmi) wrote :

same problem in ubuntu 9.10 (rhytmbox 0.12.5)

Sebastien Bacher (seb128) wrote :

could you run dpkg -l | grep gstreamer?

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Selmi (selmi) wrote :

here it is

Sebastien Bacher (seb128) wrote :

do you get the issue on local mp3 files too there?

Selmi (selmi) wrote :

all are local, they sit on my diskdrive. same thing happens if iplay from cd. i can send some mp3 as example if needed

Sebastien Bacher (seb128) wrote :

would be nice to have an example on the bug indeed

Selmi (selmi) wrote :

mp3 file which doesn't work properly with rhytmbox. both bitrate and length are not detected

Sebastien Bacher (seb128) wrote :

do you get the correct informations in totem or the same issue?

Selmi (selmi) wrote :

in totem it works. according to about box its version 2.28.1 using GStreamer 0.10.25

Sebastien Bacher (seb128) wrote :

the example you added works fine on karmic in a guest session there, rhythmbox lists 0:56 and play it correctly

Sebastien Bacher (seb128) wrote :

could you try in a guest session too? does gst-launch playbin2 uri=... has the same issue?

Sebastien Bacher (seb128) wrote :

you might want to add -v to get details about the file when playing it or use rhythmbox --debug

Selmi (selmi) wrote :

i wasn't able to start gues session (fglrx drivers...) but i deleted all rhytmbox config files and launched it from clean state - and everything works correctly since then.

unfortunately i didn't thought about making backup of original settings to find out what was wrong. probably some cached information was incorrect. now its too late

however problem is solved, rhytmbox works. thanks

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
StevoSn (cornelius) wrote :

Hey, I have got the same problem as described above.. There are some mp3 files in my rhythmbox database without time information. Result is, that you can play those songs but you cannot set the seekbar.
I had a look at the RB xml-configuration files. Among others there is ~/.local/share/rhythmbox/rhythmbox.xml. I figured out that the duration of these songs is also missing there.
meaning that the whole entry <duration>111</duration> is missing.

I tried to find the difference between those songs with no probs and the faulty ones, but couldn't see anything.
I used mp3info to read the file information and everything seems to be just fine.
After that I did a backup of the file rhythmbox.xml and started RB again.. the database was empty and RB started to scan my music folder.. the same happend again. and actually, now even more files are without the duration information. Imho this means that there's only a faulty scanning process, but no corrupt mp3 files.

I also tried
> rhythmbox -d but the output had nothing todo with this issue..

so long...

StevoSn (cornelius) on 2010-01-14
Changed in rhythmbox (Ubuntu):
status: Invalid → Incomplete
Nigel Babu (nigelbabu) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu development version, this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs relevant for this particular issue.

I have this problem too, but I've found something interesting which may help figure out what's going on. Steps to reproduce:

1. Find an affected song in the collection, where the duration is "Unknown" in the Time column.
2. Right-click, choose Properties.
3. Modify at least one of the tags (e.g. Title, Artist, Album, etc.) so that Rhythmbox is forced to write it to the song file.
4. Click close - Rhythmbox will write the tags, and in doing so, re-calculate the duration correctly.
5. Play the song. You may need to start playing another song first, then play the modified one.
6. Seeking should now work correctly.

There are a few possibilities and speculations:

1. The tags in the file are corrupt, and Rhythmbox is rewriting the tag header correctly, which allows it to correctly calculate the song length. This is unlikely however, since I've been quite meticulous with my tag curation in Amarok 1.4 and Ex Falso over the past few years.
2. Because the songs were not imported into the collection using Rhythmbox (they were simply indexed from a collection managed by Amarok 1.4), the indexing may not have been doing the duration calculation correctly, or at all, for some files.

I have tested this on files that I know beforehand have valid ID3v2 tags and the durations and seeking works correctly in Amarok 1.4

Running Lucid amd64, possibly relevant packages from dpkg -l:

ii rhythmbox 0.12.8-0ubuntu1
ii rhythmbox-plugin-cdrecorder 0.12.8-0ubuntu1
ii rhythmbox-plugin-coherence 0.12.8-0ubuntu1
ii rhythmbox-plugins 0.12.8-0ubuntu1
ii rhythmbox-ubuntuone-music-store 0.0.8-0ubuntu1

ii gstreamer0.10-alsa 0.10.28-1
ii gstreamer0.10-ffmpeg 0.10.10-1
ii gstreamer0.10-gnonlin 0.10.15-1
ii gstreamer0.10-nice 0.0.10-2build1
ii gstreamer0.10-plugins-bad 0.10.18-1ubuntu1
ii gstreamer0.10-plugins-base 0.10.28-1
ii gstreamer0.10-plugins-base-apps 0.10.28-1
ii gstreamer0.10-plugins-good 0.10.21-1ubuntu2
ii gstreamer0.10-plugins-ugly 0.10.14-1
ii gstreamer0.10-pulseaudio 0.10.21-1ubuntu2
ii gstreamer0.10-tools 0.10.28-1
ii gstreamer0.10-x 0.10.28-1
ii libgstreamer-plugins-base0.10-0 0.10.28-1
ii libgstreamer0.10-0 0.10.28-1

ii ffmpeg 4:0.5.1-1ubuntu1
ii libavcodec-extra-52 4:0.5.1-1ubuntu1+medibuntu1
ii libavdevice-extra-52 4:0.5.1-1ubuntu1+medibuntu1
ii libavfilter-extra-0 4:0.5.1-1ubuntu1+medibuntu1
ii libavformat-extra-52 4:0.5.1-1ubuntu1+medibuntu1
ii libavutil-extra-49 4:0.5.1-1ubuntu1+medibuntu1
ii libpostproc-extra-51 4:0.5.1-1ubuntu1+medibuntu1
ii libswscale-extra-0 4:0.5.1-1ubuntu1+medibuntu1

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
UnknownSam (bsp52nd) wrote :

Me to was affected by this bug. I'm running lucid lynx.
Installing ubuntu-extras-restricted helped me.

I have my mp3's on Samba server which is then mapped on each of my computers.

Laptop with 10.4 works fine, all tracks have durations - no issues at all.

Desktop with 10.4 has tracks with missing duration and bitrate.

As you expect mp3info shows correct duration on one of those files. I have tried editing the ID3 tags with EasyTag and Rhythmbox but no change.

Hope this helps

Oh, Desktop was an upgraded install not a fresh install as it was with the laptop.

However I did create a new home folder for this user to no stored settings.

cschol (cschol2112) wrote :

I had the same problem in Lucid Lynx. Rhythmbox 0.12.8 would not show duration "Unknown" and disable the slider bar.

However, installing

gstreamer0.10-plugins-ugly

fixed the problem.

I confirmed this by uninstalling gstreamer0.10-plugins-ugly, which brought back the behavior, and installing it again, which fixed it.

Zortrox (zortrox) wrote :

I might have found a quick fix to this problem. NOTE: I have Ubuntu 10.04 (Lucid) x64.

1. In Synaptic Package Manager install "gstreamer0.10-fluendo-plugins-mp3-partner". It is an enhanced MP3 codec file.
2. Install EasyTag. In Terminal "sudo apt-get install easytag" (without quotes).
3. Once it's downloaded, go to the program in the Application menu (under Sound & Video).
4. Navigate to your music library and select every file in it (Ctrl + A).
5. Click File -> Save File(s) (Or just click Ctrl + S).
6. FIXED!!

Iván Campaña (ivan-campana) wrote :

Zortrox solution is not quite quick if you have a lot of files, but yes it works, after that all songs show the correct length...

Download full text (3.2 KiB)

Hi,

I had the same problem on Ubuntu 10.04 64 bits desktop edition.
Every audio files sits on a NTFS type of partition. Some files duration are tagged "unknown" and others are the correct length shown.
I resolved the problem by deleting the media DB file : ~/.local/share/rhythmbox/rhythmdb.xml so the next time rhytmbox is started it have to rebuild the DB. That new import is showing lenght correctly, for all audio files without exception. So there was a problem during the initial and first build of the DB (maybe at that time my environment missed a codec or something needed by rhytmbox to do the job correctly??).

You'll see above some dpkg -l to see installed version of softwares. You'll also find a copy of the corrupted rhythmdb.xml in attached file.

Here is the output of "dpkg -l | grep gstrea"
ii bluez-gstreamer 4.60-0ubuntu8 Bluetooth GStreamer support
ii gstreamer0.10-alsa 0.10.28-1 GStreamer plugin for ALSA
ii gstreamer0.10-ffmpeg 0.10.10-1 FFmpeg plugin for GStreamer
ii gstreamer0.10-gnonlin 0.10.15-1 non-linear editing module for GStreamer
ii gstreamer0.10-nice 0.0.10-2build1 ICE library (GStreamer plugin)
ii gstreamer0.10-plugins-bad 0.10.18-1ubuntu1 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-base 0.10.28-1 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-apps 0.10.28-1 GStreamer helper programs from the "base" se
ii gstreamer0.10-plugins-good 0.10.21-1ubuntu2 GStreamer plugins from the "good" set
ii gstreamer0.10-plugins-ugly 0.10.14-1 GStreamer plugins from the "ugly" set
ii gstreamer0.10-pulseaudio 0.10.21-1ubuntu2 GStreamer plugin for PulseAudio
ii gstreamer0.10-tools 0.10.28-1 Tools for use with GStreamer
ii gstreamer0.10-x 0.10.28-1 GStreamer plugins for X11 and Pango
ii libgstreamer-plugins-base0.10-0 0.10.28-1 GStreamer libraries from the "base" set
ii libgstreamer0.10-0 0.10.28-1 Core GStreamer libraries and elements

and "dpkg -l | grep rhy"
ii rhythmbox 0.12.8-0ubuntu4 music player and organizer for GNOME
ii rhythmbox-plugin-cdrecorder 0.12.8-0ubuntu4 burning plugin for rhythmbox music player
ii rhythmbox-plugins 0.12.8-0ubuntu4 plugins for rhythmbox music player
ii rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1 Ubuntu One Musi...

Read more...

Mahmoud Tantawy (mtantawy) wrote :

installing gstreamer0.10-plugins-ugly
then re adding the files to the library works, now the duration & seeking works
why isn't that installed by default since it is needed?

I had the same problem and it appears that it specifically affected files that were marked as executable.
When I ran chmod -x on the mp3, Rhythmbox calculated the duration correctly.

Although it didn't help the fact that I still cannot seek some of those files...

I did the same as comment #38, which was to delete my db file and have Rhytombox reimport everything. It seems that gstreamer0.10-plugins-ugly is needed to have the correct information, and that isn't available on install.

Vadim Rutkovsky (roignac) wrote :

Can't reproduce anymore in Rhythmbox 2.90.1~20110908-0ubuntu1. Length was correctly identified for sample files from comment #4 and #21.

Please, change bug status to New, if the problem is still reproducible for affected users

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
tags: added: testcase
description: updated
Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
flix (felix-hess) wrote :

Ubuntu 14.04 32bit also is affected by the bug. I use Rhythmbox 3.0.2 and about 1/3 of my music library is shown as length "unknown". When I look into the rhytmdb.xml the titles with unknown length don't have a <duration>-tag.

I removed the rhythmdb.xml and started rhythmbox from scratch with a music library with 11 mp3-titles. Initially 3 of them showed an unknown length. Then I manually removed all three <entry type="song">-entries which had no <duration>-tag from the database. Afterwards I restarted rhythmbox, the three titles where readded by rhythmbox and suddenly had the correct length.

For me it looks like a bug in rhythmbox which sometimes does not write the duration-tag to its database.

flix (felix-hess) wrote :

I just wrote a python skript which removes all defect entries (which have no duration tag) from rhythmbox's database. Store the script to your home directory, close rhythmbox and open a terminal. Run the following commands:
chmod u+x repairRhythmDb.py
./repairRhythmDb.py
mv .local/share/rhythmbox/rhytmdb.xml ./backupRhythmDb.xml
mv repaired_rhythmdb.xml .local/share/rhythmbox/rhythmdb.xml

Restard rhythmbox. It will add all files which have been removed because of their missing duration. Hopefully all of them will appear with a correct length afterwards. If not just run the last three commands again (while rhythmbox is closed).
With the help of the script my database of about 10,000 audio files was fixed after two runs.

Interesting fact: while coding the script I deleted the rhythmdb.xml-file an started rhythmbox to regenerate it. Suddenly only about 1% had a missing length. Yesterday I ended up with 30% of the files with missing duration. I can't remember any software change between yesterday and today.

Changed in rhythmbox (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers